当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 设置3d桌面出现错误,我这样解决的
帖子发表于 : 2008-11-03 12:37 

注册: 2008-10-11 8:12
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
偶是个windows老鸟,却是linux菜鸟,只是偶尔体验一下,安装了个ubuntu8.10玩玩。
昨晚设置3d桌面出现错误,花屏,然后自动回到登录界面,输入用户名和密码之后,花屏,然后又重新进入登陆界面,反复如此,不
能进入桌面。于是采取以前的老办法,在登录届面点左下角的 选项/会话/安全模式下的终端。

  输入以下命令:

  gconf-editor

  找到Desktop->Goname->Application->windows_manager;
找到:current和default,两个键值都是/usr/bin/compiz;
把两处/usr/bin/compin改成/usr/bin/metacity。

按Cltrcol+Alt+backspace退回登录届面,选项/会话/Gnome,成功进入到桌面,一切正常,但所有的3d设置均已失效,于是便重新设

置,但不小心又设置坏了,犯了与前次同样的毛病,就是花屏后反复退回到登录界面,无法进入桌面。这次我再进入到安全模式终端

,企图重新设置current和default键,但在设置current时意外点错了,居然将“编辑”点成了“设为强制值”,成了灰色的不可修

改了。只好单独把default键修改了一下,但返回登录界面输入用户名和密码后,仍然出现原来的毛病,花屏无法进入桌面,这下可

坏了。这时,我忽然想起已经开启了root用户登录,于是便用root进入安全模式下的终端,但遗憾的是,current键仍然无法修改了,键值

成了灰色的。无奈之下,用root用户进入到桌面,将正常使用的用户删除,然后又建了一个相同名称的用户,设置一番后,如愿回到

桌面。
告诉新手们,设置3D桌面一定要小心啊,不然容易犯大错,到时后悔就晚了,幸运的是我开启了root用户。这也说明开启root用户的
好处啊。
现在请教,我还能不能把设置成强制值的current键值改回来吗?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 设置3d桌面出现错误,我这样解决的
帖子发表于 : 2009-03-09 13:49 

注册: 2009-03-08 23:20
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
:em20
老兄我也遇到了同样的问题,可是按照你说的做了,还是没有解决啊。
请老兄帮忙啊!!!!!!!!!!!!!!!!!!!!!
小弟将不胜感激啊!!!!!!!!!!!!!!!!!!


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 设置3d桌面出现错误,我这样解决的
帖子发表于 : 2009-03-09 13:53 
头像

注册: 2007-07-30 18:28
帖子: 22033
地址: 空气中
系统: Linux
送出感谢: 17
接收感谢: 68
3D那种东西删除就好了。


_________________
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 设置3d桌面出现错误,我这样解决的
帖子发表于 : 2009-04-07 14:24 

注册: 2009-04-05 16:04
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
我也出现这样的问题,按照你这种方法还是解决不了,还有其他的方法吗?急啊!谢谢了!
我的两个参数 current 是metacity
default是usr/bin/metacity

然后我把两个都改为usr/bin/metacity,重新ctrl+alt+backspace后进入gnome,后还是会像原来那样。我有打开 gconf-editor, 发现那个current值又自动变回metacity了。
实在没辙了,各位帮帮忙。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 设置3d桌面出现错误,我这样解决的
帖子发表于 : 2009-05-04 20:35 

注册: 2009-03-06 22:55
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
我按照LZ的方法把两处/usr/bin/compin改成/usr/bin/metacity仍不能解决,我执行 以下网上高手写的命令
sudo apt-get remove compizconfig-settings-manager
sudo apt-get remove emerald
sudo apt-get remove fusion-icon
把3D桌面干掉了。
可以正常登录了。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 设置3d桌面出现错误,我这样解决的
帖子发表于 : 2010-10-14 16:48 

注册: 2010-06-29 8:26
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
对于强制值,我也试过,如何清除,参考http://apps.hi.baidu.com/share/detail/2193205


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译