当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 用源码在ubuntu 8.04.1上安装 compiz-fusion 0.7.8
帖子发表于 : 2008-11-05 11:52 

注册: 2008-11-05 11:46
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
ubuntu 8.10终于在10月30日正式发布了,怀着迫切的心情下载了ubuntu 8.10的dvd版,(这个链接是官方链接,最近特慢估计是下载的人太多)并安装了一下,但非常遗憾。没有我的显卡受限驱动(nvidia gforce2 mx400),打开受限驱动里是空的。也就意味着不能玩3d特效了,失望中。
要知道在ubuntu 8.04 和 8.04.1里的默认compiz-funsion是0.7.4的。里面没有将桌面变圆柱形和球体的特效。当然可以使用源安装0.7.6里面带有该特效。

顺便说一下安装0.7.6吧,其实只要打开“源管理”里的“添加第三方源”。

deb http://ppa.launchpad.net/compiz/ubuntu hardy main

然后关闭,就会提示你是否要更新选择是就会自动更新,然后打开“更新管理器”系统就会自动发现更新的资源点更新就行了。

虽然有0.7.6,但是对于我这种想看看新鲜东西的人就不满足了。而ubuntu没有compiz-fusion 0.7.8针对ubuntu 8.04的deb包(提醒各位8.10里的包在8.04里是安装不了的,除非你想重装系统,否则你最好不要去尝试)。

现在唯一的途径就是自己去下载源代码来安装了。

1.现在首先准备一个干净的ubuntu 8.04.1系统(安装了compiz-funsion其他版本的系统我没试过是否可以成功)。

2.打开终端使用命令 sudo apt-get remove compiz* 将系统清扫一下。

3.到compiz-fusion的官方网站http://releases.compiz-fusion.org/0.7.8下载0.7.8的包,注意里面带有两种打包形式gz包和bz2包,你只要下载一种就可以了。(有cmake字样的压缩包也不要下载)

4.按照官方的说法要安装一些包,使用如下命令

sudo apt-get install build-essential libxcomposite-dev libpng12-dev libsm-dev libxrandr-dev libxdamage-dev libxinerama-dev libstartup-notification0-dev libgconf2-dev libgl1-mesa-dev libglu1-mesa-dev libmetacity-dev librsvg2-dev libdbus-1-dev libdbus-glib-1-dev libgnome-desktop-dev libgnome-window-settings-dev gitweb curl autoconf automake automake1.9 libtool intltool libxslt1-dev xsltproc libwnck-dev python-dev python-pyrex

安装好这些包

5.这步是关键,官方网站里也没提到,其实干净的系统里还缺少一些包

i.首先要到debian下载如下两个最新的包

http://ftp.debian.org/debian/pool/main/libx/libx11/libx11_1.1.5-1.diff

http://ftp.debian.org/debian/pool/main/libx/libx11/libx11_1.1.5.orig.tar

ii.将以上两个包解压到一个目录下,将libx11_1.1.5.orig.tar包解压

iii.在终端中输入如下命令

sudo apt-get build-dep libx11-6
cd libx11_1.1.5 // 进入libx11_1.1.5.orig.tar包解压后的目录(cd后的路径视你的实际情况而定)
gunzip -c ../libx11_1.1.3-1.diff.gz | patch -p1 // libx11_1.1.3-1.diff.gz 文件于libx11_1.1.5.orig.tar包解压后的文件夹在同一目录下
chmod +x debian/rules
fakeroot debian/rules binary // 注意该步骤可能会提示你要安装fakeroot你只要使用sudo apt-get install fakeroot安装后再执行该步该步骤执行时间挺长大概要十几二十分钟
cd .. // 退回到libx11_1.1.5的上级目录(你会发现该目录下生成了几个deb包,有150多M)
sudo dpkg -i libx11*deb // 安装生成的deb包

安装完这些包后编译就不会出错了。

6.将compiz-fusion的官方网站下载的包解压缩(注意在这里我们不使用带有cmake字样的压缩包)

按照以下顺序(文件夹中带的字样,非全称)

compiz

bcop

libcompizconfig

compizconfig-python

ccsm

compiz-fusion-plugins-main

在终端分别进入解压后的包里执行以下命令进行编译安装

./configure --prefix=/usr
make
sudo make install

但是注意在进入ccms时要执行这个命令而不是使用以上命令

sudo python setup.py install
其他包的顺序就无所谓了。

7.最后用命令

git clone git://anongit.opencompositing.org/users ... usion-icon

下载fusion-icon的包

再进入该包使用

make

sudo make install

安装好该包

(不打开该程序的话3d效果无法显示,在菜单“应用程序”“系统工具”中可以打开该程序)



好了,重新启动。现在大功告成了。这个3d效果比0.7.4多了前面的圆柱圆球效果外还多了个所谓“养鱼”和一个雪花效果。不过少了“动画”效果,也就是说没了燃烧飞机等等,不过据说是另分了类,有弄出来的说一下吧,呵呵!对了最后来张截图(背后为雪花效果)
附件:
文件注释: 截图
Screenshot.png
Screenshot.png [ 175.53 KiB | 被浏览 2043 次 ]


参考:http://wiki.compiz-fusion.org/Installation
附件:
文件注释: 8.10雪花截图
Screenshot1.png
Screenshot1.png [ 1.37 MiB | 被浏览 1949 次 ]



最后由 luojxun 编辑于 2008-11-06 19:14,总共编辑了 7 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 用源码在ubuntu 8.04.1上安装 compiz-fusion 0.7.8
帖子发表于 : 2008-11-05 12:09 

注册: 2008-11-05 11:46
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
以上是本人在ubuntu8.04.1安装compiz-fusion 0.7.8的过程 :em09
不过不知道怎么没有了“动画”这一项,据说8.10里是有的,有一项里面有个神灯和纸飞机图标。而以上方法安装没有。有知道使用什么可以弄出来的也请分享一下 :em11


最后由 luojxun 编辑于 2008-11-06 7:53,总共编辑了 2 次

页首
 用户资料  
 
3 楼 
 文章标题 : Re: 用源码在ubuntu 8.04.1上安装 compiz-fusion 0.7.8
帖子发表于 : 2008-11-05 22:10 

注册: 2008-11-05 11:46
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
:em06 :em06
终于搞定了gf2 mx400的nvidia的官方驱动

原来不要到官方提供的页面去下,那只能下到NVIDIA-Linux-x86-96.43.07-pkg1.run,这个版本不对。应该下NVIDIA-Linux-x86-96.43.09-pkg1.run,使用google可以搜到官方下载地址。不过安装后系统里的字会模糊。

:em09 :em09


最后由 luojxun 编辑于 2008-11-06 19:16,总共编辑了 2 次

页首
 用户资料  
 
4 楼 
 文章标题 : Re: 用源码在ubuntu 8.04.1上安装 compiz-fusion 0.7.8
帖子发表于 : 2008-11-05 22:34 

注册: 2008-11-05 11:46
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
要有“养鱼”和“雪花”特效,可以使用新立得查找
compiz-fusion-plugins-unsupported
安装完后就有了。不过似乎不能使用。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 用源码在ubuntu 8.04.1上安装 compiz-fusion 0.7.8
帖子发表于 : 2008-11-06 10:08 

注册: 2008-11-05 11:46
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
今天的受限驱动里有了gf2 mx400的驱动了 :em11 :em11


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 用源码在ubuntu 8.04.1上安装 compiz-fusion 0.7.8
帖子发表于 : 2008-11-06 11:12 

注册: 2008-11-05 11:46
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
compiz-fusion-plugins-unsupported ubuntu8.10里带的不能用。要用源码安装
http://releases.compiz-fusion.org/0.7.8处下载,compiz-fusion-plugins-unsupported-0.7.8.tar.gz和compiz-bcop-0.7.8.tar.gz。注意要先安装compiz-bcop-0.7.8.tar.gz。

只需要在终端分别进入解压后的包里执行以下命令进行编译安装就可以了 :em09 :em09
./configure --prefix=/usr
make
sudo make install


最后由 luojxun 编辑于 2008-11-08 8:37,总共编辑了 1 次

页首
 用户资料  
 
7 楼 
 文章标题 : Re: 用源码在ubuntu 8.04.1上安装 compiz-fusion 0.7.8
帖子发表于 : 2008-11-06 19:18 

注册: 2008-11-05 11:46
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
:em09 :em09 如果要在8.04.1里有“动画”效果
可以到 http://gitweb.opencompositing.org/ 去下载插件


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 用源码在ubuntu 8.04.1上安装 compiz-fusion 0.7.8
帖子发表于 : 2008-11-09 12:15 

注册: 2008-10-03 22:44
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
我的安装完simple-ccsm 后 更改桌面背景-视觉效果-自定义-首选项-动画-enable extra animations 打上勾 就有了燃烧什么的特效了 是英语的 自己一个一个试试


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 用源码在ubuntu 8.04.1上安装 compiz-fusion 0.7.8
帖子发表于 : 2008-11-15 7:53 
头像

注册: 2007-07-11 21:43
帖子: 3382
地址: 东江边
系统: archlinux
送出感谢: 15
接收感谢: 7
我自己编辑下雪插件, ./configure --prefix=/usr得到如下出错信息:
hecking for COMPIZ... configure: error: Package requirements (compiz) were not met:

No package 'compiz' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables COMPIZ_CFLAGS
and COMPIZ_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


dkg-config要如何改啊?


_________________
我来了,我看见了,我征服了!
求勾搭,不管饭。


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 用源码在ubuntu 8.04.1上安装 compiz-fusion 0.7.8
帖子发表于 : 2009-01-23 14:10 

注册: 2005-12-04 17:46
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
刚安成功
新装的8.04.2 按照楼主的方法

libX11-xcb 我是打开新立得搜索后那3个都装上
楼主提供的地址无法下载
现在正在找资料设置3D桌面呢
:em01


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 用源码在ubuntu 8.04.1上安装 compiz-fusion 0.7.8
帖子发表于 : 2009-01-23 15:04 

注册: 2005-12-04 17:46
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
compiz-fusion-plugins-extra-0.7.8
compiz-fusion-plugins-unsupported-0.7.8
这2个包也要下来 要不特效不全

解压后进入目录 安装命令也是
./configure --prefix=/usr
make
sudo make install


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 用源码在ubuntu 8.04.1上安装 compiz-fusion 0.7.8
帖子发表于 : 2009-04-07 20:04 

注册: 2008-09-14 9:44
帖子: 38
地址: 广东汕头
送出感谢: 0 次
接收感谢: 0 次
恩,很不错,可以了 :em05


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 用源码在ubuntu 8.04.1上安装 compiz-fusion 0.7.8
帖子发表于 : 2009-05-09 7:17 

注册: 2008-11-05 11:46
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
9楼的错误提示就是因为编译时需要的一些包没有安装。
现在的9.04不用如此麻烦,可以在新立得里搜索compiz把后面带有dev的包安装上,使用git clone得到包后分别使用make clean, make, make install就可以了。 :em09 :em09


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Exabot [Bot] 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译