当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 开了个效果 结果登陆崩溃
帖子发表于 : 2008-11-05 17:19 

注册: 2008-11-02 22:40
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
如题 桌面高级选项中开了个效果 结果一登陆就花屏 然后就自动退出来

不是只能重装才能解决吧

高手们


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 开了个效果 结果登陆崩溃
帖子发表于 : 2008-11-05 17:27 
头像

注册: 2008-08-29 21:31
帖子: 1051
送出感谢: 0 次
接收感谢: 2
你设置了compiz自动启动了,把自动启动取消后就可以正常进桌面了。
按Alt+Ctrl+F1进字符界面,然后登录。
登录后输入:
cd ~/.config/autostart
把该目录下compiz的启动项删除就行了。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 开了个效果 结果登陆崩溃
帖子发表于 : 2008-11-05 17:50 
头像

注册: 2008-07-19 12:44
帖子: 3437
地址: 广西(桂)南宁(邕)
送出感谢: 0 次
接收感谢: 76
初学者会在字符界面用命令的不多,提示一下,删除命令是 “ rm 文件名 "


_________________
一善鱼 yq-ysy@163.com

音频数字工作站 Ardour 4 初学者教程  影视特效3D动画 Blender 2.5~2.6 完全教程  图像处理 Krita 3 数字绘画入门


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 开了个效果 结果登陆崩溃
帖子发表于 : 2008-11-05 23:52 

注册: 2008-04-24 13:05
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
我也有同样的问题
但是~/.config/autostart下
没有关于compiz启动的entry
该如何处理呢?

一怒之下把compiz移除了

其实只要移除
~/.config/compiz
~/.gconf/apps/compiz
这两处可能错误的compiz配置文件
并让compiz重新生成初始配置文件一般就能解决问题了
希望对lz有帮助


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 开了个效果 结果登陆崩溃
帖子发表于 : 2008-11-06 10:15 

注册: 2008-10-21 9:37
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
luyunting 写道:
我也有同样的问题
但是~/.config/autostart下
没有关于compiz启动的entry
该如何处理呢?

一怒之下把compiz移除了

其实只要移除
~/.config/compiz
~/.gconf/apps/compiz
这两处可能错误的compiz配置文件
并让compiz重新生成初始配置文件一般就能解决问题了
希望对lz有帮助


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 开了个效果 结果登陆崩溃
帖子发表于 : 2008-11-07 11:13 
头像

注册: 2008-07-19 12:44
帖子: 3437
地址: 广西(桂)南宁(邕)
送出感谢: 0 次
接收感谢: 76
试试这样:在登录介面,按ctrl+alt+F1打开终端登录(虚拟机也许按键有所不同),
或者以单用户模式登录,然后输入下列命令,然后重启:
touch $HOME/.config/compiz/disable-compiz (如果想禁止开机自启动compiz)
rm $HOME/.config/compiz/disable-compiz (如果想开机自启动compiz)
如果是有$HOME/..config/autostart/emerald.desktop文件就删掉,命令是:
rm $HOME/..config/autostart/emerald.desktop (如果想禁止开机自启动emerald)
以上方法是参考网上国外论坛的例子。


_________________
一善鱼 yq-ysy@163.com

音频数字工作站 Ardour 4 初学者教程  影视特效3D动画 Blender 2.5~2.6 完全教程  图像处理 Krita 3 数字绘画入门


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 开了个效果 结果登陆崩溃
帖子发表于 : 2008-11-30 15:52 

注册: 2008-11-02 22:40
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
哥哥们 你们说的我都试了
都行不通


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 开了个效果 结果登陆崩溃
帖子发表于 : 2008-11-30 16:54 
头像

注册: 2005-10-25 13:54
帖子: 272
送出感谢: 0 次
接收感谢: 0 次
yq-ysy 写道:
试试这样:在登录介面,按ctrl+alt+F1打开终端登录(虚拟机也许按键有所不同),
或者以单用户模式登录,然后输入下列命令,然后重启:
touch $HOME/.config/compiz/disable-compiz (如果想禁止开机自启动compiz)
rm $HOME/.config/compiz/disable-compiz (如果想开机自启动compiz)
如果是有$HOME/..config/autostart/emerald.desktop文件就删掉,命令是:
rm $HOME/..config/autostart/emerald.desktop (如果想禁止开机自启动emerald)
以上方法是参考网上国外论坛的例子。

照上面所说内容修改后,重启X。方法是输入
sudo /etc/init.d/gdm restart
你不会输命令就按ctrl+alt+F7切回图形界面,然后按ctrl+alt+backspace键,重启登录界面
仔细检查你运行的结果,上面的仁兄所写的操作已经把compiz全部特效关闭。如果仍不好使,就不是桌面特效的问题,有可能与你的显卡驱动有关了。检查你的操作,看看你做没做到上述操作。如果没成功就上来说不好用。你还是重装算了。

另外,说一下你安装的compiz是系统自带的,还是卸载系统自带后重装的。两者配置方法略有不同。


_________________
Full Circle中文杂志 | Ubuntu社区独立发行的电子月刊
http://www.freeearth.org.cn


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 开了个效果 结果登陆崩溃
帖子发表于 : 2008-11-30 17:09 
头像

注册: 2008-08-29 21:31
帖子: 1051
送出感谢: 0 次
接收感谢: 2
pason 写道:
哥哥们 你们说的我都试了
都行不通


哥们,上面几个回帖包括了禁止compiz自启动、完全删除用户的compiz配置、完全禁用compiz等诸多方法,你居然说不行?怀疑你根本没有正确操作,或者你的显卡驱动没装好。
再说下去我只能建议你把compiz完全删除了。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译