保存xorg.conf时报错

GnomeShell/Unity/Beryl/AiGLX/XGL/Compiz Fusion
回复
heiljsf
帖子: 83
注册时间: 2007-06-11 10:56
送出感谢: 0
接收感谢: 0

保存xorg.conf时报错

#1

帖子 heiljsf » 2008-12-22 22:28

/etc/X11/xorg.conf

Failed to parse existing X config file '/etc/X11/xorg.conf'!
头像
ws_105
帖子: 313
注册时间: 2008-10-24 8:02
送出感谢: 0
接收感谢: 0

Re: 保存xorg.conf时报错

#2

帖子 ws_105 » 2008-12-23 13:45

是不是语法写错了?
Ubuntu 8.04 @ Intel Pentium D 925 + Intel 945G Chipset + DDR2 1.0G + SATA 160G
http://hi.baidu.com/ws_105
maochunlei
帖子: 32
注册时间: 2008-08-12 15:23
送出感谢: 0
接收感谢: 0

Re: 保存xorg.conf时报错

#3

帖子 maochunlei » 2008-12-24 0:07

我这里也有这个问题,我的解决方法:在保存的时候,选择领存,然后,自己sudo cp进去,替换原来那个,就行了。嘿嘿~ :em06 :em06
头像
yq-ysy
论坛版主
帖子: 3572
注册时间: 2008-07-19 12:44
来自: 广西(桂)南宁(邕)
送出感谢: 0
接收感谢: 77 次

Re: 保存xorg.conf时报错

#4

帖子 yq-ysy » 2008-12-24 8:59

如果是权限问题,简单,用root身份修改xorg.conf文件就行了。
图形介面的终端下用命令: sudo gedit /etc/X11/xorg.conf
纯终端下用命令: sudo vim /etc/X11/xorg.conf
heiljsf
帖子: 83
注册时间: 2007-06-11 10:56
送出感谢: 0
接收感谢: 0

Re: 保存xorg.conf时报错

#5

帖子 heiljsf » 2008-12-24 9:33

= = 上面办法都用过.... 还是不行
头像
ws_105
帖子: 313
注册时间: 2008-10-24 8:02
送出感谢: 0
接收感谢: 0

Re: 保存xorg.conf时报错

#6

帖子 ws_105 » 2008-12-24 19:09

Ubuntu 8.04 @ Intel Pentium D 925 + Intel 945G Chipset + DDR2 1.0G + SATA 160G
http://hi.baidu.com/ws_105
头像
anly_cg
帖子: 10
注册时间: 2008-12-12 22:30
送出感谢: 0
接收感谢: 0

Re: 保存xorg.conf时报错

#7

帖子 anly_cg » 2008-12-24 21:32

连接:原创:分享ubuntu8.10显示器分辨率和刷新率问题终级解决(图解)
viewtopic.php?f=94&t=174785

应用程序-附件-终端,打开使用命令: sudo gedit /etc/X11/xorg.conf
/etc/X11/xorg.conf里Ubuntu 8.10原装系统正确文件资料如下:
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection


(备注:把原来的清空,粘上我发的原文件保存后退出重启,这时已经修改成功! :em11
heiljsf
帖子: 83
注册时间: 2007-06-11 10:56
送出感谢: 0
接收感谢: 0

Re: 保存xorg.conf时报错

#8

帖子 heiljsf » 2008-12-25 10:18

= = 试过了,无效! 正是替换之后,报的这个~
头像
coolvir
帖子: 32
注册时间: 2009-08-21 0:17
送出感谢: 0
接收感谢: 0

Re: 保存xorg.conf时报错

#9

帖子 coolvir » 2009-11-19 13:53

各位哥们,不是那么回事的,试试这个办法,如下:
sudo nvidia-xconfig
sudo nvidia-settings
修改你想要的参数,保存吧。会OK的!
原因在于9.10刚安装完时并没有使配置文件初始化,所以通不过解释,用nvidia-xconfig重新创建后就可以了.
祝大家愉快! :em09
看风雨,知世情!
头像
tenzu
论坛版主
帖子: 36913
注册时间: 2008-11-21 20:26
送出感谢: 0
接收感谢: 21 次

Re: 保存xorg.conf时报错

#10

帖子 tenzu » 2009-11-19 13:57

11个月后才有了正确答案么?
头像
coolvir
帖子: 32
注册时间: 2009-08-21 0:17
送出感谢: 0
接收感谢: 0

Re: 保存xorg.conf时报错

#11

帖子 coolvir » 2009-11-19 14:37

呵呵,又看见TENZU了,还真以为你跑去ARCH混日子了呢!
看风雨,知世情!
头像
xinen007
帖子: 159
注册时间: 2008-05-28 21:32
来自: 豫南小苏州
送出感谢: 0
接收感谢: 0
联系:

Re: 保存xorg.conf时报错

#12

帖子 xinen007 » 2009-11-20 8:14

1.

代码: 全选

sudo rm /etc/X11/xorg.conf
这一步很重要
2.调整好后点Apply,然后点 save to X Configuration File,弹出一个窗口,然后点show preview 把你看到的内容复制下来
3.打开终端 sudo gedit /etc/X11/xorg.conf 粘贴上你刚复制的内容,最后保存即可。
免费vpn,翻墙必备-->http://vcup.in/j9a
------------------------------------------------------→

320G/2G
Intel core i3 330M 2.13GHz
Nvidia GT 325M 128bit/512M

Ubuntu 10.04+VMware 7.1.0
头像
xjwlove
帖子: 94
注册时间: 2009-02-15 16:48
来自: 湖南省永州
送出感谢: 0
接收感谢: 0
联系:

Re: 保存xorg.conf时报错

#13

帖子 xjwlove » 2009-11-25 0:57

问世间情为狗屎,直叫人上厕所不带纸
记录生活点点滴嘀,点击进入我的博客
dzq0371
帖子: 14
注册时间: 2009-11-29 21:12
送出感谢: 0
接收感谢: 0

Re: 保存xorg.conf时报错

#14

帖子 dzq0371 » 2010-04-21 23:28

问题解决,特别感谢 xinen007 :em11
回复

回到 “桌面特效”