当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 成功驱动NVIDIA 9300M GS !
帖子发表于 : 2009-03-23 3:14 
头像

注册: 2007-07-12 15:57
帖子: 63
地址: JLU
送出感谢: 0 次
接收感谢: 0 次
快三点了都..总算能够和自己说声辛苦了
这张卡可是驱动了我好几天了....
来说说具体过程吧
在8.04的时候, 这个卡直接用glx驱动就OK,我也没想多少
到了8.10, 就有问题了, 总是驱不上, 一选受限驱动就出错进不了X+当机
官方驱动也没有任何成效
后来看到网上说, 如果需要装官方驱动, 那么要在/etc/default/linux-restricted-modules-common这个文件里面加上DISABLED_MODULES="nv nvidia_new"
于是照做了一下,怀着惴惴的心情purge卸载了glx的一切,以及nvidia-kernel-common
开始安装180.29官方驱动,结果还是一样, 但是好多了,提示我一段话
引用:
failed to initialize the nvidia kernel module! please ensure that there is a supported nvidia GPU in this system and
that the nvidia device files have been created properly, please consult the nvidia readme for details.
screen(s) found, but none have a usable configuration


看到这个之后大概想到的是xorg.conf出错, 进去看了一眼
有苗头, 这时候sudo su到root用户之后,运行Xorg -configure, 生成一个根据本机配置写出的xorg.conf.new
接着X -config ~/xorg.conf.new(生成在root的家目录下)
让我欣喜的是出现了一个我没见到过的错误,告诉我screen找不到, 而不是没有配置文件了
打开xorg.conf.new,再打开原来没有驱动时使用的xorg.conf进行比对
发现xorg.conf里面有这样的字样
引用:
Screen "Default Screen"
Monitor "Configured Monitor"


而在新生成的xorg.conf.new里面却是这样的
引用:
Screen "Screen0"
Monitor "Configured Monitor"


这很明显是根据生成规则生成的字段,而不是根据本地信息生成的
将xorg.conf.new里面的内容修改成xorg.conf里的样子, 再次Xorg -config ~/xorg.conf.new

万恶的源头出现了
提示我说我的预编译内核是180.22的,而我的驱动是180.29的,不匹配(这里要谴责NVIDIA的人了,在官方安装的时候,installer提示我它会帮我编译一个适合这个驱动的内核, 可是编译出来的是180.22的)!
现在的我已经接近胜利了
卸载180.29, 安装180.22, reboot
心里打鼓, 肚里打鼓(饿的), 不一会, 到了正常死机的地方, 结果NVIDIA那支大眼睛出现了
我在心里喊万岁, 昨天NVIDIA工程师帮我一个晚上都没有解决, 今天被我误打误撞给搞定了!
现在可以好好睡一觉了, 以后看numb3rs不用在把窗口缩成一点点了

这里感谢bigsnake.net,是他的一个提示(上面提到的)让我走出困境, 我在学校bbs上的签名也是copy他的

请访问我的博客:山高路远


_________________
不要跳来跳去,要学的还很多
http://johnnnny.blogspot.com


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 成功驱动NVIDIA 9300M GS !
帖子发表于 : 2009-03-23 8:25 
头像

注册: 2007-07-11 21:43
帖子: 3382
地址: 东江边
系统: archlinux
送出感谢: 15
接收感谢: 7
我也一样的显卡,每次都安装成功了啊。


_________________
我来了,我看见了,我征服了!
求勾搭,不管饭。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 成功驱动NVIDIA 9300M GS !
帖子发表于 : 2009-03-23 8:41 
头像

注册: 2007-07-12 15:57
帖子: 63
地址: JLU
送出感谢: 0 次
接收感谢: 0 次
momova 写道:
我也一样的显卡,每次都安装成功了啊。

不知道了, 我就是驱不上, 受限的每用必死。。


_________________
不要跳来跳去,要学的还很多
http://johnnnny.blogspot.com


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 成功驱动NVIDIA 9300M GS !
帖子发表于 : 2009-04-19 1:34 

注册: 2006-08-15 20:16
帖子: 42
送出感谢: 0 次
接收感谢: 0 次
兄弟,请把你的XORG.CONF文件发上来好吗?
或者发到我邮箱:none4978@hotmail.com

谢谢:)


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 成功驱动NVIDIA 9300M GS !
帖子发表于 : 2009-04-19 1:39 

注册: 2006-08-15 20:16
帖子: 42
送出感谢: 0 次
接收感谢: 0 次
我的显卡也是9300M GS,但一直安装不能驱动,我确认官方驱动已经安好,但一直不能自动配置

这是我现在的配置,只能调整分辨率,好像是驱动没加载成功

我也试着把驱动改成NVIDIA,但一直不起作用,所以只好先用VESA的,至少还能看个1280的分辨率......
谢谢!

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection


Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
EndSection
Section "Device"
Identifier "Configured Video Device"
Boardname "vesa"
Busid "PCI:1:0:0"
Driver "vesa"
Screen 0
EndSection

Section "Monitor"
Identifier "Configured Monitor"
Vendorname "Generic LCD Display"
Modelname "LCD Panel 1280x1024"
Horizsync 31.5-64.0
Vertrefresh 56.0 - 65.0
modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
modeline "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
modeline "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
Defaultdepth 24
SubSection "Display"
Depth 24
Virtual 1280 800
Modes "800x600@60" "1024x768@60" "800x600@56" "1280x960@60" "640x480@60" "1280x1024@60"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
Inputdevice "Synaptics Touchpad"
EndSection
Section "Module"
Load "glx"
Load "GLcore"
Load "v4l"
EndSection
Section "device" #
Identifier "device1"
Boardname "vesa"
Busid "PCI:1:0:0"
Driver "vesa"
Screen 1
EndSection
Section "screen" #
Identifier "screen1"
Device "device1"
Defaultdepth 24
Monitor "monitor1"
EndSection
Section "monitor" #
Identifier "monitor1"
Gamma 1.0
EndSection
Section "ServerFlags"
EndSection


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 成功驱动NVIDIA 9300M GS !
帖子发表于 : 2009-04-19 16:21 

注册: 2007-11-19 18:27
帖子: 87
送出感谢: 0 次
接收感谢: 0 次
我也是9300
用官网下的驱动一次装好 不过还是有浏览器切换标签和滚动页面卡的情况


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 成功驱动NVIDIA 9300M GS !
帖子发表于 : 2009-04-20 19:34 

注册: 2006-08-15 20:16
帖子: 42
送出感谢: 0 次
接收感谢: 0 次
tyin 写道:
我也是9300
用官网下的驱动一次装好 不过还是有浏览器切换标签和滚动页面卡的情况



我的好像是沒加載成功

請發一個你的XORG.CONF文件給我好嗎?謝謝


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 成功驱动NVIDIA 9300M GS !
帖子发表于 : 2009-04-25 16:31 

注册: 2007-11-19 18:27
帖子: 87
送出感谢: 0 次
接收感谢: 0 次
后来重装了 不知道是显卡驱动问题还是 ext4问题 运行效率太低 软件切换都要灰好多秒

现在用jfs 和源里的nv180驱动 用了3天了 没什么问题了 就是启动不怎么稳定
不是每次启动都一个效果。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 成功驱动NVIDIA 9300M GS !
帖子发表于 : 2009-04-27 9:31 
头像

注册: 2007-08-14 17:30
帖子: 122
送出感谢: 0 次
接收感谢: 0 次
tyin 写道:
后来重装了 不知道是显卡驱动问题还是 ext4问题 运行效率太低 软件切换都要灰好多秒

现在用jfs 和源里的nv180驱动 用了3天了 没什么问题了 就是启动不怎么稳定
不是每次启动都一个效果。



启动不稳定?不是每次启动都一个效果?? 你是不是调什么东西了啊? 。。。。 :em04 :em04 :em04 嘿嘿。。。新本本的“第一次”被UBUNTU给开 封了。。。。


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 成功驱动NVIDIA 9300M GS !
帖子发表于 : 2009-04-27 10:05 

注册: 2006-08-15 20:16
帖子: 42
送出感谢: 0 次
接收感谢: 0 次
成功了,昨天更新了一下主板BIOS就OK啦,呵呵

謝謝大家


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 成功驱动NVIDIA 9300M GS !
帖子发表于 : 2009-07-09 23:31 

注册: 2008-05-18 9:09
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
本人 9300 M G ,用nvidia 官方的185.18.14驱动,完美驱动,个人感觉比较180.22有很大的效果提升,特别是开启compiz fusion后。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:leafseelight 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译