当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 26 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 我试装XGL出问题了,各位帮帮忙
帖子发表于 : 2006-09-19 18:55 

注册: 2006-09-14 22:40
帖子: 273
送出感谢: 0 次
接收感谢: 0 次
我按http://wiki.ubuntu.org.cn/Xgl_HowTo试装XGL结果一启动就花屏,完全看不见,请问是我装的时候出错还是我的显卡太烂,我的显卡是ATI Radeon 9250,装的是里面的Gnome Xgl,我看了http://gentoo-wiki.com/HARDWARE_Video_Card_Support_Under_XGL#ATI_Cards的说明好像我的显卡能装啊,不过我的英文太烂,看不太懂,各位帮我看看,如果能装的话告诉我一下装那个要注意什么吗?我有完全按照那篇文章的说法做哦。还有顺便问各位KDE Xgl , Gnome Xgl 和XFCE Xgl有什么区别呢?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-09-20 4:57 
头像

注册: 2006-05-13 4:02
帖子: 10606
送出感谢: 0 次
接收感谢: 7
* Radeon 9250
o Chipset: RV280
o Driver: ATI Proprietary Version 8.26.18
o Notes: Tested on Ubuntu 6.06LTS (Dapper). Installation issues with via CVS, suggest using binaries and tutorial from https://help.ubuntu.com/community/CompositeManager/Xgl
我不建议用这个方法做,导致万一出错,连gnome都进不去。
看我的帖子:
http://forum.ubuntu.org.cn/viewtopic.ph ... highlight=
各种桌面下的xgl没有什么区别,都是XGL/compiz,只是设置上有所不同罢了。


_________________
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-09-20 14:09 

注册: 2006-09-14 22:40
帖子: 273
送出感谢: 0 次
接收感谢: 0 次
受到高手的帮助心里十分激动啊,我按照你的做法做了,可出现了我在您的贴子上回的内容:
http://forum.ubuntu.org.cn/viewtopic.ph ... 0&start=45 的第50楼那样的问题,于是论坛上的贴子:
http://forum.ubuntu.org.cn/viewtopic.ph ... 55&start=0 做,貌似正常了,按你的说法一步步做完,好像很成功,可重启后选XGL登录出现了那个效果只能出现几秒钟,好像是在右上角那个三角形的图标一出现效果就没了,而且也出现一些像注销后什么都看不见之类的情况,不知怎么解决,高人再帮看一下,谢谢哈。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-09-20 14:22 
头像

注册: 2006-05-13 4:02
帖子: 10606
送出感谢: 0 次
接收感谢: 7
你下载一个最新的ati驱动试试。
https://support.ati.com/ics/support/def ... olderID=27
找到合适你的显卡的驱动。最新的应该是8.28.8版本,是个.run文件。
我反正照他的做法是启动不了xgl的,输入fglrxinfo得到的是mesa,也就是没有3D加速。
我是自己编译的。不要怕,照做就行了。等我一下,我进ubuntu。


_________________
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-09-20 14:27 

注册: 2006-09-14 22:40
帖子: 273
送出感谢: 0 次
接收感谢: 0 次
我有照做,也没怕,有高人的指点怕什么。帮人帮到底哈,ATI的主页都是英文的我看不懂,你就再指深一点把下载的链接告诉我可以不?还有如果我要重装驱动要怎么办?怎么重装驱动,要按你的贴子的方法再做一次吗?


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-09-20 14:34 
头像

注册: 2006-05-13 4:02
帖子: 10606
送出感谢: 0 次
接收感谢: 7
我回来了。
我先把ati显卡的驱动编译过程告诉你,照做即可:
引用:
先把linux-restricted-modules中的fglrx模块屏蔽了
sudo gedit /etc/default/linux-restricted-modules-common


DISABLED_MODULES=""

改成
DISABLED_MODULES="fglrx"

解决安装ATI驱动的一些依赖关系
sudo apt-get update
sudo apt-get install module-assistant build-essential
sudo apt-get install fakeroot dh-make debconf libstdc++5 gcc-3.3-base

创建.deb
chmod +x ati-driver-installer-*.run
./ati-driver-installer-*.run --buildpkg Ubuntu/dapper


安装.deb
代码:
sudo dpkg -i xorg-driver-fglrx_*-1_i386.deb
sudo dpkg -i fglrx-kernel-source_*-1_i386.deb
sudo dpkg -i fglrx-control_*-1_i386.deb

删除以前的fglrx-kernel的deb
sudo rm /usr/src/fglrx-kernel*.deb

创建新的fglrx-kernel.deb
sudo module-assistant prepare
sudo module-assistant update
sudo module-assistant build fglrx
sudo module-assistant install fglrx
如果这句出错,用:
cd /usr/src
sudo dpkg -i fglrx-kernel-*.deb
sudo depmod -a

升级xorg.conf
sudo aticonfig --initial --input=/etc/X11/xorg.conf

重启
sudo reboot

重启完毕后先用
fglrxinfo
看看ATI的驱动是否安装完毕

然后再用
fgl_glxgears

glxgears -printfps
测试一下
fgl_glxgears结果一般在800以上(以9600为参考)
glxgears结果一般在4000以上(以9600为参考)
这样的话就是安装成功了

要是fglrxinfo的结果显示
fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.4.1)

请卸载驱动
sudo dpkg -r fglrx-control
sudo dpkg -r fglrx-kernel-source
sudo dpkg -r xorg-driver-fglrx

然后再安装


_________________
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-09-20 14:38 
头像

注册: 2006-05-13 4:02
帖子: 10606
送出感谢: 0 次
接收感谢: 7
把上面的照做一边,就安装好了最新的驱动。你的显卡是独立的么?是32位系统么?
如果是,下载地址:
https://a248.e.akamai.net/f/674/9206/0/ ... 8.28.8.run


_________________
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-09-20 15:06 

注册: 2006-04-23 16:00
帖子: 69
送出感谢: 0 次
接收感谢: 0 次
zhuqin_83 兄,我按照 你讲的方法一步一步做了, 可以进去,但是就像这位兄弟所说, 我看到效果还不到五秒钟就自动变会老的样子了,也是驱动的问题吗?


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-09-20 15:10 
头像

注册: 2006-05-13 4:02
帖子: 10606
送出感谢: 0 次
接收感谢: 7
jaye 写道:
zhuqin_83 兄,我按照 你讲的方法一步一步做了, 可以进去,但是就像这位兄弟所说, 我看到效果还不到五秒钟就自动变会老的样子了,也是驱动的问题吗?

你什么显卡?


_________________
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-09-20 15:11 

注册: 2006-04-23 16:00
帖子: 69
送出感谢: 0 次
接收感谢: 0 次
另外 ,我安装XGL后, 打fglrxinfo还是没有Xlib: extension "XFree86-DRI" missing on display ":1.0". 这个提示,是不是哪点有问题???

显卡是按照我自己的方法照好的,因为googleearth可以正常运行,所以驱动应该是装好了吧


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2006-09-20 15:18 

注册: 2006-04-23 16:00
帖子: 69
送出感谢: 0 次
接收感谢: 0 次
我的显卡是ATI Mobile 9200 (32M), 本本上的独立显卡,呵


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2006-09-20 15:19 

注册: 2006-04-23 16:00
帖子: 69
送出感谢: 0 次
接收感谢: 0 次
就是Compiz Theme setting不是有许多主风格主题吗?

不过我点哪个窗口都不发生变化,仍是以前 的GNOME风格,另外Compiz Manager 下的Select Windows Manager下它默认问题是Matecity, 我把它换成Compiz后, Selecte Window Decorator就变成灰色无法选择了, 其实窗口仍是没有任何变化,还是2D的。

有的时候,在刚刚启动XGL的前几秒, 有十分之一的情况下可以在前五秒中看到XGL的效果,然后就再也没有了。

还有就是当打开一个程序的时候, 窗口出现的会非常慢, 但一会就好了, 这又是怎么会事啊?


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2006-09-20 15:21 

注册: 2006-04-23 16:00
帖子: 69
送出感谢: 0 次
接收感谢: 0 次
至从加的源越来越多后,发现奇怪的事情, 它总提醒我升级OpenOffice,Linux-image之类的东西,我看了一下其实它要升级的版本和我机子里面的是一样的,奇怪, 是不是在source.list里面最好放一个源就行了!!


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2006-09-20 15:35 
头像

注册: 2006-05-13 4:02
帖子: 10606
送出感谢: 0 次
接收感谢: 7
jaye 写道:
至从加的源越来越多后,发现奇怪的事情, 它总提醒我升级OpenOffice,Linux-image之类的东西,我看了一下其实它要升级的版本和我机子里面的是一样的,奇怪, 是不是在source.list里面最好放一个源就行了!!

oo的话,不用管他,反正一直有问题。
linux-image是内核的更新。那个是必须的。
source.list不是一个源就可以的。但是现在好像清华和上交的源有问题,导致你的oo更新出错。
我反正只用官方的源。


_________________
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2006-09-20 15:37 

注册: 2006-04-23 16:00
帖子: 69
送出感谢: 0 次
接收感谢: 0 次
嗯。主要是用上交的源后就出现乱七八糟的问题了, LINUX-KERNER必须升级吗? 我看它和我系统里面的版本基本是一样的呀


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 26 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译