按论坛里的置顶贴安装beryl失败了,大家帮帮忙吧!!

GnomeShell/Unity/Beryl/AiGLX/XGL/Compiz Fusion
回复
kyree
帖子: 96
注册时间: 2006-09-12 13:03
送出感谢: 0
接收感谢: 0

按论坛里的置顶贴安装beryl失败了,大家帮帮忙吧!!

#1

帖子 kyree » 2006-10-07 20:45

按照论坛置顶贴的方法安装beryl,没有提示出现了什么问题,
ATI的显卡,驱动已经装好了。
安装结束,重启后任务栏也出现了beryl manager的图标。
窗口管理器选择beryl,窗口闪几下,还是出现老的GNOME的外观。
在Emerald管理器里选择外观根本就没有反应,不能应用的,为什么呢?

在登录时选择会话,还是只有GNOME的选项,

以前没玩过这么高级的东西,请大家帮帮忙吧。
谢谢了。
上次由 kyree 在 2006-10-07 21:53,总共编辑 1 次。
kyree
帖子: 96
注册时间: 2006-09-12 13:03
送出感谢: 0
接收感谢: 0

#2

帖子 kyree » 2006-10-07 21:11

代码: 全选

carter@carter-laptop:~$ beryl
XGL Absent, checking for NVIDIA
Nvidia Absent, assuming AIGLX
beryl: No composite extension

XGL没装?怎么装?
上次由 kyree 在 2006-10-07 22:31,总共编辑 1 次。
kyree
帖子: 96
注册时间: 2006-09-12 13:03
送出感谢: 0
接收感谢: 0

#3

帖子 kyree » 2006-10-07 21:26

display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON XPRESS 200M Series Generic
OpenGL version string: 2.0.5814 (8.25.18)
cocozsdo
帖子: 22
注册时间: 2005-05-27 18:09
送出感谢: 0
接收感谢: 0

#4

帖子 cocozsdo » 2006-10-07 23:07

坛子里这个帖不灵?
http://forum.ubuntu.org.cn/about26499.html

millboy_x写得很清楚的,要么可以到ubuntu官方社区提供的XGL安装方法
(E文,包括ATI,nv,intel等):

https://help.ubuntu.com/community/CompositeManager/Xgl

gnome,kde,xfce的设置都有,照猫画虎就是了。
caryl
帖子: 48
注册时间: 2006-09-29 9:16
送出感谢: 0
接收感谢: 0

#5

帖子 caryl » 2006-10-08 16:09

跟你遇到的问题一模一样,试了多种方法也没搞定。等。。。
头像
milkboy_x
帖子: 431
注册时间: 2006-06-13 11:02
来自: 广东 广州
送出感谢: 0
接收感谢: 0

Re: 按论坛里的置顶贴安装beryl失败了,大家帮帮忙吧!!

#6

帖子 milkboy_x » 2006-10-08 16:38

kyree 写了:安装结束,重启后任务栏也出现了beryl manager的图标。
窗口管理器选择beryl,窗口闪几下,还是出现老的GNOME的外观。
在Emerald管理器里选择外观根本就没有反应,


这么证明楼主的机器已经装好了Beryl,可是XGL还没有能正常启动。不知楼主是使用XGL的,还是AIGLX的?
本人的帖子已经对应ATI的更新了,请再看一下是否有帮助。
kyree
帖子: 96
注册时间: 2006-09-12 13:03
送出感谢: 0
接收感谢: 0

Re: 按论坛里的置顶贴安装beryl失败了,大家帮帮忙吧!!

#7

帖子 kyree » 2006-10-08 19:45

milkboy_x 写了:
kyree 写了:安装结束,重启后任务栏也出现了beryl manager的图标。
窗口管理器选择beryl,窗口闪几下,还是出现老的GNOME的外观。
在Emerald管理器里选择外观根本就没有反应,


这么证明楼主的机器已经装好了Beryl,可是XGL还没有能正常启动。不知楼主是使用XGL的,还是AIGLX的?
本人的帖子已经对应ATI的更新了,请再看一下是否有帮助。


你的帖子我看了,没看见有关于XGL的安装啊。XGL我也试着装过了,现在已经装乱了。有点晕,每次都进不去X,非要输入startx才可以进去。提示找不到/dev/wacom.
瘋掉了,改天重装一次吧。
lijzz
帖子: 196
注册时间: 2006-09-03 20:53
送出感谢: 0
接收感谢: 0

#8

帖子 lijzz » 2006-10-08 19:53

你按此说明试试,我的没问题:

http://forum.beryl-project.org/topic-48 ... -for-gnome
kyree
帖子: 96
注册时间: 2006-09-12 13:03
送出感谢: 0
接收感谢: 0

#9

帖子 kyree » 2006-10-10 22:10

搞定了,但是又坏了.
至少我成功过.是因为XGL没装造成的 :D
你笑我菜我承认.
yunxiao
帖子: 6
注册时间: 2006-09-24 18:18
送出感谢: 0
接收感谢: 0

大哥,你怎么搞定的

#10

帖子 yunxiao » 2006-10-11 18:05

大哥,你怎么搞定的,教我一下吧,我的问题和你出现的是一模一样啊
kyree
帖子: 96
注册时间: 2006-09-12 13:03
送出感谢: 0
接收感谢: 0

#11

帖子 kyree » 2006-10-12 20:10

哥们你是没装XGL啊.装上XGL就会好的.
我是按这个帖子装的,
http://forum.ubuntu.org.cn/viewtopic.php?t=24390

非常管用,瓢就在这里,自己画个葫芦吧:)
先装好显卡驱动!备份xorg-conf 和 gdm-conf 和一切将要编辑的文件.
说实在的,linux好容易崩溃啊,特别是X,要小心.
suime
帖子: 11
注册时间: 2006-10-16 19:51
来自: 重庆
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 suime » 2006-10-19 21:58

反正我这么干就搞定了
sudo ln -sf /usr/bin/Xgl /etc/X11/X

也就是将Xorg替换成了Xgl,虽然这样成功了,但是不知道有不有什么不妥的。
回复

回到 “桌面特效”