当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页

安装Beryl后,觉得Beryl如何?
很好,确实能够让linux更加容易使用! 68%  68%  [ 49 ]
一般般,可有可无。 15%  15%  [ 11 ]
的却有用,但是拖慢系统很多,郁闷! 10%  10%  [ 7 ]
完全没有需要,只是装饰品,我需要更加实际的东西!! 7%  7%  [ 5 ]
总计票数 : 72
作者 内容
1 楼 
 文章标题 : [调查]Beryl很多朋友都用上了吧?做个小小调查!
帖子发表于 : 2006-10-08 17:13 
头像

注册: 2006-06-13 11:02
帖子: 431
地址: 广东 广州
送出感谢: 0 次
接收感谢: 0 次
从观看XGL的演示视频,到使用open suse的3D桌面,到Ubuntu里面的XGL+compiz,到现在的Beryl,经过4个月的折腾。使用、升级、再使用,觉得compiz/Beryl是越来越成熟了,使用越来越简便了,特效越来越趋于实用了。
本人只是一个普通的不行了的电脑用户,平时电脑对于我就是上网+听歌+看片子+聊天,compiz/Beryl带给我使用linux时候的好处是明显的,更加华丽的界面,更加容易找寻的窗口。不知道各位已经使用compiz/Bery的朋友对它有什么看法,特此开贴调查一下。 :lol:


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-10-08 18:49 

注册: 2006-09-14 12:56
帖子: 58
送出感谢: 0 次
接收感谢: 0 次
呵呵,不好意思,借你的帖子问一下 ,我刚才照你说的运行了一下 glxinfo ,输出如下:
name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig
client glx vendor string: NVIDIA Corporation
client glx version string: 1.4
client glx extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_visual_info,
GLX_EXT_visual_rating, GLX_EXT_import_context, GLX_SGI_video_sync,
GLX_NV_swap_group, GLX_NV_video_out, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
GLX_SGI_swap_control, GLX_NV_float_buffer, GLX_ARB_fbconfig_float
GLX version: 1.2
GLX extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_SGIX_fbconfig, GLX_ARB_get_proc_address
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 6100/PCI/SSE2
OpenGL version string: 1.2 (2.0.2 NVIDIA 87.62)
OpenGL extensions:
GL_ARB_depth_texture, GL_ARB_imaging, GL_ARB_multitexture,
GL_ARB_point_parameters, GL_ARB_point_sprite, GL_ARB_shadow,
GL_ARB_texture_border_clamp, GL_ARB_texture_cube_map,
GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,
GL_ARB_window_pos, GL_ARB_texture_non_power_of_two, GL_ARB_vertex_program,
GL_ARB_fragment_program, GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color,
GL_EXT_blend_func_separate, GL_EXT_blend_minmax, GL_EXT_blend_subtract,
GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_multi_draw_arrays,
GL_EXT_packed_pixels, GL_EXT_rescale_normal, GL_EXT_secondary_color,
GL_EXT_separate_specular_color, GL_EXT_shadow_funcs, GL_EXT_stencil_wrap,
GL_EXT_texture3D, GL_EXT_texture_edge_clamp, GL_EXT_texture_env_add,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3, GL_EXT_texture_lod,
GL_EXT_texture_lod_bias, GL_EXT_texture_object, GL_EXT_vertex_array,
GL_ATI_texture_mirror_once, GL_HP_occlusion_test,
GL_IBM_texture_mirrored_repeat, GL_NV_blend_square,
GL_NV_texgen_reflection, GL_NV_texture_rectangle,
GL_NV_texture_env_combine4, GL_SGIS_generate_mipmap, GL_SGIS_texture_lod,
GL_SGIX_depth_texture, GL_SGIX_shadow
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x2c 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 0 0 None
0x2d 24 tc 0 32 0 r . . 8 8 8 8 0 0 0 0 0 0 0 0 0 None
0x2e 32 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 0 0 Ncon
0x2f 32 tc 0 32 0 r . . 8 8 8 8 0 0 0 0 0 0 0 0 0 Ncon


看不太明白,我的BREYL问题出在什么地方 ,、怎么启动不起来,帮帮我吧
还有 ,我的系统栏里边已经有了beryl setting manager 和emerald theme manager 这两个选项,可是无法启动 ,呵呵,还哟,我的emeral theme manager 是个绿的钻石,不知道为什么


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-10-08 21:41 

注册: 2006-07-09 12:22
帖子: 1331
地址: 南京
送出感谢: 0 次
接收感谢: 1
引用:
direct rendering: No

显卡加速不支持,需要安装新的驱动...


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-10-08 22:16 
头像

注册: 2006-06-13 11:02
帖子: 431
地址: 广东 广州
送出感谢: 0 次
接收感谢: 0 次
don-quixote 写道:
引用:
direct rendering: No

显卡加速不支持,需要安装新的驱动...

启动XGL后是会引起“direct rendering: No”,当然还是用nv驱动也会显示“direct rendering: No”,但是“OpenGL version string: 1.2 (2.0.2 NVIDIA 87.62) ”证明其实是已经装了nvidia的驱动了的。
还是检查Beryl的启动问题吧。


页首
 用户资料  
 
5 楼 
 文章标题 : 小结!!
帖子发表于 : 2006-10-10 11:42 
头像

注册: 2006-06-13 11:02
帖子: 431
地址: 广东 广州
送出感谢: 0 次
接收感谢: 0 次
截至10月10号早上11点,总的投票只有19票,难道用Beryl的人只有这么少了?还是没有能看到这个帖子? :?: :?:


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-10-10 20:39 

注册: 2005-07-28 9:31
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
不错不错~~~~!最大的好处就是可以很快速的说服我的朋友改用linux上网呵呵~非常吸引人呵呵!!


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-10-10 20:44 

注册: 2006-03-03 10:34
帖子: 34
送出感谢: 0 次
接收感谢: 0 次
比原先的Xgl+compiz慢,错误也多


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-10-13 17:43 

注册: 2006-09-16 13:16
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
搞了半天没搞定,放弃了


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-10-13 20:43 

注册: 2006-03-21 10:47
帖子: 406
送出感谢: 0 次
接收感谢: 0 次
nvidia最新的96.25beta驱动已经支持在beryl中实现 direct rendering 加速了,速度损失也不大,我已经在用了。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-10-13 21:32 
头像

注册: 2006-06-13 11:02
帖子: 431
地址: 广东 广州
送出感谢: 0 次
接收感谢: 0 次
gmlbh 写道:
nvidia最新的96.25beta驱动已经支持在beryl中实现 direct rendering 加速了,速度损失也不大,我已经在用了。


能给个下载的地址吗 :?: :?: :lol:


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2006-10-14 1:54 

注册: 2006-03-21 10:47
帖子: 406
送出感谢: 0 次
接收感谢: 0 次
nvidia beta driver:
http://www.nzone.com/object/nzone_downloads_rel70betadriver.html
这里是beryl官方的wiki:
http://wiki.beryl-project.org/index.php/Install/Ubuntu/Edgy/nVIDIA
和ubuntu官方论坛上的帖子:
http://ubuntuforums.org/showthread.php?t=263851
里面有两种安装方法,由于ubuntu官方编译的驱动还没出来,我是自己从第一个地址下的驱动,然后自己编译的。
自己编译的话要看清楚一下注意事项:
引用:
If you would prefer to install the nvidia drivers from nvidia's script, you may simply download the NVIDIA beta drivers from here, then:

代码:
sudo nano /etc/default/linux-restricted-modules-common

Add "nv" at the bottom. (no quotes)

Code:

sudo apt-get install linux-headers-`uname -r` build-essential gcc gcc-3.4 xserver-xorg-dev sudo apt-get --purge remove nvidia-glx nvidia-settings nvidia-kernel-common sudo rm /etc/init.d/nvidia-* sudo /etc/init.d/gdm stop sudo sh NVIDIA-Linux-x86-1.0-9625-pkg1.run sudo /etc/init.d/gdm start

And restart your computer. The Nvidia script should change your xorg.conf to enable nvidia drivers, so this will work without any previous nvidia drivers.

Remember that following this method requires a reinstillation of them every time the kernel changes.

这个在ubuntu官方的帖子里面有的,我摘出来是要特别提醒大家。
ps:楼上的,我也是广州的。 :D


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2006-10-14 9:13 
头像

注册: 2006-06-13 11:02
帖子: 431
地址: 广东 广州
送出感谢: 0 次
接收感谢: 0 次
gmlbh 写道:
nvidia最新的96.25beta驱动已经支持在beryl中实现 direct rendering 加速了,速度损失也不大,我已经在用了。


经查阅资料,仅限于Edgy里面使用Xorg7.1时实现direct rendering=YES,使用的是AIGLX。
Dapper里面用96.25beta驱动还没有尝试。


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2006-10-14 11:07 
头像

注册: 2006-05-03 0:39
帖子: 8273
地址: المريخ
送出感谢: 0 次
接收感谢: 1
很喜欢这个,稳定很多。

而且默认设置又美观又不花稍,爽极了!


_________________
PHP是最好的语言!不服来战!


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2006-10-14 14:55 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
因为没了render,q3不能全屏幕,游戏贴图有些色彩失真,被我禁止了。
整天来说,其他方面都非常好了。


_________________
● 鸣学


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2006-10-21 17:11 
头像

注册: 2006-10-16 7:24
帖子: 624
地址: 安康/西安/广州
送出感谢: 0 次
接收感谢: 0 次
我的AMD64系统,源里的好多东西感觉版本低啊,好像加了一个compiz的源后那里边的compiz要求依赖关系的软件包版本比源里能找到的最高版本高一点,寒一个,看来一时半会是用不上了


_________________
读书取正,读易取变,读骚取幽,读庄取达,读汉文取坚,最有味卷中岁月。
与菊同野,与梅同疏,与莲同洁,与兰同芳,与海棠同韵,定自称花里神仙。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:aukomn 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译