当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装beryl后无法使用google earth
帖子发表于 : 2006-10-21 12:07 

注册: 2006-10-11 20:41
帖子: 375
送出感谢: 0 次
接收感谢: 0 次
硬件: AMD 3000+/1G RAM/ATI X800(128M), @1600x1200x32
系统: Dapper/i386
按照论坛里的帖子顺利安装了beryl,运行相当流畅。glxgears的FPS在2300左右。
但启动google earth (beta 4)后就停在启动界面上,
最初安装dapper的时候也出现过这种情况,后来安装了ATI提供的驱动并确认硬件加速启动后,问题解决。
装完beryl后的硬件驱动仍然没有问题,但还是不能启动google earth。
glxinfo的输出是:
name of display: :1.0
Xlib: extension "XFree86-DRI" missing on display ":1.0".
display: :1 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_get_proc_address, GLX_SGI_video_sync, GLX_ARB_multisample,
GLX_ATI_pixel_format_float, GLX_ATI_render_texture
GLX version: 1.2
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_multisample
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON X800 GTO Generic
OpenGL version string: 1.2 (2.0.6011 (8.28.8))
OpenGL extensions:
GL_ARB_multitexture, GL_ARB_texture_border_clamp, GL_ARB_texture_cube_map,
GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
GL_ARB_texture_env_dot3, GL_ARB_transpose_matrix, GL_EXT_abgr,
GL_EXT_blend_color, GL_EXT_blend_minmax, GL_EXT_blend_subtract,
GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
GL_EXT_texture_env_dot3, GL_EXT_texture_lod_bias

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x2c 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 0 0 None
0x2d 24 tc 0 32 0 r . . 8 8 8 8 0 0 0 0 0 0 0 0 0 None
0x2e 32 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 0 0 Ncon
0x2f 32 tc 0 32 0 r . . 8 8 8 8 0 0 0 0 0 0 0 0 0 Ncon


页首
 用户资料  
 
2 楼 
 文章标题 : 又发现一个问题
帖子发表于 : 2006-10-21 13:26 

注册: 2006-10-11 20:41
帖子: 375
送出感谢: 0 次
接收感谢: 0 次
totem在beryl下运行极慢,切回metacity就好了。VLC在beryl下运行正常,播放速度流畅。


页首
 用户资料  
 
3 楼 
 文章标题 : 重新安装ATI的驱动程序,把glxgears的FPS提高到了4000左右
帖子发表于 : 2006-10-21 15:49 

注册: 2006-10-11 20:41
帖子: 375
送出感谢: 0 次
接收感谢: 0 次
重新安装ATI的驱动程序,把glxgears的FPS提高到了4000左右
但还是不能运行google earth, 解决了视频播放的问题,看来ATI的却动一定要留好了,不能安装完就随手给删了。
我用的8.28.8的ATI驱动。


最后由 aloha 编辑于 2006-10-22 10:34,总共编辑了 1 次

页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-10-21 18:55 
头像

注册: 2006-09-04 23:49
帖子: 59
送出感谢: 0 次
接收感谢: 0 次
命令行运行:
代码:
DISPLAY=:0 googleearth


页首
 用户资料  
 
5 楼 
 文章标题 : 不灵
帖子发表于 : 2006-10-22 10:28 

注册: 2006-10-11 20:41
帖子: 375
送出感谢: 0 次
接收感谢: 0 次
DISPLAY=:0 googleearth
或者
DISPLAY=:0.0 googleearth
都没有显示,估计因为在/etc/gdm/gdm.conf里面已经改成了1-Standard
DISPLAY=:1 googleearth
或者
DISPLAY=:1.0 googleearth
则显示启动画面后停止在初始化阶段,和原来一样,但是在窗口里面显示了一条错误:
Xlib: extension "XFree86-DRI" missing on display ":1.0".
和glxinfo的输出中的错误一样。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-10-25 13:13 
头像

注册: 2006-09-30 1:08
帖子: 759
地址: QingDao
送出感谢: 0 次
接收感谢: 0 次
不用改gdm.conf和gdm.conf-custom



建立XGL启动脚本
代码:
sudo gedit /usr/bin/startxgl.sh

粘贴:
代码:
Xgl -fullscreen :1 -ac -accel glx:pbuffer -accel xv:pbuffer & sleep 2 && DISPLAY=:1
# Start GNOME
exec gnome-session

使脚本可执行:
代码:
sudo chmod 755 /usr/bin/startxgl.sh


5) 给登录管理器添加一个XGL会话
代码:
sudo gedit /usr/share/xsessions/xgl.desktop

粘贴:
代码:
[Desktop Entry]
Encoding=UTF-8
Name=XGl
Exec=/usr/bin/startxgl.sh
Icon=
Type=Application


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-10-27 16:49 

注册: 2005-04-11 22:56
帖子: 113
送出感谢: 0 次
接收感谢: 0 次
我一直有这个问题。
XGL/ATI X1300


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-10-27 18:05 
头像

注册: 2006-07-08 14:07
帖子: 1773
送出感谢: 14
接收感谢: 1
我的可以用,就是有些框是黑点


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-10-27 21:01 

注册: 2006-10-11 20:41
帖子: 375
送出感谢: 0 次
接收感谢: 0 次
这不是安装compiz的方法么,我又这么试了一编,google-earth是能跑了,但beryl又起不来了。
ipv6now 写道:
不用改gdm.conf和gdm.conf-custom



建立XGL启动脚本
代码:
sudo gedit /usr/bin/startxgl.sh

粘贴:
代码:
Xgl -fullscreen :1 -ac -accel glx:pbuffer -accel xv:pbuffer & sleep 2 && DISPLAY=:1
# Start GNOME
exec gnome-session

使脚本可执行:
代码:
sudo chmod 755 /usr/bin/startxgl.sh


5) 给登录管理器添加一个XGL会话
代码:
sudo gedit /usr/share/xsessions/xgl.desktop

粘贴:
代码:
[Desktop Entry]
Encoding=UTF-8
Name=XGl
Exec=/usr/bin/startxgl.sh
Icon=
Type=Application


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-01-17 13:02 

注册: 2007-01-16 12:16
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
我也是这样:

引用:
DISPLAY=:0 googleearth
或者
DISPLAY=:0.0 googleearth
都没有显示,估计因为在/etc/gdm/gdm.conf里面已经改成了1-Standard
DISPLAY=:1 googleearth
或者
DISPLAY=:1.0 googleearth
则显示启动画面后停止在初始化阶段,和原来一样,但是在窗口里面显示了一条错误:
Xlib: extension "XFree86-DRI" missing on display ":1.0".
和glxinfo的输出中的错误一样。


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-01-17 13:37 
头像

注册: 2006-05-13 4:02
帖子: 10606
送出感谢: 0 次
接收感谢: 7
不知道和scim有没有关系。反正scim和acroreader ooo 等都有冲突。
你可以试试sudo im-switch -s scim-pinyin,并且安装scim-bridge。


_________________
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo


页首
 用户资料  
 
12 楼 
 文章标题 : GoogleEarth
帖子发表于 : 2007-03-07 9:12 
头像

注册: 2006-01-09 9:41
帖子: 201
地址: 湖南邵东
送出感谢: 0 次
接收感谢: 0 次
源里有,可以直接安装就行了


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Sogou [Spider] 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译