当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 18 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : [问题]No composite extension
帖子发表于 : 2006-11-03 21:17 
头像

注册: 2005-12-29 9:19
帖子: 101
送出感谢: 0 次
接收感谢: 0 次
~$ beryl-xgl
XGL Absent, checking for NVIDIA
Nvidia Absent, assuming AIGLX
beryl-xgl: No composite extension
是什么原因?是xgl没装上么?


_________________
就是喜欢ubuntu^_^
图片


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-11-03 22:58 
头像

注册: 2005-12-29 9:19
帖子: 101
送出感谢: 0 次
接收感谢: 0 次
为什么我beryl装h 了,任务栏也有图标了,可是xgl却装不上啊?我都是按置顶的帖子一步步装了的啊~


_________________
就是喜欢ubuntu^_^
图片


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-11-04 0:27 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
Absent是没有的意思。就是你也不是使用xgl的启动方式,又没有nvidia的最新驱动,也没安装aiglx


_________________
● 鸣学


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-11-04 8:37 
头像

注册: 2005-12-29 9:19
帖子: 101
送出感谢: 0 次
接收感谢: 0 次
eexpress 写道:
Absent是没有的意思。就是你也不是使用xgl的启动方式,又没有nvidia的最新驱动,也没安装aiglx

我的是ati9550,已经按wiki上装好了驱动,它这个提示是说我没装上xgl还是说没启动xgl?要是没启动的话该怎么启动呢?我要怎么样才能查看我是否装成功了xgl啊?谢谢~


_________________
就是喜欢ubuntu^_^
图片


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-11-04 13:52 

注册: 2006-03-21 10:47
帖子: 406
送出感谢: 0 次
接收感谢: 0 次
http://wiki.beryl-project.org/index.php/Install/Ubuntu/Edgy/GCDrivers

http://wiki.cchtml.com/index.php/Ubuntu_Edgy_Installation_Guide

引用:
Ubuntu Edgy Installation Guide
From cchtml.com
Jump to: navigation, search

In Ubuntu Edgy you can choose between two methods of installing the proprietary ATI driver. If you are new to linux you should use the first method as it is a lot easier than the second one and will work well in most cases. The second method describes how to install the very latest driver version, but requires some additional work and knowledge.
Contents
[hide]

* 1 Method 1: Installing Edgy's Included Driver (8.28.8)
o 1.1 Disable Composite Extension
o 1.2 Installing the driver
o 1.3 Confirm that it works
o 1.4 Troubleshooting for Method 1
* 2 Method 2: Generating/Installing Ubuntu packages for the new 8.30.3 drivers in Ubuntu Edgy Manually
o 2.1 Disable Composite Extension
o 2.2 Blacklist old fglrx module from linux-restricted-modules
o 2.3 Installing the new driver
o 2.4 Confirm that it worked
o 2.5 Troubleshooting for Method 2
+ 2.5.1 xorg.conf
* 3 Troubleshooting for both Methods
o 3.1 General
o 3.2 DRI does not work although the fglrx module is loaded
o 3.3 Module isn't loaded
o 3.4 2D speed
o 3.5 Is the rebooting really necessary?
o 3.6 Revert to Xorg driver

[edit]
Method 1: Installing Edgy's Included Driver (8.28.8)

The included fglrx driver supports Radeon 8500+ and the X-series cards up to X1900.
[edit]
Disable Composite Extension

In Ubuntu Edgy the Composite extension is enabled by default, however, fglrx does not yet support Composite with DRI. In order to to disable Composite you have to edit the xorg.conf file:

sudo gedit /etc/X11/xorg.conf

and add these lines at the end of the file:
File: /etc/X11/xorg.conf

Section "Extensions"
Option "Composite" "0"
EndSection

[edit]
Installing the driver

Make sure the restricted repository is enabled in /etc/apt/sources.list or this guide will not work!

sudo apt-get update
sudo apt-get install linux-restricted-modules-$(uname -r) #Okay if it is already installed
sudo apt-get install xorg-driver-fglrx
sudo depmod -a
sudo aticonfig --initial
sudo aticonfig --overlay-type=Xv

Now Reboot your system:

sudo shutdown -r now

An alternative to the aticonfig --initial command is to edit /etc/X11/xorg.conf and replace the string "ati" with "fglrx" in the "Device" section. This way you won't lose your old "Screen" and "Monitor" settings. Afterwards you can use aticonfig for setting overlay etc.
[edit]
Confirm that it works

fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9600 Generic
OpenGL version string: 2.0.6011 (8.28.8)

[edit]
Troubleshooting for Method 1

* The output of dmesg | grep fglrx and /var/log/Xorg.0.log are most useful when looking for errors. You should really include this when you are asking for help somewhere.

* If you used Method 2 before, you have to unblacklist fglrx again by editing /etc/default/linux-restricted-modules-common. You may have to run sudo lrm-manager afterwards.

* See Troubleshooting for both Methods



[edit]
Method 2: Generating/Installing Ubuntu packages for the new 8.30.3 drivers in Ubuntu Edgy Manually

The new fglrx driver supports Radeon 9500+ (older cards will not work!) and the X-series cards up to X1900.
[edit]
Disable Composite Extension

In Ubuntu Edgy the Composite extension is enabled by default, however, fglrx does not yet support Composite with DRI. In order to to disable Composite you have to edit the xorg.conf file:

sudo gedit /etc/X11/xorg.conf

and add these lines at the end of the file:
File: /etc/X11/xorg.conf

Section "Extensions"
Option "Composite" "0"
EndSection

[edit]
Blacklist old fglrx module from linux-restricted-modules

As ubuntu's linux-restricted-modules package includes the fglrx module from an old driver version (8.28.8), we have to blacklist this module to make sure the new kernel module which is needed by the new driver will be used instead.

sudo gedit /etc/default/linux-restricted-modules-common

Edit DISABLED_MODULES to include fglrx
File: /etc/default/linux-restricted-modules-common

DISABLED_MODULES="fglrx"

[edit]
Installing the new driver

Download the ATI driver installer: ati-driver-installer-8.30.3.run (this installer is for 32bit and 64bit systems)

Change to the download directory. Make sure that you have the universe and multiverse repositories enabled in /etc/apt/sources.list before doing these steps.

Install necessary tools:

sudo apt-get update
sudo apt-get install module-assistant build-essential
sudo apt-get install fakeroot dh-make debconf libstdc++5 linux-headers-$(uname -r)

Create .deb packages:

sudo ln -sf bash /bin/sh
bash ati-driver-installer-8.30.3.run --buildpkg Ubuntu/edgy
sudo ln -sf dash /bin/sh

Install .deb packages:

sudo dpkg -i xorg-driver-fglrx_8.30.3-1*.deb
sudo dpkg -i fglrx-kernel-source_8.30.3-1*.deb
sudo dpkg -i fglrx-control_8.30.3-1*.deb

Remove any old fglrx debs from /usr/src/:

sudo rm /usr/src/fglrx-kernel*.deb

Compile the kernel module:

sudo module-assistant prepare
sudo module-assistant update
sudo module-assistant build fglrx
sudo module-assistant install fglrx
sudo depmod -a

IMPORTANT: You have to recompile the kernel module after each kernel update!

Update the xorg.conf file:

sudo aticonfig --initial
sudo aticonfig --overlay-type=Xv

Note: You could also edit your /usr/X11/xorg.conf file to change your driver to fglrx then run:

sudo aticonfig --overlay-type=Xv

This way your xorg.conf file will stay clean.

Now Reboot:

sudo shutdown -r now

[edit]
Confirm that it worked

$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9700 Generic
OpenGL version string: 2.0.6119 (8.30.3)

$ glxinfo | grep render
direct rendering: Yes

If your direct rendering is disabled, you may have to symlink the dri folder:

sudo mkdir /usr/X11R6/lib/modules
sudo ln -s /usr/lib/dri /usr/X11R6/lib/modules/

[edit]
Troubleshooting for Method 2
[edit]
xorg.conf

The aticonfig --initial command will not update the xorg.conf file if it already has a "fglrx" Device section. However, you may force aticonfig to generate default Monitor, Device, and Screen sections with the following command:

sudo aticonfig --force --initial




[edit]
Troubleshooting for both Methods
[edit]
General

The output of dmesg | grep fglrx and /var/log/Xorg.0.log are most useful when looking for errors.
[edit]
DRI does not work although the fglrx module is loaded

Make sure the Composite extension is disabled, add this to your /etc/X11/xorg.conf file:

Section "Extensions"
Option "Composite" "Disable"
EndSection

[edit]
Module isn't loaded

If the fglrx module isn't loaded try to add fglrx to /etc/modules on a new line. See also bug 63912.
File: /etc/modules

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

fglrx

[edit]
2D speed

If you suffer from slow 2D speed it might help to set

Option "XaaNoOffscreenPixmaps"

in the fglrx device section of /etc/X11/xorg.conf
[edit]
Is the rebooting really necessary?

No.

However, rebooting is the easiest method to ensure that the kernel module(s) from the old driver are unloaded and the fglrx module is loaded instead. If you don't want to reboot for some reason, you may manually shut down Xorg, unload any old "drm", "radeon" or "fglrx" modules and then start Xorg again.

Note: if modprobe fglrx can't find the fglrx module, try rebuilding your kernel module dependency:

sudo depmod -a

[edit]
Revert to Xorg driver

If (for any reason) the fglrx install fails, you can revert to the Xorg driver by executing

sudo dpkg-reconfigure xserver-xorg

and selecting the "ati" driver, or simply restoring the previous /etc/X11/xorg.conf file, if you made a backup.

You also need to remove the xorg-driver-fglrx or your manually installed drivers to get the 3D acceleration back, since it is provided by file /usr/lib/libGL.so.1.2 which belongs to libgl1-mesa package and which is moved to backup and replaced at the installation of xorg-driver-fglrx (or the manually built) package. In case the removal of the fglrx drivers fails to restore the file from libgl1-mesa, you have to reinstall the package by running:

sudo apt-get install --reinstall libgl1-mesa


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-11-04 14:05 
头像

注册: 2005-12-29 9:19
帖子: 101
送出感谢: 0 次
接收感谢: 0 次
$ glxinfo | grep render
direct rendering: Yes

~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9550 Generic
OpenGL version string: 2.0.5814 (8.25.18)

这说明我的驱动已经装成功了啊。可是为什么还是不成功呢?


_________________
就是喜欢ubuntu^_^
图片


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-11-04 14:15 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
xorg.conf里面没有修改吧。一般是需要加几行东西的。我之前贴过几次英文网址,我都忘记地址了。是按照显卡分类以及分显卡的安装的说明。你找找,类似于berylonedgy这样的网址。


_________________
● 鸣学


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-11-04 15:50 
头像

注册: 2005-12-29 9:19
帖子: 101
送出感谢: 0 次
接收感谢: 0 次
eexpress 写道:
xorg.conf里面没有修改吧。一般是需要加几行东西的。我之前贴过几次英文网址,我都忘记地址了。是按照显卡分类以及分显卡的安装的说明。你找找,类似于berylonedgy这样的网址。


你是说下面的代码么:
gedit /etc/X11/xorg.conf

添上
代码:
Section "Extensions"
Option "Composite" "0"
EndSection
上面这段我加了,也没效果,gdm登录时选择xgl,显示说会话只启动了10秒,
然后就只能登录普通gnome。
如果按下面的设置启动xgl的话,连gnome都进不去了,只能通过startx来进入,更郁闷,网上能找的资料我都找了,国外的论坛也去看了,可是都没有找到解决的办法,唉~~可是你们的怎么就能装成功呢?

ATI的:
sudo gedit /etc/gdm/gdm.conf-custom,在[servers] 后面加入
1=Xgl

[server-Xgl]
name=Xgl server
command=/usr/bin/Xgl -fullscreen -br -accel xv:pbuffer -accel glx:pbuffer -dpi 100 -nolisten tcp
flexible=true

还有sudo gedit /etc/gdm/gdm.conf,找到“0=Standard”,改为“1=Standard”;找到“GdmXserverTimeout=10”,改为“GdmXserverTimeout=50”


_________________
就是喜欢ubuntu^_^
图片


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-11-04 16:51 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
你抄的这些都是老方法。都告诉你关键词了,你应该搜索哦。

http://doc.gwos.org/index.php/BerylOnEdgy


_________________
● 鸣学


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-11-04 20:35 
头像

注册: 2005-12-29 9:19
帖子: 101
送出感谢: 0 次
接收感谢: 0 次
eexpress 写道:
你抄的这些都是老方法。都告诉你关键词了,你应该搜索哦。

http://doc.gwos.org/index.php/BerylOnEdgy

我上你给的那个网站看了,他给的办法也是那样啊,超酷桌面置顶的是一样的,我的是dapper。
我觉得就是xgl没装上,有什么命令能查看么?


_________________
就是喜欢ubuntu^_^
图片


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2006-11-04 21:36 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
http://wiki.beryl-project.org/index.php/Install/Ubuntu
这是官方的。仔细看下。有dapper的。


_________________
● 鸣学


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2006-11-05 11:44 
头像

注册: 2005-12-29 9:19
帖子: 101
送出感谢: 0 次
接收感谢: 0 次
没辙了,网上的方法全都试过了,没成功过,任务栏上倒是有红宝三石的图标了,可是就是没用,xgl没启动
去官方论坛看了,也有些人是我这样的问题,可是都没给出解决方案,其实我装这个只是想要个透明效果罢了,就是vista的那种效果,挺喜欢的。
我的显卡是ati9550,有没有哪位仁兄用这样的显卡装成功了的啊?指点一下经验啊。我都折腾了两三天了,唉~~
难道是个bug不成?


_________________
就是喜欢ubuntu^_^
图片


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2006-11-05 11:52 
头像

注册: 2005-12-29 9:19
帖子: 101
送出感谢: 0 次
接收感谢: 0 次
通过命令starx进入后,如果窗口管理器选择beryl的话,就是闪两下又恢复原样了。关机按钮也没有了,看来是xgl好像是装上了,只是没启动成功,可是却不知道该怎么办了~


_________________
就是喜欢ubuntu^_^
图片


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2006-11-05 14:58 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
noahsark 写道:
没辙了,网上的方法全都试过了,没成功过,任务栏上倒是有红宝三石的图标了,可是就是没用,xgl没启动
去官方论坛看了,也有些人是我这样的问题,可是都没给出解决方案,其实我装这个只是想要个透明效果罢了,就是vista的那种效果,挺喜欢的。
我的显卡是ati9550,有没有哪位仁兄用这样的显卡装成功了的啊?指点一下经验啊。我都折腾了两三天了,唉~~
难道是个bug不成?
只要透明,可以找找transset的用法。


_________________
● 鸣学


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2006-11-05 17:01 

注册: 2006-10-27 10:54
帖子: 27
送出感谢: 0 次
接收感谢: 0 次
我跟你一样 9700 的 郁闷死了 才开始用ubuntu 先是被显卡驱动。。。。。。 然后又被java。。。。。 接着就是beryl 我都晕了 没一样顺利


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 18 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译