当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 谁知道如何能修复fglrxinfo出错的问题
帖子发表于 : 2006-11-04 1:32 
头像

注册: 2006-08-22 22:12
帖子: 142
送出感谢: 0 次
接收感谢: 0 次
系统为dapper,已经安装ati驱动程序和beryl。一切工作正常。
但是fglrxinfo出现如下信息,
Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: MOBILITY RADEON 9700 Generic
OpenGL version string: 1.2 (2.0.6065 (8.29.6))

glxgears也出现同样的错误。

这个 Xlib: extension "XFree86-DRI" missing on display ":0.0". 的问题应该如何解决呢?谢谢!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-11-06 8:54 

注册: 2006-05-24 10:26
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
http://wiki.ubuntu.org.cn/ATI%E6%98%BE% ... 7%E5%8D%97
里有解决方法。
引用:
如果您收到如下消息Xlib: extension "XFree86-DRI" missing on display ":1.0, 编辑 /etc/X11/xorg.conf 并在 Section "Module" 字段内添加 load "dri"


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-11-14 2:06 
头像

注册: 2006-08-22 22:12
帖子: 142
送出感谢: 0 次
接收感谢: 0 次
多谢楼上的哥们儿,但是已经尝试过了,不灵!


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-11-16 17:14 

注册: 2006-06-27 15:48
帖子: 142
送出感谢: 0 次
接收感谢: 0 次
驱动没驱起来,用glxinfo看一下,要有direct rendering: Yes才行,再用dmesg看一下,是不是drm模块出错了,我的inter显卡开始就是这样,把内核降到23后正常了。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-11-16 17:17 

注册: 2006-06-27 15:48
帖子: 142
送出感谢: 0 次
接收感谢: 0 次
驱动没驱起来,用glxinfo看一下,要有direct rendering: Yes才行,再用dmesg看一下,是不是drm模块出错了,我的inter显卡开始就是这样,把内核降到23后正常了。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-11-22 0:23 
头像

注册: 2006-08-22 22:12
帖子: 142
送出感谢: 0 次
接收感谢: 0 次
有direct rendering: Yes,而且加速也正常,使用起来没有什么错误,就是看着很不爽,想弄清楚到底为什么呀。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译