当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]有用ati9200成功安装beryl的吗?
帖子发表于 : 2006-11-08 8:52 

注册: 2006-03-05 10:29
帖子: 200
送出感谢: 1
接收感谢: 0 次
我的是ati9200,一直安装不上,有谁成功了吗?能说一下怎么成功的吗?
另:别拿非ati9200的安装教程来,因为都试过了。
谢谢!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-11-08 20:53 
头像

注册: 2006-07-23 16:25
帖子: 1592
地址: 南京
送出感谢: 0 次
接收感谢: 0 次
有,我的是ati9200的,刚成功,用aiglx+beryl+dapper,正在研究scim的冲突问题中


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-11-09 13:58 

注册: 2006-03-05 10:29
帖子: 200
送出感谢: 1
接收感谢: 0 次
请问楼上是如何做的,我的是xubuntu,照着beryl的wiki做,重启后进xgl时会出现 section的10秒错误,但改成50秒等待后,还是不能进入。
Thanks


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-11-10 20:55 
头像

注册: 2006-07-23 16:25
帖子: 1592
地址: 南京
送出感谢: 0 次
接收感谢: 0 次
我用的是ubuntu,不过我想原理应该差不多。
考虑到ati9200本身比较老了,所以没有用xgl,而是用aixgl,另外我也没用ati的闭源驱动,因为听说对ati9200而言,开源驱动更快。
参考的文档我记不清哪下的了,好像也是beryl 的 wiki
大致摘录如下:
How-to install Beryl with AIGLX on Edgy

As of october 2006, AIGLX should work out of the box in edgy, provided your graphics card supports it.
[edit]
How-to install Beryl with AIGLX on Dapper
[edit]
Add repositories

Edit the sources.list file:
sudo nano /etc/apt/sources.list

Add this line:
deb http://ubuntu.beryl-project.org/ dapper main aiglx

Make sure to get the public key for the repository:
wget http://ubuntu.beryl-project.org/quinn.key.asc -O - | sudo apt-key add -

Update the package list and upgrade your system before installing
sudo apt-get update
sudo apt-get dist-upgrade
[edit]
Install AIGLX

Install the new X server (called xserver-xorg-air):
sudo apt-get install xserver-xorg-air-core linux-dri-modules-common linux-dri-modules-`uname -r`

There's a small glitch with xserver-xorg-air-core: it doesn't install its own modules for input and video drivers. The workaround is to point to the Xorg modules instead:
sudo ln -s /usr/lib/xorg/modules/drivers/ /usr/lib/xorg-air/modules/
sudo ln -s /usr/lib/xorg/modules/input/ /usr/lib/xorg-air/modules/

Modify /etc/X11/xorg.conf - maybe it is a good advice to make a copy before editing because in any problem, you might not be able to login again in the graphic session! So first, make a backup
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.old

The modifications : Needs to be in the Screen section:
DefaultDepth 24

Make sure these are all there, and GLcore is commented out:
Section "Module"
# Load "GLcore"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dbe"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10″
Load "type1″
Load "vbe"
EndSection

Exactly like this (depends on your graphic chip): (IF there is no Option "XAANoOffscreenPixmaps". Add it! for 855GM)
Section "Device"
Identifier "Intel Corporation Intel Default Card"
Driver "i810"
Option "XAANoOffscreenPixmaps"
BusID "PCI:0:2:0″
EndSection

Add this under Section "ServerLayout"
Option "AIGLX" "true"

You must have composite exstension enabled (if not, add it):
Section "Extensions"
Option "Composite" "Enable"
EndSection

and this:
Section "DRI"
Mode 0666
EndSection

Now modify gdm's config to use AIGLX the next time you boot: Modify the file /etc/gdm/gdm.conf-custom and make it look like this:
sudo nano /etc/gdm/gdm.conf-custom
[servers]
0=aiglx

[server-aiglx]
name=aiglx server
command=/usr/bin/Xorg-air :0
flexible=true

All these modifications will be effective the next time you boot!
[edit]
Install Beryl

Simply type
sudo apt-get install beryl

That's too easy !

You'll also need themes for the decorations
sudo apt-get install emerald-themes

Beryl is a metapackage that will install all the dependencies (beryl-core, beryl-plugins, beryl-manager, beryl-settings) and also the decoration themes (emerald but not emerald-themes). Make sure you have all!
[edit]
Starting Beryl (and AIGLX)

You need first to start AIGLX. Just close all your windows, logout and press Ctrl + Alt + Backspace. That will stop and restart your X server. If the login screen doesn't show up, try to reboot. If you still have some trouble, restore your backup copy (/etc/X11/xorg.conf.old). If the login screen shows up, cool! AIGLX seems to works.

To start Beryl, you might just type beryl but it is more usefull to use the manager instead, so type
beryl-manager

You'll see an ermald icon in your panel which helps you to manage beryl and the decorations.

To start beryl at each session, go in Gnome Menu > System > Preferences > Sessions > Startup Programs and add beryl-manager.
[edit]
Specific instructions for Kubuntu (Dapper)
[edit]
Changing KDE's x-server

Follow the same instructions until the modification of gdm.

To set the x-server that KDE will use with, open up /etc/kde3/kdm/kdmrc in an editor:
sudo vim /etc/kde3/kdm/kdmrc

and change the ServerCmd (somewhere around line #465) to read :
ServerCmd=/usr/bin/Xorg-air :0
[edit]
KDE start-up script

Create a start-up script named beryl.start in ~/.kde/Autostart :
vim ~/.kde/Autostart/beryl.start

and enter the following contents into it :
[Desktop Entry]
Encoding=UTF-8
Exec=beryl-manager
GenericName[en_US]=
StartupNotify=false
Terminal=false
TerminalOptions=
Type=Application
X-KDE-autostart-after=kdesktop

save the file and then make it executable :
chmod +x ~/.kde/Autostart/beryl.start
[edit]
Using it

If you find it too slow then open up Compiz Settings Manager and remove the blur effect -- as of this writing (Sept. 2006) it really slows things down. Some commands to get you started (all of them are configurable through the Settings Manager):
General Option
Alt+Mouse wheel Make window translucent/opaque
Application Switcher
Alt+Tab switch between windows from current workspace
Ctrl+Alt+Tab switch between windows from all workspaces
Scale (Arrange and view all windows)
Bottom-Left (hot corner) All workspaces (clicking a window will zoom it to the front)
Top-right (hot corner) Current workspace
Show Desktop (View desktop of current cube face )
Bottom-right (hot corner) Tturns on or off;
Rotate cube
Ctrl+Alt+Left/Right Arrow Switch desktops on cube;
Ctrl+Shift+Alt+Left/Right Arrow Send the active window to the left/right workspace
Ctrl+Alt+Left-click and grab Rotate cube manually
Zoom
Super-key+Right-click Zoom in once
Super-key+Mouse wheel up/down Zoom in/out manually
Move Window
Alt+Left-click Move window
Ctrl+Shift+Left-click Snap move window (will stick to borders)
Resize window
Alt+Middle-click
Water
Hold Ctrl+Super key and move mouse Your pointer is moving on water (Disabled by default)
Shift-F9 Rain is falling on your screen
Blur
Add some blur under transparent windows (will slow down your computer!)
Minimize Effect
Animations when creating or closing windows (works also for menu but then you have to select "Unknown"! "Menu" alone doesn't work)
Negative
Super Key+m Inverse color of the screen
Super Key+n Inverse color of the current window
Reflection
Add somes textures to decoration (mostly visible when transparent)
Screenshot
Super Key+Left Click and grab Take a screenshot of the selected area (picture saved on the desktop)
Trail focus
Older windows are more transparent
Wobbly
Makes windows, menus,... like chewing-um
Brightness and Saturation
Ctrl+Mouse wheel down/up Desaturate/Resaturate (works also for desktop)
Shift+Mouse wheel down/up Less/more Brightness (works also for desktop)
Put
Super Key+Keypad 1..9 Quickly place a window on a screen (1=top left, 2=top center,...). On a laptop (i.e if you don't have a numeric keypad, use Super Key+Fn Key+Virtual Keypad)
Bring up the window below the top window (I don't know that plugin?)
希望能你有所帮助


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-11-11 11:33 

注册: 2006-03-05 10:29
帖子: 200
送出感谢: 1
接收感谢: 0 次
唉,不能进入X,还是等官方的直接支持了。
在hiweed那里找到个原因:9200用fglrx驱动的话不能用xgl.
http://www.hiweed.com/node/225

Thanks all the same.


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-11-11 15:53 
头像

注册: 2006-07-23 16:25
帖子: 1592
地址: 南京
送出感谢: 0 次
接收感谢: 0 次
hiweed我没用过,不过我想ubuntu的问题我可以帮你。
进不了x,是你的配置问题出了问题。你先从文字模式用原来的配置文件覆盖现在的配置文件
cp /etc/X11/xorg.conf.original-0 /etc/X11/xorg.conf
这样你至少应该可以进X了。
然后按你安装时方法去掉你的fglrx驱动和xlg ,compiz等等。
重新进一遍图形界面,使用glxinfo查看一下你的显卡信息,确定3D打开后,就可以按我上一贴的方法作了
祝你好运 :)


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-11-11 21:28 

注册: 2006-03-05 10:29
帖子: 200
送出感谢: 1
接收感谢: 0 次
晕啊!删了fglrx,只有开源驱动,开了3D,完全照上面的wiki做,但重启后还是没反应,进程中有显示aiglx,终端输入beryl-manager,只显示
libGL warning: 3D driver claims to not support visual 0x4b
屏幕没反应。
关掉beryl-manager,再试,屏幕闪了一下,出现
XGL Absent, checking for NVIDIA
Nvidia Absent, assuming AIGLX
beryl: Another window manager is already running on screen: 0
beryl: No manageable screens found on display :0.0
只能等它再成熟一些了,以后再试。

在此感谢TheThirdGhost的热情帮助。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-11-12 9:48 
头像

注册: 2006-07-23 16:25
帖子: 1592
地址: 南京
送出感谢: 0 次
接收感谢: 0 次
不客气,最后还是帮不了你 :(
不过我把我的执行结果贴出来,没准以后对你还有点用 :D
thinker@thinker-desktop:~$ libGL warning: 3D driver claims to not support visual 0x4b
Engine settings loaded
XGL Absent, checking for NVIDIA
Nvidia Absent, assuming AIGLX
libGL warning: 3D driver claims to not support visual 0x4b
beryl: No stencil buffer. Clipping of transformed windows is not going to be correct when screen is transformed.
Initiating splash
beryl: water: GL_ARB_fragment_program is missing
哦,另外要说明的是你每次开机第一次进图形时,运行beryl-manage,基本上都会有问题,好像是一个bug,用ctrl+ALT+back退出再进一次,然后beryl-manage,就可以了。看你的执行结果第二次出错显示,你的beryl-manager,已经在运行了


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Sogou [Spider] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译