当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]请教x700装xgl beryl的问题
帖子发表于 : 2006-11-13 15:32 

注册: 2006-09-02 21:23
帖子: 143
地址: Nanjing China
送出感谢: 0 次
接收感谢: 0 次
请教我的显卡是ati mobility radeon x700,64m显存,不知道可不可以装xgl,beryl这些特绚的东东?
听说ati的卡出现的问题比较多,哪位高手可不可以指点一下?或者给一个指导的链接?我刚装好ubuntu所以不太会。。。谢谢。。。
恩,显卡的驱动我是这样弄的,http://wiki.ubuntu.org.cn/ATI%E6%98%BE%E5%8D%A1%E5%AE%89%E8%A3%85%E9%85%8D%E7%BD%AE%E6%8C%87%E5%8D%97

系统需求
请确保您的显卡具有如下属性:
* 它是一块"镭"显卡
* 卡的类型为9xxx系列,9500或更高,或卡的类型为X系列(例如X300),或其拥有电视输出TV-Ouet能力. 'fglrx' 驱动不支持早于8500的显卡.
* 命令 lspci 显示卡的名字带"ATI"字样.
* 您需要3D硬件加速支持,或显示刷新率高于60Hz.开源驱动在其他方面都做得很好.
如果您的ATI显卡不在上述列表中,它已经支持3D加速了.

Ubuntu 6.06 (Dapper Drake) 安装说明

sudo apt-get update
sudo apt-get install linux-restricted-modules-$(uname -r)
sudo apt-get install xorg-driver-fglrx
sudo aticonfig --initial
sudo aticonfig --overlay-type=Xv

重启系统.

确保驱动已经工作:

$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9700 Generic
OpenGL version string: 2.0.5755 (8.24.8)


3D已经开启glxinfo | grep rendering,得到direct rendering: Yes


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-11-13 22:24 

注册: 2006-10-28 18:05
帖子: 266
送出感谢: 0 次
接收感谢: 0 次
我ATI IGP340M(7000核心)都行了的。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-11-14 13:08 

注册: 2006-09-02 21:23
帖子: 143
地址: Nanjing China
送出感谢: 0 次
接收感谢: 0 次
那怎么装呢?具体步骤是什么阿 ?还有装的是xgl还是AiGLX?
我是新手对这些概念不太懂。。。Beryl是窗口管理器?就像suse里的compiz一样吗?xgl和aiglx有什么区别呢?
谢谢


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-11-14 16:16 

注册: 2006-11-03 18:42
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
顶阿,我的显卡是ATI REDEON X600 , 同样装了fglrx驱动,下来怎样装xgl+beryl,还是aiglx+beryl?那位大虾回答一下这个问题阿


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-11-14 19:13 

注册: 2006-09-02 21:23
帖子: 143
地址: Nanjing China
送出感谢: 0 次
接收感谢: 0 次
今天做了大胆的尝试,结果让我更加喜欢ubuntu这个酷酷的操作系统了!
我的做法,完全按照官方的对ati卡的指南,http://wiki.beryl-project.org/index.php/Install/Ubuntu/Dapper/ATI
搞定以后重启;在会话选择xgl,结果不能进入桌面就重新推出来了;
无奈,选择gnome,进入,提示有更新,二话没说,装!
装了以后我不死心又重启了一次,选择会话xgl,结果进去了!
我现在已经可以看到抖动的菜单,立方体桌面,雨点特效,正在尝试其他的效果,我想应该没有问题
enjoy ubuntu!

发现一个问题,super是win键不?咋不好用呢?

found anoter problem: xgl持续占用cpu。。。cpu始终保持50%左右甚至更高的使用率


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-11-15 4:55 
头像

注册: 2006-05-13 4:02
帖子: 10606
送出感谢: 0 次
接收感谢: 7
注意,blur和fade两个特效不要同时打开,会导致cpu占用很高。
super键可以设置成win键,在系统-首选项-键盘-布局选项-alt/win键行为-super键被映射到win键。


_________________
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-11-15 16:20 

注册: 2006-11-03 18:42
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
多谢surperman05, 和 zhuqin_83, 我按照两位的做法成功 搞定 beryl, 哈哈,爽阿,折腾了两天没有白费阿,我的显卡是
ATI REDEON X600 , 同样装了fglrx驱动,xgl+beryl. :em06 :em07


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-11-15 17:07 

注册: 2006-09-02 21:23
帖子: 143
地址: Nanjing China
送出感谢: 0 次
接收感谢: 0 次
不过a卡好像不太好弄aiglx+beryl这个有点不爽
不知道有人弄成功了吗


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-11-15 20:19 

注册: 2006-11-03 18:42
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
我的桌面,hoho! :em08


附件:
Screenshot.png
Screenshot.png [ 566.63 KiB | 被浏览 653 次 ]

页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-11-15 21:24 
头像

注册: 2006-01-19 11:55
帖子: 1114
地址: HUST
送出感谢: 0 次
接收感谢: 0 次
superman05 写道:
今天做了大胆的尝试,结果让我更加喜欢ubuntu这个酷酷的操作系统了!
我的做法,完全按照官方的对ati卡的指南,http://wiki.beryl-project.org/index.php/Install/Ubuntu/Dapper/ATI
搞定以后重启;在会话选择xgl,结果不能进入桌面就重新推出来了;
无奈,选择gnome,进入,提示有更新,二话没说,装!
装了以后我不死心又重启了一次,选择会话xgl,结果进去了!
我现在已经可以看到抖动的菜单,立方体桌面,雨点特效,正在尝试其他的效果,我想应该没有问题
enjoy ubuntu!

发现一个问题,super是win键不?咋不好用呢?

found anoter problem: xgl持续占用cpu。。。cpu始终保持50%左右甚至更高的使用率

你也可以在键盘设置里设置成通用104键盘,这样那些快捷键冲突一般都不出现。
ps:俺也是x700的,很流畅,不过我只开了几个有用的,比如scale,呵呵


_________________
http://www.classfoo.org


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-09-16 3:13 

注册: 2007-09-16 3:10
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
偶的openSUSE...ATI X600
装了fglrx之后Xserver进不去了……这里有高人知道怎么办不?
(不知道这样跑来ubuntu的论坛问suse又没有人要揍我。。。ft)


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-09-16 11:21 
头像

注册: 2007-08-04 23:13
帖子: 62
送出感谢: 0 次
接收感谢: 0 次
kiiwii 写道:
偶的openSUSE...ATI X600
装了fglrx之后Xserver进不去了……这里有高人知道怎么办不?
(不知道这样跑来ubuntu的论坛问suse又没有人要揍我。。。ft)

suse....应该可以用aticonfig配置吧。。。


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-09-16 15:31 

注册: 2006-09-02 21:23
帖子: 143
地址: Nanjing China
送出感谢: 0 次
接收感谢: 0 次
ClassFoo 写道:
kiiwii 写道:
偶的openSUSE...ATI X600
装了fglrx之后Xserver进不去了……这里有高人知道怎么办不?
(不知道这样跑来ubuntu的论坛问suse又没有人要揍我。。。ft)

suse....应该可以用aticonfig配置吧。。。

suse最好用yast配置


_________________
ASUS Z91V,1.73GHz,512M,60G,x700 64M;
Arch & windows xp


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译