安装ATI官方驱动后Docky点设置出现黑块的解决办法

GnomeShell/Unity/Beryl/AiGLX/XGL/Compiz Fusion
回复
头像
yoursaf
帖子: 233
注册时间: 2010-04-01 0:58
送出感谢: 0
接收感谢: 3 次

安装ATI官方驱动后Docky点设置出现黑块的解决办法

#1

帖子 yoursaf » 2011-01-06 23:44

因为有题中所说的现象,我差点舍弃了Docky,但那东西实在是太合我心意了,所以一直在想办法,现在终于解决了。
dock.png
这是原来的情况。
现在这个问题已经解决,如图
Screenshotdocky.png
在10.6以上版本的驱动里启用了一项新的2D加速功能,而这个功能在有些显卡上会有些小问题,
解决办法是使用原来的2D加速功能,命令是:

代码: 全选

sudo aticonfig --set-pcs-str=DDX,ForceXAA,TRUE
[/color]

然后重启机器,这个问题就OK了

代码: 全选

if ( 信春哥=true )
  {
    得永生;
    不挂科;
    赚大钱;
    不怕磕;
  }
 else
   {
     去死吧;
   }
头像
蒙毅酋长
帖子: 136
注册时间: 2009-08-29 17:55
送出感谢: 1 次
接收感谢: 1 次

Re: 安装ATI官方驱动后Docky点设置出现黑块的解决办法

#2

帖子 蒙毅酋长 » 2011-01-10 11:56

我也出现这个问题,用了好多了。 :em11
大容量Dropbox网盘请点http://db.tt/v9y9d8b2
头像
gaelookair
帖子: 48
注册时间: 2010-06-22 8:35
送出感谢: 0
接收感谢: 0

Re: 安装ATI官方驱动后Docky点设置出现黑块的解决办法

#3

帖子 gaelookair » 2011-01-21 19:44

我用了这个代码之后三维背景就直接变成灰色不能用了,每次开机还报错,有没有恢复原状的代码啊
sallon88
帖子: 7
注册时间: 2010-09-28 12:26
送出感谢: 0
接收感谢: 0

Re: 安装ATI官方驱动后Docky点设置出现黑块的解决办法

#4

帖子 sallon88 » 2011-08-23 19:09

为什么我用sudo aticonfig --set-pcs-str=DDX,ForceXAA,TRUE,重启之后没用啊,
查看日志还是显示的,fglrx(0): ATI 2D Acceleration Architecture enabled
我用的catalyst 11.8
头像
yoursaf
帖子: 233
注册时间: 2010-04-01 0:58
送出感谢: 0
接收感谢: 3 次

Re: 安装ATI官方驱动后Docky点设置出现黑块的解决办法

#5

帖子 yoursaf » 2011-08-24 9:21

貌似最新版的ATI驱动有问题。我升级到1104之后用最新的驱动开不了3D,没办法又降回来的

代码: 全选

if ( 信春哥=true )
  {
    得永生;
    不挂科;
    赚大钱;
    不怕磕;
  }
 else
   {
     去死吧;
   }
happytofly
帖子: 14
注册时间: 2008-09-08 18:49
送出感谢: 0
接收感谢: 0

Re: 安装ATI官方驱动后Docky点设置出现黑块的解决办法

#6

帖子 happytofly » 2011-08-28 7:51

另一种解决方法:打开 Metacity 的混合特效
http://linuxtoy.org/archives/enable-met ... iting.html

1. 按 Alt + F2,打开“运行应用程序”对话框。输入 gconf-editor,并按回车。
2. 导航到 Apps->metacity->general,并选中 compositing_manager。

你也可以执行下面的终端命令来打开 Metacity 的混合特效:

gconftool-2 -s '/apps/metacity/general/compositing_manager' --type bool true

要关闭 Metacity 的混合特效则执行:

gconftool-2 -s '/apps/metacity/general/compositing_manager' --type bool false
回复

回到 “桌面特效”