当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : ub10.04.2+freewins 如何安装
帖子发表于 : 2011-06-02 12:51 
头像

注册: 2009-02-06 9:18
帖子: 1080
地址: 小僧乃吐蕃国大雪山大轮寺护国法师座下四大护法之西域妖僧是也
送出感谢: 0 次
接收感谢: 11
如题,系统是10.04.2,CCSM是0.8.2,想安装freewins
我看这文章。。但是装不上,编译有错。。
有经验的朋友请指点一二。。。
http://www.dongwm.com/archives/compiz-%E5%A4%96%E6%8C%82%E6%8F%92%E4%BB%B6%E6%AC%A3%E8%B5%8F%E5%92%8C%E5%AE%89%E8%A3%85/


_________________
Laptop: i5-460m hm55 4g 320g hd5470 14'led 2.3kg (acer 4738g)
Windows XP 7 8 all in one partition.
Ubuntu 10.04 LTS
Mac OS X 10.6.7
折腾笔记
论坛随手记


页首
 用户资料  
 
2 楼 
 文章标题 : Re: ub10.04.2+freewins 如何安装
帖子发表于 : 2011-06-02 13:14 
头像

注册: 2007-06-13 15:57
帖子: 12651
地址: 在他乡
送出感谢: 54
接收感谢: 90
只能编译,
编译有错是肯定的,没错就不用求助了 :em04
接下来看LZ的了 :em09


页首
 用户资料  
 
3 楼 
 文章标题 : Re: ub10.04.2+freewins 如何安装
帖子发表于 : 2011-06-02 13:21 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 274
这插件最没用的啊。


_________________
● 鸣学


页首
 用户资料  
 
4 楼 
 文章标题 : Re: ub10.04.2+freewins 如何安装
帖子发表于 : 2011-06-02 13:26 

注册: 2009-04-11 17:27
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
看我安装的简要过程:
dongwm@dongwm:~/freewins/bulid$ cmake ..
-- Configuring done
-- Generating done
-- Build files have been written to: /home/dongwm/freewins/bulid
dongwm@dongwm:~/freewins/bulid$ make
[100%] Built target freewins
dongwm@dongwm:~/freewins/bulid$ make install
[100%] Built target freewins
Install the project...
-- Install configuration: "Debug"
-- Up-to-date: /home/dongwm/.compiz-1/metadata/freewins.xml
running /usr/bin/gconftool-2 --install-schema-file=/home/dongwm/freewins/bulid/generated/compiz-freewins.schemas > /dev/null 2>&1
-- Up-to-date: /home/dongwm/.gconf/schemas/compiz-freewins.schemas
-- Up-to-date: /home/dongwm/.compiz-1/plugins/libfreewins.so

问题可能存在:1 你的cmake版本 2 你的boost库 3 compiz版本

你可以粘贴一下你的编译报错信息


页首
 用户资料  
 
5 楼 
 文章标题 : Re: ub10.04.2+freewins 如何安装
帖子发表于 : 2011-06-02 13:43 
头像

注册: 2009-02-06 9:18
帖子: 1080
地址: 小僧乃吐蕃国大雪山大轮寺护国法师座下四大护法之西域妖僧是也
送出感谢: 0 次
接收感谢: 11
应该还是挺有用的吧,有时候展示东西给人看,角度可以转一下。。。

出错信息如下。。。

CMake Error at CMakeLists.txt:7 (compiz_plugin):
Unknown CMake command "compiz_plugin".


CMake Warning (dev) in CMakeLists.txt:
No cmake_minimum_required command is present. A line of code such as

cmake_minimum_required(VERSION 2.8)

should be added at the top of the file. The version specified may be lower
if you wish to support older CMake versions for this project. For more
information run "cmake --help-policy CMP0000".
This warning is for project developers. Use -Wno-dev to suppress it.

-- Configuring incomplete, errors occurred!

===========================翻译了一下
CMake的错误时的CMakeLists.txt:7(compiz_plugin):
未知的CMake命令“compiz_plugin“。


CMake的警告(发展)中的CMakeLists.txt:
目前没有cmake_minimum_required命令。一行代码,如

cmake_minimum_required(版本2.8)

应加在文件的顶部。指定的版本可能较低
如果你想支持这个项目的旧CMake的版本。欲了解更多
信息运行“的CMake- 帮助政策CMP0000“。
此警告的项目开发。使用- Wno- dev的镇压。

- 配置不完整,错误发生!


_________________
Laptop: i5-460m hm55 4g 320g hd5470 14'led 2.3kg (acer 4738g)
Windows XP 7 8 all in one partition.
Ubuntu 10.04 LTS
Mac OS X 10.6.7
折腾笔记
论坛随手记


页首
 用户资料  
 
6 楼 
 文章标题 : Re: ub10.04.2+freewins 如何安装
帖子发表于 : 2011-06-02 13:59 

注册: 2009-04-11 17:27
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
缺少comizplugin库 你boost库都安装了什么?我比较懒 你可以参看一下我安装了什么boost库 :
dongwm@dongwm:~/freewins/bulid$ dpkg --list |grep boost
ii boost-build 2.0-m12-2 cross-platform build system for C++ projects
ii libboost-all-dev 1.42.0.1ubuntu1 Boost C++ Libraries development files (ALL, default version)
ii libboost-date-time-dev 1.42.0.1ubuntu1 date-time libraries based on generic programming (default version)
ii libboost-date-time1.42-dev 1.42.0-4ubuntu2 set of date-time libraries based on generic programming concepts
ii libboost-date-time1.42.0 1.42.0-4ubuntu2 set of date-time libraries based on generic programming concepts
ii libboost-dbg 1.42.0.1ubuntu1 Boost C++ Libraries with debug symbols
ii libboost-dev 1.42.0.1ubuntu1 Boost C++ Libraries development files (default version)
ii libboost-doc 1.42.0.1ubuntu1 Boost C++ Libraries documentation (default version)
ii libboost-filesystem-dev 1.42.0.1ubuntu1 filesystem operations in C++ (default version)
ii libboost-filesystem1.42-dev 1.42.0-4ubuntu2 filesystem operations (portable paths, iteration over directories, etc) in C++
ii libboost-filesystem1.42.0 1.42.0-4ubuntu2 filesystem operations (portable paths, iteration over directories, etc) in C++
ii libboost-graph-dev 1.42.0.1ubuntu1 generic graph components and algorithms in C++ (default version)
ii libboost-graph-parallel-dev 1.42.0-4ubuntu2 generic graph components and algorithms in C++ (default version)
ii libboost-graph-parallel1.42-dev 1.42.0-4ubuntu2 generic graph components and algorithms in C++
ii libboost-graph-parallel1.42.0 1.42.0-4ubuntu2 generic graph components and algorithms in C++
ii libboost-graph1.42-dev 1.42.0-4ubuntu2 generic graph components and algorithms in C++
ii libboost-graph1.42.0 1.42.0-4ubuntu2 generic graph components and algorithms in C++
ii libboost-iostreams-dev 1.42.0.1ubuntu1 Boost.Iostreams Library development files (default version)
ii libboost-iostreams1.42-dev 1.42.0-4ubuntu2 Boost.Iostreams Library development files
ii libboost-iostreams1.42.0 1.42.0-4ubuntu2 Boost.Iostreams Library
ii libboost-math-dev 1.42.0.1ubuntu1 Boost.Math Library development files (default version)
ii libboost-math1.42-dev 1.42.0-4ubuntu2 Boost.Math Library development files
ii libboost-math1.42.0 1.42.0-4ubuntu2 Boost.Math Library
ii libboost-mpi-dev 1.42.0-4ubuntu2 C++ interface to the Message Passing Interface (MPI) (default version)
ii libboost-mpi-python-dev 1.42.0-4ubuntu2 Python interface to the Message Passing Interface (MPI) (default version)
ii libboost-mpi-python1.42-dev 1.42.0-4ubuntu2 C++ interface to the Message Passing Interface (MPI), Python Bindings
ii libboost-mpi-python1.42.0 1.42.0-4ubuntu2 C++ interface to the Message Passing Interface (MPI), Python Bindings
ii libboost-mpi1.42-dev 1.42.0-4ubuntu2 C++ interface to the Message Passing Interface (MPI)
ii libboost-mpi1.42.0 1.42.0-4ubuntu2 C++ interface to the Message Passing Interface (MPI)
ii libboost-program-options-dev 1.42.0.1ubuntu1 program options library for C++ (default version)
ii libboost-program-options1.42-dev 1.42.0-4ubuntu2 program options library for C++
ii libboost-program-options1.42.0 1.42.0-4ubuntu2 program options library for C++
ii libboost-python-dev 1.42.0.1ubuntu1 Boost.Python Library development files (default version)
ii libboost-python1.42-dev 1.42.0-4ubuntu2 Boost.Python Library development files
ii libboost-python1.42.0 1.42.0-4ubuntu2 Boost.Python Library
ii libboost-regex-dev 1.42.0.1ubuntu1 regular expression library for C++ (default version)
ii libboost-regex1.42-dev 1.42.0-4ubuntu2 regular expression library for C++
ii libboost-regex1.42.0 1.42.0-4ubuntu2 regular expression library for C++
ii libboost-serialization-dev 1.42.0.1ubuntu1 serialization library for C++ (default version)
ii libboost-serialization1.42-dev 1.42.0-4ubuntu2 serialization library for C++
ii libboost-serialization1.42.0 1.42.0-4ubuntu2 serialization library for C++
ii libboost-signals-dev 1.42.0.1ubuntu1 managed signals and slots library for C++ (default version)
ii libboost-signals1.42-dev 1.42.0-4ubuntu2 managed signals and slots library for C++
ii libboost-signals1.42.0 1.42.0-4ubuntu2 managed signals and slots library for C++
ii libboost-system-dev 1.42.0.1ubuntu1 Operating system (e.g. diagnostics support) library (default version)
ii libboost-system1.42-dev 1.42.0-4ubuntu2 Operating system (e.g. diagnostics support) library
ii libboost-system1.42.0 1.42.0-4ubuntu2 Operating system (e.g. diagnostics support) library
ii libboost-test-dev 1.42.0.1ubuntu1 components for writing and executing test suites (default version)
ii libboost-test1.42-dev 1.42.0-4ubuntu2 components for writing and executing test suites
ii libboost-test1.42.0 1.42.0-4ubuntu2 components for writing and executing test suites
ii libboost-thread-dev 1.42.0.1ubuntu1 portable C++ multi-threading (default version)
ii libboost-thread1.42-dev 1.42.0-4ubuntu2 portable C++ multi-threading
ii libboost-thread1.42.0 1.42.0-4ubuntu2 portable C++ multi-threading
ii libboost-wave-dev 1.42.0.1ubuntu1 C99/C++ preprocessor library (default version)
ii libboost-wave1.42-dev 1.42.0-4ubuntu2 C99/C++ preprocessor library
ii libboost-wave1.42.0 1.42.0-4ubuntu2 C99/C++ preprocessor library
ii libboost1.42-all-dev 1.42.0-4ubuntu2 Boost C++ Libraries development files (ALL)
ii libboost1.42-dbg 1.42.0-4ubuntu2 Boost C++ Libraries with debug symbols
ii libboost1.42-dev 1.42.0-4ubuntu2 Boost C++ Libraries development files
ii libboost1.42-doc 1.42.0-4ubuntu2 Boost.org libraries documentation


页首
 用户资料  
 
7 楼 
 文章标题 : Re: ub10.04.2+freewins 如何安装
帖子发表于 : 2011-06-02 14:00 

注册: 2009-04-11 17:27
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
dongwm@dongwm:~/freewins/bulid$ dpkg --list |grep cmake
ii cmake 2.8.3-3ubuntu7 a cross-platform, open-source make system
ii cmake-curses-gui 2.8.3-3ubuntu7 curses based user interface for CMake (ccmake)
ii cmake-data 2.8.3-3ubuntu7 CMake data files (modules, templates and documentation)
ii cmake-dbg 2.8.3-3ubuntu7 debugging symbols for CMake
ii cmake-doc 2.8.3-3ubuntu7 extended documentation in various formats for CMake
ii cmake-qt-gui 2.8.3-3ubuntu7 Qt4 based user interface for CMake (cmake-gui)


页首
 用户资料  
 
8 楼 
 文章标题 : Re: ub10.04.2+freewins 如何安装
帖子发表于 : 2011-06-02 15:12 
头像

注册: 2009-02-06 9:18
帖子: 1080
地址: 小僧乃吐蕃国大雪山大轮寺护国法师座下四大护法之西域妖僧是也
送出感谢: 0 次
接收感谢: 11
挺难搞,装了一大堆东西了,错误还是一样。。。


_________________
Laptop: i5-460m hm55 4g 320g hd5470 14'led 2.3kg (acer 4738g)
Windows XP 7 8 all in one partition.
Ubuntu 10.04 LTS
Mac OS X 10.6.7
折腾笔记
论坛随手记


页首
 用户资料  
 
9 楼 
 文章标题 : Re: ub10.04.2+freewins 如何安装
帖子发表于 : 2011-06-02 15:26 

注册: 2009-04-11 17:27
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
和你聊1个细节:你是在freewins目录下创建一个build目录 然后cd到build目录 再执行 cmake .. 嘛?不能在freewins目录下执行 cmake .


页首
 用户资料  
 
10 楼 
 文章标题 : Re: ub10.04.2+freewins 如何安装
帖子发表于 : 2011-06-02 15:31 

注册: 2009-04-11 17:27
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
我建议你把build目录下的文件全部删除了 重新cmake


页首
 用户资料  
 
11 楼 
 文章标题 : Re: ub10.04.2+freewins 如何安装
帖子发表于 : 2011-06-02 17:21 
头像

注册: 2009-02-06 9:18
帖子: 1080
地址: 小僧乃吐蕃国大雪山大轮寺护国法师座下四大护法之西域妖僧是也
送出感谢: 0 次
接收感谢: 11
ciici 写道:
我建议你把build目录下的文件全部删除了 重新cmake


有删除过。。。


_________________
Laptop: i5-460m hm55 4g 320g hd5470 14'led 2.3kg (acer 4738g)
Windows XP 7 8 all in one partition.
Ubuntu 10.04 LTS
Mac OS X 10.6.7
折腾笔记
论坛随手记


页首
 用户资料  
 
12 楼 
 文章标题 : Re: ub10.04.2+freewins 如何安装
帖子发表于 : 2011-06-02 17:30 

注册: 2009-04-11 17:27
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
难道是人品。。。 这个文件你有嘛 /usr/share/compiz/cmake/CompizPlugin.cmake


页首
 用户资料  
 
13 楼 
 文章标题 : Re: ub10.04.2+freewins 如何安装
帖子发表于 : 2011-06-02 17:59 
头像

注册: 2009-02-06 9:18
帖子: 1080
地址: 小僧乃吐蕃国大雪山大轮寺护国法师座下四大护法之西域妖僧是也
送出感谢: 0 次
接收感谢: 11
会不会是这个原因,有两个包没装上


有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
libboost-mpi-dev: 依赖: libboost-mpi1.40-dev 但无法安装它
E: 破损的软件包


_________________
Laptop: i5-460m hm55 4g 320g hd5470 14'led 2.3kg (acer 4738g)
Windows XP 7 8 all in one partition.
Ubuntu 10.04 LTS
Mac OS X 10.6.7
折腾笔记
论坛随手记


页首
 用户资料  
 
14 楼 
 文章标题 : Re: ub10.04.2+freewins 如何安装
帖子发表于 : 2011-06-02 18:02 
头像

注册: 2009-02-06 9:18
帖子: 1080
地址: 小僧乃吐蕃国大雪山大轮寺护国法师座下四大护法之西域妖僧是也
送出感谢: 0 次
接收感谢: 11
那个文件没有。。。
git:版本控制工具,linux之父所作!一般更新包文件都使用这个工具,我们要下载的compiz插件都是git版本控制
还有这个GIT也没装到,似乎没有这个包。。。


_________________
Laptop: i5-460m hm55 4g 320g hd5470 14'led 2.3kg (acer 4738g)
Windows XP 7 8 all in one partition.
Ubuntu 10.04 LTS
Mac OS X 10.6.7
折腾笔记
论坛随手记


页首
 用户资料  
 
15 楼 
 文章标题 : Re: ub10.04.2+freewins 如何安装
帖子发表于 : 2011-06-02 18:12 

注册: 2009-04-11 17:27
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
弱弱的问一下 没有git 你怎么下载的freewins?那mpi的包我的确是有的 你修复一下?还有我刚才说的那个目录文件,我传给你你直接在那个目录下解压 试一 下 文件权限是root
附件:
compizforcmake.tar.gz [8.2 KiB]
被下载 14 次


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译