当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 36 篇帖子 ]  前往页数 1, 2, 3  下一页
作者 内容
1 楼 
 文章标题 : [求助][已解决]请教beryl安装步骤的最新版本
帖子发表于 : 2006-12-08 16:27 
头像

注册: 2005-12-15 21:52
帖子: 351
送出感谢: 0 次
接收感谢: 0 次
我的本本是Hp nx6330,intel 64bit双核的,显卡ati x1300 128mb,按照beryl安装需要的配置,
运行起来应该没有问题,但是我参考了网上和论坛上许多兄弟的安装方法,都没有获得成功。
请问诸位兄弟有没有比较权威的安装手册可以参考。

我目前的安装情况如下:
操作系统edgy amd64位,显卡驱动使用源里的fglrx,fglrxinfo能显示ati标志,不是mesa。
使用了将xgl加入启动程序和将xgl加入会话的方法,均不能进入beryl
倒是第一次尝试时没安装xgl和fglrx,直接用vesa驱动上的beryl还出现了beryl0.1.2跳动的图标,
但是因为没有3d加速而出现不了3d桌面。

看到不少用hp笔记本的兄弟都成功了(据说非常简单,所以连步骤都没写 :?: ),特请大家分享一下成功安装的经验。


最后由 spider5 编辑于 2007-01-11 1:15,总共编辑了 3 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-12-08 17:12 

注册: 2006-01-08 19:24
帖子: 68
地址: 广州
送出感谢: 0 次
接收感谢: 0 次
先在论坛搜索一下相关的安装方法


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-12-08 19:38 
头像

注册: 2005-12-15 21:52
帖子: 351
送出感谢: 0 次
接收感谢: 0 次
搜了一堆,各人描述都有差异,我在1楼也说了。
所以才提问,楼上的参考的是哪一个,贴出链接来看看。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-12-08 22:22 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
ati的显卡是比较麻烦,还不如intel的集成显卡容易设置beryl。你看看下面的连接行不行。

http://wiki.beryl-project.org/wiki/Inst ... Edgy/AiGLX


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-12-09 0:16 
头像

注册: 2005-12-15 21:52
帖子: 351
送出感谢: 0 次
接收感谢: 0 次
这篇文章看过了,当初出现beryl的图标就是按照这个guide做的,但是里面一个字也没有提到ati呀,
难道默认支持了?

先谢谢楼上。

已经超过12点,明天继续向大家请教。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-12-09 6:26 
头像

注册: 2006-05-13 4:02
帖子: 10606
送出感谢: 0 次
接收感谢: 7
看那里的xgl.
ati的卡现在只能用xgl,aiglx很不好。


_________________
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-12-10 3:04 
头像

注册: 2005-12-15 21:52
帖子: 351
送出感谢: 0 次
接收感谢: 0 次
谢谢zhuqin的提示,但是没有用,只能配置好xgl,beryl还是不行。

我一运行beryl-manager立刻就出现
代码:
beryl拦截到致命信号 11


有没有用ati卡的兄弟提供一下方法呀。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-12-10 10:07 

注册: 2006-02-12 22:24
帖子: 208
送出感谢: 0 次
接收感谢: 0 次
先要装好驱动,开启加速,不然beryl跑不起来.
1>装驱动 http://wiki.cchtml.com/index.php/Ubuntu ... tion_Guide 用第一个,比较简单.
2>装xgl/beryl http://wiki.beryl-project.org/index.php ... u/Edgy/XGL
*我的环境是p2.4c+ati9550


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-12-10 16:28 
头像

注册: 2005-12-15 21:52
帖子: 351
送出感谢: 0 次
接收感谢: 0 次
谢谢fuoren的回复,不过可能是你的显卡跟我的差太远了,所以你能成功的我就不行。另外你说的开启加速是指什么操作?
驱动的安装我就是照这个装的,能成功运行xgl说明没有安装错。昨天我还试了方法二的8.31.5,结果连xgl都启动不了了,直接黑屏。

现在我是希望有用64位系统的x1000以上显卡的兄弟出来给我指导一下这次安装尝试过的方法很多,等安装成功后一定把经历都贴出来,希望以后的兄弟少走弯路。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-12-10 17:24 
头像

注册: 2005-12-15 21:52
帖子: 351
送出感谢: 0 次
接收感谢: 0 次
不等你们的建议了,先从重装系统,开始,记录每一步过程。
硬件:
代码:
hp nx6330 709pa
cpu intel core 2 duo T5600
ram 512Mb
显卡 ati x1300 series 128Mb 独显

安装光盘 edgy-amd64-alternate,自己刻的。
分区5个,保留了hp的救援恢复分区,另分成/boot,/,/home,格式reiserf
选这种格式的原因是分区数据不容易损坏,swap。保留/home的数据
断网安装,否则在安装到92%时会长期停滞。
大约花费25分钟安装完成。


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2006-12-10 17:54 
头像

注册: 2005-12-15 21:52
帖子: 351
送出感谢: 0 次
接收感谢: 0 次
进入gnome桌面,配置网络,现在还没有输入法。
进入软件源,将universe和multiuni选上,否则装beryl时会提示找不到软件源。更改后软件源会自动更新。
更新期间顺便看了一下默认的显卡驱动,是vesa的。
把输入法补上。
代码:
sudo apt-get install im-switch scim-pinyin

直接切换输入法,登出,再登入一次,现在能用scim输入了,我只用拼音,用别的输入法可以装其他包。
代码:
sudo im-switch -s scim -z default

执行这一步时会有提示安装scim-qtimm,不必理睬。


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2006-12-10 18:32 
头像

注册: 2005-12-15 21:52
帖子: 351
送出感谢: 0 次
接收感谢: 0 次
edgy的firefox似乎有问题,把google硬导航到google.com/firefox去了,弄得现在google经常上不去,不知道大家有没有解决方法。
嫌亚洲官服的速度有点慢,测试了一下,清华的速度最快,于是又改了一次sources.list。不过好像无效的链接非常多。
安装ati驱动,参考
http://wiki.cchtml.com/index.php/Ubuntu ... tion_Guide
这个和zhuqin兄写的中文版差不多,但是其中多出的几步是不能少的,也许是amd64版本特有的现象。

sudo vi /etc/X11/xorg.conf
在最后插入这段,关于disable,有写false的,有写0的,估计效果差不多
代码:
Section "Extensions"
        Option  "Composite" "Disable"
EndSection


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2006-12-10 20:49 
头像

注册: 2005-12-15 21:52
帖子: 351
送出感谢: 0 次
接收感谢: 0 次
代码:
sudo apt-get update
sudo apt-get install linux-restricted-modules-$(uname -r)
sudo apt-get install xorg-driver-fglrx
sudo depmod -a
sudo aticonfig --initial
sudo aticonfig --overlay-type=Xv

安装过程会要求插入edgy的光盘
给我装的是2.6.17-10
aticonfig的第二步出现两个warning,意思是对当前会话无效。
ok,重新启动。


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2006-12-10 20:58 
头像

注册: 2005-12-15 21:52
帖子: 351
送出感谢: 0 次
接收感谢: 0 次
今天的论坛慢得让人无法忍受啊。
进入gdm,输入fglrxinfo,还有glxinfo。
输出
代码:
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon X1300 Generic
OpenGL version string: 2.0.6011 (8.28.8)

为了保险,先在xorg.conf里加入一行
代码:
Option      "XaaNoOffscreenPixmaps"


ok,显卡驱动安装完成。
8.28.8版驱动不支持aiglx的证据。
代码:
~:/usr/lib/dri$ nm -D fglrx_dri.so | grep -i __driCreateNewScreen
>>no output<<
~:/usr/lib/dri$ nm -D radeon_dri.so | grep -i __driCreateNewScreen
00000000000392d0 T __driCreateNewScreen_20050727
~:/usr/lib/dri$ nm -D r300_dri.so | grep -i __driCreateNewScreen
0000000000035100 T __driCreateNewScreen_20050727


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2006-12-10 21:59 
头像

注册: 2005-12-15 21:52
帖子: 351
送出感谢: 0 次
接收感谢: 0 次
继续,安装beryl
参考的是这个链接
http://wiki.beryl-project.org/index.php ... u/Edgy/XGL
已经失败多次了,不抱很大希望,不行就换显卡驱动。

代码:
ping ubuntu.beryl-project.org
PING ubuntu.beryl-project.org (80.77.247.17) 56(84) bytes of data.
64 bytes from lupine.me.uk (80.77.247.17): icmp_seq=1 ttl=46 time=300 ms
64 bytes from lupine.me.uk (80.77.247.17): icmp_seq=2 ttl=46 time=300 ms
64 bytes from lupine.me.uk (80.77.247.17): icmp_seq=3 ttl=46 time=300 ms
64 bytes from lupine.me.uk (80.77.247.17): icmp_seq=4 ttl=46 time=300 ms


在/etc/apt/sources.list中加入一行
代码:
deb http://ubuntu.beryl-project.org/ edgy main main-edgy main-edgy-amd64

然后
代码:
wget http://beryl-mirror.lupine.me.uk/1609B551.gpg -O- | sudo apt-key add -
sudo apt-get update


最后由 spider5 编辑于 2006-12-10 22:13,总共编辑了 3 次

页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 36 篇帖子 ]  前往页数 1, 2, 3  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译