[问题]配置xgl出现问题!wiki中没有找到解决办法,求老鸟出主意

GnomeShell/Unity/Beryl/AiGLX/XGL/Compiz Fusion
回复
suluoniu
帖子: 10
注册时间: 2006-12-20 15:51
送出感谢: 0
接收感谢: 0

[问题]配置xgl出现问题!wiki中没有找到解决办法,求老鸟出主意

#1

帖子 suluoniu » 2006-12-28 0:39

我的硬件是cd341+ATI X1600PRO+1G+SATA
按照英文wiki装的fglrx驱动,返回信息正确
按照这个wiki安装xgl,beryl

配置xgl的两种方法都试过了,
第一种 方法出现如下问题,选择xgl登录后,出现如下提示:
Xsession:unable to launch "/usr/local/bin/startxgl.sh"
Xsession --- "/usr/local/bin/startxgl.sh
"not found;falling back to default session
第二种 出现花屏现象,郁闷,高手帮忙。
.



配置xgl(两种方法,二选一)

方法一:在登录对话界面加入xgl选框

sudo gedit /usr/local/bin/startxgl.sh

内容如下:

#!/bin/sh

Xgl -fullscreen :1 -ac -br -accel glx:pbuffer -accel xv:pbuffer &

sleep 4

export DISPLAY=:1

exec gnome-session

如果出现问题的话,尝试

#!/bin/sh

Xgl :1 -fullscreen -ac -br -accel glx:pbuffer -accel xv:pbuffer &

sleep 4

export DISPLAY=:1

exec gnome-session

然后 sudo chmod a+x /usr/local/bin/startxgl.sh

注:如果使用以上脚本导致你的字体或鼠标配置不能正常载入,那么用"exec

/etc/X11/Xsession"代替上面的“exec gnome-session”

sudo gedit /usr/share/xsessions/xgl.desktop

内容:

[Desktop Entry]

Encoding=UTF-8

Name=Xgl

Exec=/usr/local/bin/startxgl.sh

Icon=

Type=Application

OK,登出,在选择会话选框里面就会出现xgl选项了。

方法二:修改gdm.conf启动xgl

sudo gedit /etc/gdm/gdm.conf-custom

在文件的最后加入

0=Xgl

[server-Xgl]

name=Xgl server

command=/usr/bin/Xgl :0 -fullscreen -ac -accel glx:pbuffer -accel xv:fbo

flexible=true

重启,系统就会自动启动xgl了。
上次由 suluoniu 在 2006-12-28 11:16,总共编辑 1 次。
suluoniu
帖子: 10
注册时间: 2006-12-20 15:51
送出感谢: 0
接收感谢: 0

#2

帖子 suluoniu » 2006-12-28 11:14

求救高手!!!!!!!!!!!!!
wolfjiao
帖子: 32
注册时间: 2006-11-06 14:01
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 wolfjiao » 2006-12-28 11:35

卸掉重新安装beryl
suluoniu
帖子: 10
注册时间: 2006-12-20 15:51
送出感谢: 0
接收感谢: 0

#4

帖子 suluoniu » 2006-12-28 11:53

可是我都没有让beryl它启动啊
wolfjiao
帖子: 32
注册时间: 2006-11-06 14:01
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 wolfjiao » 2006-12-28 12:29

如果 ps -A|grep Xgl有返回信息的话,重新安装Beryl.

用方法一启动。

sudo gedit /etc/gdm/gdm.conf

查找GdmXserverTimeout=10
修改为
GdmXserverTimeout=50


sudo gedit /etc/X11/xorg.conf
察看 device

代码: 全选

Section "Device"
	Identifier	"ATI Technologies, Inc. Radeon X850 Pro (R480)"
	Driver		"radeon"
#	Option		"AGPFastWrite" "yes"  
#	Option		"AGPMode" "4"
	Option		"ColorTiling" "on"
	Option		"EnablePageFlip" "true"
	Option		"AccelMethod" "EXA"
	Option		"XAANoOffScreenPixMaps"
	Option		"RenderAccel" "true"
	Option		"DRI" "true"
	BusID		"PCI:1:0:0"
最后加上

代码: 全选


Section "Extensions"
	Option	    "Composite" "0"
EndSection
[/code]
suluoniu
帖子: 10
注册时间: 2006-12-20 15:51
送出感谢: 0
接收感谢: 0

#6

帖子 suluoniu » 2007-01-04 9:29

我试了还是不行,重新装系统还是不行,!!
suluoniu
帖子: 10
注册时间: 2006-12-20 15:51
送出感谢: 0
接收感谢: 0

#7

帖子 suluoniu » 2007-01-04 9:35

我难道真的人品有问题,没有搜索到别人有这个问题
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#8

帖子 BigSnake.NET » 2007-01-04 13:08

/usr/local/bin/startxgl.sh
chmod了麽。。。
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
回复

回到 “桌面特效”