当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 我在安装beryl遇到的问题,有安装步骤,求高人指点
帖子发表于 : 2007-01-02 21:53 

注册: 2006-11-20 11:56
帖子: 34
地址: 北京
送出感谢: 0 次
接收感谢: 0 次
我刚才装的beryl出问题拉
窗口边框没有,而且没有一点beryl效果,而且还有点卡
我的笔记本是:
Hewlett-Packard HP Pavilion ze2202

AMD Mobile Sempron 2800+ (1.60 gigahertz)

ATI RADEON XPRESS 200M (共享显卡,最高128MB)

Windows XP Professional Service Pack 2

Ubuntu Edgy 6.10
(我的笔记本能不能达到beryl要求的最低配置阿?)
我的安装步骤是:
显卡:
sudo apt-get install xorg-driver-fglrx

sudo depmod -a

sudo aticonfig --initial

sudo aticonfig --overlay-type=Xv
(我在执行上面的结果:perry@perry:~$ sudo aticonfig --initial
Uninitialised file found, configuring.
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.original-0)
添加源
sudo gedit /etc/apt/sources.list


deb http://www.beerorkid.com/compiz edgy main-edgy

deb http://media.blutkind.org/xgl/ edgy main-edgy

deb http://compiz-mirror.lupine.me.uk/ edgy main-edgy

deb http://ubuntu.compiz.net/ edgy main-edgy


加入钥匙:

wget http://www.beerorkid.com/compiz/quinn.key.asc -O - | sudo apt-key add -

wget http://media.blutkind.org/xgl/quinn.key.asc -O - | sudo apt-key add -

wget http://compiz-mirror.lupine.me.uk/quinn.key.asc -O - | sudo apt-key add -

wget http://ubuntu.compiz.net/quinn.key.asc -O - | sudo apt-key add -

刷新

sudo apt-get update


安装xgl和beryl:

sudo apt-get install xserver-xgl

sudo apt-get install beryl emerald emerald-themes

.配置xgl

sudo gedit /usr/local/bin/startxgl.sh

内容如下:

#!/bin/sh

Xgl -fullscreen :1 -ac -br -accel glx:pbuffer -accel xv:pbuffer &

sleep 4

export DISPLAY=:1

exec gnome-session



然后 sudo chmod a+x /usr/local/bin/startxgl.sh

sudo gedit /usr/share/xsessions/xgl.desktop

内容:

[Desktop Entry]

Encoding=UTF-8

Name=Xgl

Exec=/usr/local/bin/startxgl.sh

Icon=

Type=Application

在选择会话选框里面就会出现xgl选项。

启动beryl(也有三种办法)

主菜单-系统-首选项-会话-启动程序 添加 beryl-manager。(这种方法在不启

动xgl的时候beryl也会启动。)


结果就是我上面说的这样的问题拉
不知道怎么解决拉,也看拉很多贴子,现在对于beryl很迷茫阿~
请高手指点~~~


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-01-02 22:01 

注册: 2006-11-20 11:56
帖子: 34
地址: 北京
送出感谢: 0 次
接收感谢: 0 次
PS:
不过我看到“红宝石”拉


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-01-02 22:18 

注册: 2006-11-20 11:56
帖子: 34
地址: 北京
送出感谢: 0 次
接收感谢: 0 次
perry@perry:~$ fglrxinfo
Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5.1)

还有这样的信息


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-01-03 0:35 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
看来你找的方法对于你现在的版本过时了。

http://forum.ubuntu.org.cn/viewtopic.php?t=26309这个看了吗。


_________________
● 鸣学


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-01-03 1:17 

注册: 2006-11-20 11:56
帖子: 34
地址: 北京
送出感谢: 0 次
接收感谢: 0 次

我马上看看 去

现在又出现拉新的错误
我在终端运行beryl-manager时
出现:
perry@perry:~$ beryl-manager
perry@perry:~$ Xlib: extension "XFree86-DRI" missing on display ":0.0".
XGL Absent, checking for NVIDIA
Nvidia Absent, checking for texture_from_pixmap
texture_from_pixmap Present
Xlib: extension "XFree86-DRI" missing on display ":0.0".
beryl: glXBindTexImageEXT is missing
beryl: Failed to manage screen: 0
beryl: No manageable screens found on display :0.0

** (emerald:19474): WARNING **: Choose same size glow images for active and inactive windows.
Inactive glow image is scaled for now.

** (emerald:19468): WARNING **: Choose same size glow images for active and inactive windows.
Inactive glow image is scaled for now.

** (emerald:19469): WARNING **: Choose same size glow images for active and inactive windows.
Inactive glow image is scaled for now.


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-01-03 1:29 

注册: 2006-11-20 11:56
帖子: 34
地址: 北京
送出感谢: 0 次
接收感谢: 0 次
我按照wiki里安装驱动的步骤安装:
perry@perry:~$ sudo aticonfig --initial
Found fglrx primary device section
Nothing to do, terminating.
perry@perry:~$ sudo aticonfig --overlay-type=Xv
Warning: Option 'VideoOverlay' doesn't affect running session.
Warning: Option 'OpenGLOverlay' doesn't affect running session.
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.fglrx-1

得到这样的提示!
不知道为什么?


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-01-03 2:04 

注册: 2006-12-14 3:00
帖子: 614
送出感谢: 0 次
接收感谢: 0 次
你描述的现象跟我前几天遇到的现象差不多。依据你的描述,应该照这个办法就可以解决:


Disable Composite Extension

In Ubuntu Edgy the Composite extension is enabled by default, however, fglrx does not yet support Composite with DRI. In order to disable Composite you have to edit the xorg.conf file:
代码:
sudo gedit /etc/X11/xorg.conf


and add these lines at the end of the file: File: /etc/X11/xorg.conf
代码:
Section "Extensions"
        Option  "Composite" "Disable"
EndSection



具体的你可以看
http://wiki.cchtml.com/index.php/Ubuntu ... tion_Guide


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译