当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 27 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 另类的beryl安装法(快捷安装方法在里面第9楼)
帖子发表于 : 2007-01-20 13:11 

注册: 2006-08-29 23:08
帖子: 210
地址: 广东茂名
送出感谢: 0 次
接收感谢: 0 次
另类的安装beryl方法

(这个方法较麻烦,快捷的安装方法在下面第9楼中有具体记述)


下面我说的是自己的真实安装过程,
高手看了后可能会哑然失笑,但不要拍砖,有类似不幸经历的,可以模仿,
没有这困难的不用多此一举。

我的现实困难是“网速比蜗牛快一点点,‘找不到软件包’‘ 连接服务器超时’‘有几个软件包无法下载’”。
准备工具:多线程下载软件:d4x(Downloader for X),推荐用MultiGet
http://multiget.sourceforge.net/index_cn.html(这是我用过的最快的下载软件)


_________________
做一个精通linux的高手--不易;
做一个熟练的linux使用者--不难。


最后由 feng3243 编辑于 2007-02-02 1:15,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-01-20 13:11 

注册: 2006-08-29 23:08
帖子: 210
地址: 广东茂名
送出感谢: 0 次
接收感谢: 0 次
好,转入正题。

1、我的爱机的配置是“赛扬2.4G,FX5200,256DDR”,当得知可以试试3D桌面时,不禁蠢蠢欲动,于是,心动不如行动,便开始了。

先在论坛上搜索了一大堆东东,终于找到了一篇“Beryl 0.1.2+Dapper+XGL安装指南-12.10更新”
http://forum.ubuntu.org.cn/viewtopic.ph ... highlight=
我一直用的都是6.06,这东西最适合我。

(1)按照milkboy_x的这教程,我先到
nv的:
http://wiki.ubuntu.org.cn/NVIDIA%E6%98% ... 7%E5%8D%97
ati的:
http://wiki.ubuntu.org.cn/ATI%E6%98%BE% ... 7%E5%8D%97

这地方,按照方法装显卡驱动。

(2)装着着,突然出现了“从服务器读取数据时出错,对方关闭了连接”“连接服务器超时”等等问题。这样试了几次,都是如此,看来真的与Bery无缘了。沮丧了一分钟后,我一发火,重来。
当再出现“从服务器读取数据时出错,对方关闭了连接”“连接服务器超时”的返回迅息时,我把这些全复制下来,然后打开下载软件MultiGe,嘿嘿,你知道怎么做了吧,按照那些网址,一个一个的把它们下载,过不了多久,真的把那些软件包下载了。于是,一个一个的安装上。

再按照安装教程设置:
sudo nvidia-xconfig
删除 nVidia 标志


_________________
做一个精通linux的高手--不易;
做一个熟练的linux使用者--不难。


最后由 feng3243 编辑于 2007-01-20 13:23,总共编辑了 2 次

页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-01-20 13:12 

注册: 2006-08-29 23:08
帖子: 210
地址: 广东茂名
送出感谢: 0 次
接收感谢: 0 次
2、再按照“Beryl 0.1.2+Dapper+XGL安装指南-12.10更新”第三步:
sudo gedit /etc/apt/sources.list,添加下列的源
deb http://beryl-mirror.lupine.me.uk dapper main
deb-src http://beryl-mirror.lupine.me.uk dapper main

可是,当进行
运行下列安装钥匙
wget http://beryl-mirror.lupine.me.uk/1609B551.gpg -O- | sudo apt-key add -

时,结果都是一样

wget http://beryl-mirror.lupine.me.uk/1609B551.gpg -O- | sudo apt-key add -
--01:16:02-- http://beryl-mirror.lupine.me.uk/1609B551.gpg
=> `-'
正在解析主机 beryl-mirror.lupine.me.uk... 失败:Name or service not known。
gpg: 找不到有效的 OpenPGP 数据。

或者干脆“连接失败”。

不知为乜,应该不是教程出问题,那么多人都搞掂了,自己,唉。


_________________
做一个精通linux的高手--不易;
做一个熟练的linux使用者--不难。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-01-20 13:13 

注册: 2006-08-29 23:08
帖子: 210
地址: 广东茂名
送出感谢: 0 次
接收感谢: 0 次
再找
找啊找啊,不知怎样,找到外婆桥时,来到了这个网站
http://ubuntu.beryl-project.org/
http://ubuntu.beryl-project.org/dists/dapper/main/

按照里面的提示
(1)设置安装源
sudo gedit /etc/apt/sources.list
deb http://ubuntu.beryl-project.org dapper main
deb-src http://ubuntu.beryl-project.org dapper main

(2)运行里面的安装钥匙
wget http://ubuntu.beryl-project.org/root@lupine.me.uk.gpg -O- | sudo apt-key add -


竟然下载成功了!!!!!!!!!!!!


(3)好,安装beryl…………
sudo apt-get install xserver-xgl libgl1-mesa xserver-xorg libglitz-glx1 beryl emerald-themes


_________________
做一个精通linux的高手--不易;
做一个熟练的linux使用者--不难。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-01-20 13:13 

注册: 2006-08-29 23:08
帖子: 210
地址: 广东茂名
送出感谢: 0 次
接收感谢: 0 次
随后,出现了一下“壮观”场面:

正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
libgl1-mesa 已经是最新的版本了。
xserver-xorg 已经是最新的版本了。
将会安装下列额外的软件包:
beryl-core beryl-manager beryl-plugins beryl-plugins-data beryl-settings
emerald libxcomposite1
下列【新】软件包将被安装:
beryl beryl-core beryl-manager beryl-plugins beryl-plugins-data
beryl-settings emerald emerald-themes libglitz-glx1 libxcomposite1
xserver-xgl
共升级了 0 个软件包,新安装了 11 个软件包,要卸载 0 个软件包,有 10 个软件未被升 级。
需要下载 8032kB 的软件包。
解压缩后会消耗掉 21.9MB 的额外空间。
您希望继续执行吗?[Y/n]y
获取:1 http://ubuntu.beryl-project.org dapper/main libxcomposite1 1:0.3-0ubuntu 1 [11.9kB]
获取:2 http://ubuntu.beryl-project.org dapper/main beryl-core 0.1.1-0ubuntu1 [6 47kB]
错误 http://ubuntu.beryl-project.org dapper/main beryl-core 0.1.1-0ubuntu1
连接服务器超时 [IP: 64.15.154.150 80]
获取:3 http://ubuntu.beryl-project.org dapper/main beryl-plugins-data 0.1.1-0ub untu1 [1604kB]
错误 http://ubuntu.beryl-project.org dapper/main beryl-plugins-data 0.1.1-0ubunt u1
连接服务器超时 [IP: 64.15.154.150 80]
获取:4 http://ubuntu.beryl-project.org dapper/main beryl-plugins 0.1.1-0ubuntu1 [1831kB]
错误 http://ubuntu.beryl-project.org dapper/main beryl-plugins 0.1.1-0ubuntu1
从服务器读取数据时出错,对方关闭了连接 [IP: 64.15.154.150 80]
获取:5 http://ubuntu.beryl-project.org dapper/main emerald 0.1.1-0ubuntu1 [565k B]
错误 http://ubuntu.beryl-project.org dapper/main emerald 0.1.1-0ubuntu1
连接服务器超时 [IP: 64.15.154.150 80]
获取:6 http://ubuntu.beryl-project.org dapper/main beryl-settings 0.1.1-0ubuntu 1 [416kB]
错误 http://ubuntu.beryl-project.org dapper/main beryl-settings 0.1.1-0ubuntu1
连接服务器超时 [IP: 64.15.154.150 80]
获取:7 http://ubuntu.beryl-project.org dapper/main beryl-manager 0.1.1-0ubuntu2 [79.1kB]
错误 http://ubuntu.beryl-project.org dapper/main beryl-manager 0.1.1-0ubuntu2
连接服务器超时 [IP: 64.15.154.150 80]
获取:8 http://ubuntu.beryl-project.org dapper/main beryl 0.1.1-0ubuntu1 [10.2kB ]
获取:9 http://ubuntu.beryl-project.org dapper/main emerald-themes 0.1.1-0ubuntu 1 [1273kB]
错误 http://ubuntu.beryl-project.org dapper/main emerald-themes 0.1.1-0ubuntu1
连接服务器超时 [IP: 64.15.154.150 80]
获取:10 http://ubuntu.beryl-project.org dapper/main libglitz-glx1 0.5.6-0ubuntu 1 [30.0kB]
获取:11 http://ubuntu.beryl-project.org dapper/main xserver-xgl 7.0.0+cvs200606 25 [1565kB]
错误 http://ubuntu.beryl-project.org dapper/main xserver-xgl 7.0.0+cvs20060625
连接服务器超时 [IP: 64.15.154.150 80]
下载 52.0kB,耗时 27m36s (31B/s)
无法下载 http://ubuntu.beryl-project.org/pool/da ... eryl-core_ 0.1.1-0ubuntu1_i386.deb 连接服务器超时 [IP: 64.15.154.150 80]
无法下载 http://ubuntu.beryl-project.org/pool/da ... s/beryl-pl ugins-data_0.1.1-0ubuntu1_all.deb 连接服务器超时 [IP: 64.15.154.150 80]
无法下载 http://ubuntu.beryl-project.org/pool/da ... s/beryl-pl ugins_0.1.1-0ubuntu1_i386.deb 从服务器读取数据时出错,对方关闭了连接 [IP: 64.15 .154.150 80]
无法下载 http://ubuntu.beryl-project.org/pool/da ... ald_0.1.1- 0ubuntu1_i386.deb 连接服务器超时 [IP: 64.15.154.150 80]
无法下载 http://ubuntu.beryl-project.org/pool/da ... gs/beryl-s ettings_0.1.1-0ubuntu1_i386.deb 连接服务器超时 [IP: 64.15.154.150 80]
无法下载 http://ubuntu.beryl-project.org/pool/da ... r/beryl-ma nager_0.1.1-0ubuntu2_i386.deb 连接服务器超时 [IP: 64.15.154.150 80]
无法下载 http://ubuntu.beryl-project.org/pool/da ... es/emerald -themes_0.1.1-0ubuntu1_i386.deb 连接服务器超时 [IP: 64.15.154.150 80]
无法下载 http://ubuntu.beryl-project.org/pool/da ... xserver-xg l_7.0.0+cvs20060625_i386.deb 连接服务器超时 [IP: 64.15.154.150 80]
E: 有几个软件包无法下载,您可以运行 apt-get update 或者加上 --fix-missing 的选项
唉……………
唉…………………
唉……………………………


_________________
做一个精通linux的高手--不易;
做一个熟练的linux使用者--不难。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-01-20 13:14 

注册: 2006-08-29 23:08
帖子: 210
地址: 广东茂名
送出感谢: 0 次
接收感谢: 0 次
唉……………………………
唉……………………………………………
唉……………………………………


长叹几声后,决定故技重演。
首先,把那些“无法下载”网址复制下来,
再打开MultiGet

经过不长的时间,终于把
下列【新】软件包将被安装:
beryl beryl-core beryl-manager beryl-plugins beryl-plugins-data
beryl-settings emerald emerald-themes libglitz-glx1 libxcomposite1
xserver-xgl

软件包下载完了。

然后,逐个安装--有点枯燥,可又有点趣味…………

再按照教程的第5步

启动xgl

NV的:
sudo gedit /etc/gdm/gdm.conf-custom,在[servers] 后面加入
0=Xgl

[server-Xgl]
name=Xgl server
command=/usr/bin/Xgl -fullscreen -ac -accel glx:pbuffer -accel xv:fbo
flexible=true

或者:
0=Xgl

[server-Xgl]
name=Xgl server
command=/usr/bin/Xgl -fullscreen -br -accel glx:pbuffer -accel xv:fbo
flexible=true


ATI的:
sudo gedit /etc/gdm/gdm.conf-custom,在[servers] 后面加入
1=Xgl

[server-Xgl]
name=Xgl server
command=/usr/bin/Xgl -fullscreen -br -accel xv:pbuffer -accel glx:pbuffer -dpi 100 -nolisten tcp
flexible=true

重启,嘿,出来 了!
顺便说说“Beryl/AIGLX 3D桌面详细使用方法”,在这里有
http://forum.ubuntu.org.cn/viewtopic.php?t=30711


_________________
做一个精通linux的高手--不易;
做一个熟练的linux使用者--不难。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-01-20 13:15 

注册: 2006-08-29 23:08
帖子: 210
地址: 广东茂名
送出感谢: 0 次
接收感谢: 0 次
3、昨晚,在本版“[分享]dapper下的beryl已经升级到了0.15”
http://forum.ubuntu.org.cn/viewtopic.php?t=36178
中,看这消息,自己安装的是0.1,那,就升级啦

(1)按照里的设置好了源
(2)在“系统--系统管理器--更新管理器”中,更新了一下。
果然,出现了升级讯息。

当然更新啦。


不一会,哇--------------


_________________
做一个精通linux的高手--不易;
做一个熟练的linux使用者--不难。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-01-20 13:15 

注册: 2006-08-29 23:08
帖子: 210
地址: 广东茂名
送出感谢: 0 次
接收感谢: 0 次
哇--------------
又来了------------------


W: 未能取回 http://cn.archive.ubuntu.com/ubuntu/poo ... 30_all.deb
从服务器读取数据时出错,对方关闭了连接 [IP: 195.248.90.38 80]

W: 未能取回 http://cn.archive.ubuntu.com/ubuntu/poo ... 05_all.deb
连接服务器超时 [IP: 195.248.90.38 80]

W: 未能取回 http://cn.archive.ubuntu.com/ubuntu/poo ... 30_all.deb
连接服务器超时 [IP: 195.248.90.38 80]

W: 未能取回 http://download.tuxfamily.org/3v1deb/po ... 0_i386.deb
连接服务器超时

W: 未能取回 http://download.tuxfamily.org/3v1deb/po ... 0_i386.deb
连接服务器超时

W: 未能取回 http://download.tuxfamily.org/3v1deb/po ... y0_all.deb
连接服务器超时

W: 未能取回 http://download.tuxfamily.org/3v1deb/po ... 0_i386.deb
连接服务器超时

W: 未能取回 http://download.tuxfamily.org/3v1deb/po ... 0_i386.deb

W: 未能取回 http://download.tuxfamily.org/3v1deb/po ... 0_i386.deb

W: 未能取回 http://download.tuxfamily.org/3v1deb/po ... 0_i386.deb

W: 未能取回 http://download.tuxfamily.org/3v1deb/po ... y0_all.deb


_________________
做一个精通linux的高手--不易;
做一个熟练的linux使用者--不难。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-01-20 13:17 

注册: 2006-08-29 23:08
帖子: 210
地址: 广东茂名
送出感谢: 0 次
接收感谢: 0 次
(3)当然,没什么大惊小怪的,我是见过这“大场面”的人,早就有心理准备了。


于是,又打开MultiGet

………………………………

--------------------



现在,我的beryl是0.1.5版。


另:
在后来的安装中,我找到了另一个方便的做法:

1)安装好nv或者是ati源里面的驱动(intel板载显卡需要安装Beryl源里面的xorg驱动)
nv的:
http://wiki.ubuntu.org.cn/NVIDIA%E6%98% ... 7%E5%8D%97
ati的:
http://wiki.ubuntu.org.cn/ATI%E6%98%BE% ... 7%E5%8D%97

2)安装Beryl+Dapper+XGL

(1)添加下列Beryl的源
sudo gedit /etc/apt/sources.list
deb http://www.albertomilone.com/drivers/da ... test/32bit binary/
deb http://ubuntu.beryl-project.org dapper main
deb http://download.tuxfamily.org/3v1deb dapper beryl-svn

(2)添加安装钥匙
先:
$ wget http://albertomilone.com/drivers/tseliot.asc
$ sudo apt-key add tseliot.asc
再:
wget http://ubuntu.beryl-project.org/root@lupine.me.uk.gpg -O- | sudo apt-key add -
wget http://download.tuxfamily.org/3v1deb/DD800CD9.gpg -O- | sudo apt-key add -


(3)更新系统
$ sudo aptitude update && sudo aptitude dist-upgrade


(4)安装Xgl和Beryl

sudo aptitude install xserver-xgl beryl emerald-themes


(5)启动xgl

NV的:
sudo gedit /etc/gdm/gdm.conf-custom,在[servers] 后面加入:
0=Xgl

[server-Xgl]
name=Xgl server
command=/usr/bin/Xgl -fullscreen -ac -accel glx:pbuffer -accel xv:fbo
flexible=true

或者:
0=Xgl

[server-Xgl]
name=Xgl server
command=/usr/bin/Xgl -fullscreen -br -accel glx:pbuffer -accel xv:fbo
flexible=true


ATI的:
sudo gedit /etc/gdm/gdm.conf-custom,在[servers] 后面加入:
1=Xgl

[server-Xgl]
name=Xgl server
command=/usr/bin/Xgl -fullscreen -br -accel xv:pbuffer -accel glx:pbuffer -dpi 100 -nolisten tcp
flexible=true

(6)加入启动项
打开菜单:系统 –> 首选项 –> 会话 –> 启动程序,加入”beryl-manager “
(7)重启你的电脑。

顺便说说“Beryl/AIGLX 3D桌面详细使用方法”,在这里有
http://forum.ubuntu.org.cn/viewtopic.php?t=30711

UBUNTU各版本的安装beryl可参照:
http://wiki.beryl-project.org/wiki/Inst ... r_Drake.29



http://forum.ubuntu.org.cn/viewtopic.ph ... highlight=


仅供一笑。
发个图show一下。
:P :twisted: :roll: :oops: :cry: :lol: :lol: :lol: :shock: :o :lol: :lol: :lol:


附件:
Screenshot.png
Screenshot.png [ 488.51 KiB | 被浏览 5177 次 ]



_________________
做一个精通linux的高手--不易;
做一个熟练的linux使用者--不难。


最后由 feng3243 编辑于 2007-02-02 1:10,总共编辑了 2 次
页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-01-20 13:39 
头像

注册: 2006-11-11 17:14
帖子: 833
地址: 浙江宁波
送出感谢: 0 次
接收感谢: 0 次
lz我顶你,你太棒了,我曾经为了装个beryl也想过很多的法子,但是在6.06下面一直没有成功,现在在edgy下成功了,没想到你这样的方法也能行,真是厉害!!!顶你!!


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-01-20 13:47 
头像

注册: 2006-09-24 22:43
帖子: 710
送出感谢: 0 次
接收感谢: 0 次
网络不好是太痛苦了。


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-01-20 15:20 

注册: 2007-01-15 9:45
帖子: 205
送出感谢: 0 次
接收感谢: 0 次
今天的beryl更新了数次,还是提示说不能成功下载文件,郁闷ing
对了,问问楼主,如果是用新立得去更新,怎样找到文件的下载链接呢?谢谢!


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-01-20 15:30 

注册: 2006-08-29 23:08
帖子: 210
地址: 广东茂名
送出感谢: 0 次
接收感谢: 0 次
tt2nn 写道:
今天的beryl更新了数次,还是提示说不能成功下载文件,郁闷ing
对了,问问楼主,如果是用新立得去更新,怎样找到文件的下载链接呢?谢谢!


更新失败时,会有这信息吧

W: 未能取回 http://cn.archive.ubuntu.com/ubuntu/pool/main/l/language-pack-en/language-pack-en_6.06+20061130_all.deb
从服务器读取数据时出错,对方关闭了连接 [IP: 195.248.90.38 80]

中间这个
http://cn.archive.ubuntu.com/ubuntu/poo ... 30_all.deb
就是链接了。

如果不行,就自己进入那软件库
http://cn.archive.ubuntu.com/ubuntu/pool/main/
自己找相应的包。

有点辛苦哦。 :lol: :P :? :lol: :lol:


_________________
做一个精通linux的高手--不易;
做一个熟练的linux使用者--不难。


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-01-20 15:31 

注册: 2007-01-15 9:45
帖子: 205
送出感谢: 0 次
接收感谢: 0 次
噢,终于下载成功了,原来是提示失败后会有提示个连接的,准备重启看看效果,阿门。不过好似听说更新后的好多人起不来?


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2007-01-20 16:09 

注册: 2007-01-15 9:45
帖子: 205
送出感谢: 0 次
接收感谢: 0 次
个网络为什么还是这样慢呢?在下载 个multiget的过程也是慢,呵呵


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 27 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译