当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 25 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : [分享]Inter 855GME板载显卡unbuntu dapper下安装bery1+aiglx
帖子发表于 : 2007-01-30 18:07 

注册: 2006-07-22 8:57
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
笔记本配置:PM 1.5 (D) +768M+855GME 应该是04,05年的主流配置。
估计好多人跟差不多的配置。

这种配置下能否实现3D的桌面效果呢?而且能不能实现3D效果呢?答案是肯定的。
我的笔记本上目前后台运行着mySql,tomcat,beryl效果全开,一点问题都没有,运行非常流畅,整体的性能绝对比同等条件winXP的效果要好的多。

公布一下我安装的过程

首先,下定决心,一定要安装aiglx,放弃安装xgl的想法,昨天一天安装xgl失败的惨痛精力使我下定决心再也不碰xgl,光xserver就崩溃了两次,估计是因为配置的失误,简单点配置失误可以在终端修改:
dpkg-reconfigure xserver-xrog.conf
如果你什么都不懂的话,那么就按照提示一步一步往下配置即可,全部默认;如果您什么都懂的话,哈哈,全部默认也会给您带来极大的便利……

第二,要做好几个关键的配置文件的备份,因为一下的配置要修改这几个文件,如果失败的话,你要反复修改。
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
sudo cp /etc/gdm/gdm.conf-custom /etc/gdm/gdm.conf-custom.bak


我安装参考的文章是beryl官方的wiki;地址如下:
http://wiki.beryl-project.org/wiki/Inst ... with_AIGLX

但是按照这个文档配置很不成功,出现了不少问题,下面我说一下我的安装过程:

首先,添加官方源
sudo gedit /etc/apt/sources.list

deb http://ubuntu.beryl-project.org dapper main

下载public key:
wget http://ubuntu.beryl-project.org/root@lupine.me.uk.gpg -O- | sudo apt-key add -
然后:
sudo apt-get update

安装驱动:
驱动的安装很方便,只要直接安装beryl官方提供的驱动即可,比A和N卡方便得多
sudo apt-get install xserver-xorg-driver-i810

下载aiglx
sudo apt-get install xserver-xorg-air-core linux-dri-modules-common linux-dri-modules-`uname -r`
这一步会遇到很多问题
如果直接在终端执行,下载速度必然很慢,都是地震闹得,论坛上也有很多人提出了解决办法:有人建议把地址记录下来然后拖到win下面的迅雷中下载,很快;
不过我采取的办法是直接在新立得里面下载,寻找高速代理,我就找乐一个土耳其的代理在下载,速度非常快,大家可以到代理中国找一下欧洲的高速代理;
但是这里又出了一个问题在386内核下居然要求安装linux-dri-modules-2.6.15-27-386这个版本可是源内并没有这个版本阿,只有linux-dri -modules-2.6.15-26-386这个版本,总之无论如何也是安装不上,我找了半天也没有找到27版安装上,没办法重新下载了686的内核,升级上再说,然后重启以686的内核启动unbuntu这个时候再执行上面的代码,这时候下载的就是686的版本了,一切顺利。

然后修改xorg的配置文件,千万别忘了备份,忘了也没有关系,坏了dpkg-reconfigure xserver-xrog.conf即可
sudo gedit /etc/X11/xorg.conf
要修改的地方
Screen 内,(这个似乎默认的有)
DefaultDepth 24
注释掉“module”中的glcore;
Section "Module"
# Load "GLcore"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dbe"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10″
Load "type1″
Load "vbe"
EndSection

在device中增加 "XAANoOffscreenPixmaps"

Option "XAANoOffscreenPixmaps"


最后几行应该是这个样子:
Section "Extensions"
Option "Composite" "Enable"
EndSection

Section "DRI"
Mode 0666
EndSection

保存退出;

此时,wiki上说要 sudo update-alternatives –config Xorg,可是我怎么弄也不行
于是按照配置xgl的办法配置,目的不就是更换xorg么
sudo gedit /etc/gdm/gdm.conf-custom

最后添加:
0=aiglx
[server-aiglx]
name=aiglx server
command=/usr/bin/Xorg-air :0
flexible=true

此刻所有难题都解决了
安装beryl
sudo apt-get install beryl emerald-themes
很简单了

然后sudo reboot一下,
beryl-manager打开配置,就可以看到比vista更加炫目的效果了。
哈哈,最后自己再狂喜一下。


附件:
文件注释: 截图
Screenshot.jpg
Screenshot.jpg [ 82.26 KiB | 被浏览 1382 次 ]

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-01-30 22:13 

注册: 2006-11-27 23:46
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
大哥 你说的这些软件 我的源里怎么一个都没有呢



你用的是什么源阿


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-01-31 0:16 

注册: 2007-01-18 16:14
帖子: 284
地址: CHINA
送出感谢: 0 次
接收感谢: 0 次
intel 的直接使用官方源里面的应该就可以了 8)


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-02-02 10:59 

注册: 2006-11-27 23:46
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
我用的就是官方的beryl源 和欧洲的官方 ubuntu的源 也是没有阿


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-02-02 11:08 

注册: 2007-01-18 16:14
帖子: 284
地址: CHINA
送出感谢: 0 次
接收感谢: 0 次
请检查你的源,把 /etc/apt/sources.list贴出来看看


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-02-02 11:19 

注册: 2006-11-27 23:46
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
deb http://ubuntu.beryl-project.org feisty main
deb-src http://ubuntu.beryl-project.org feisty main

deb http://archive.ubuntu.com/ubuntu/ feisty main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ feisty-security main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ feisty-updates main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ feisty-proposed main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ feisty-backports main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ feisty main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ feisty-security main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ feisty-updates main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ feisty-proposed main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ feisty-backports main restricted universe multiverse


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-02-02 11:33 

注册: 2007-01-18 16:14
帖子: 284
地址: CHINA
送出感谢: 0 次
接收感谢: 0 次
用的feisty?
会不会还少一个 deb http://archive.ubuntu.com/ubuntu-cn/ feisty main restricted universe multiverse


页首
 用户资料  
 
8 楼 
 文章标题 : 升级后崩溃,不能使用了
帖子发表于 : 2007-02-06 15:41 

注册: 2006-07-22 8:57
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
升级后崩溃,不能使用了。

正常的系统软件升级,我特地挑出了beryl相关的升级,仍旧是0.11版,但是不能正常使用了,很奇怪。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-02-06 15:50 
头像

注册: 2006-12-14 20:33
帖子: 834
送出感谢: 0 次
接收感谢: 0 次
情况和楼上一样 我本来还不想说的.....升级后XWindows崩溃 连LiveCD也不能用..只能用Xp安装盘格式化硬盘
重新安装
其实Intel的只要在新立得里面可以直接安装...


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-02-06 15:52 
头像

注册: 2006-12-14 20:33
帖子: 834
送出感谢: 0 次
接收感谢: 0 次
不是升级 按楼主的方法安装Beryl


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-02-06 21:40 
头像

注册: 2006-06-13 11:02
帖子: 431
地址: 广东 广州
送出感谢: 0 次
接收感谢: 0 次
有这么麻烦吗?如果是edgy的话,只要安装beryl就行了~!因为edgy已经集成aiglx了,
i810的驱动是开源的所以已经集成在edgy里面了。


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-02-07 10:30 
头像

注册: 2006-12-14 20:33
帖子: 834
送出感谢: 0 次
接收感谢: 0 次
呵呵 是啊...Edgy直接能装beryl
只不过有Bug 不能运行 Wine 等...
比如你运行Wine会出现libGL warning: 3D driver claims to not support visual 0x4b
这一类的~~


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-02-10 22:13 
头像

注册: 2006-05-13 14:00
帖子: 338
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get install beryl emerald-themes
为什么我的报错是这个?
:下列的软件包有不能满足的依赖关系:
beryl: 依赖: beryl-plugins 但是它将不会被安装
依赖: emerald 但是它将不会被安装 或
compiz-gtk 但却无法安装它
依赖: beryl-settings 但是它将不会被安装
依赖: beryl-manager 但是它将不会被安装
emerald-themes: 依赖: emerald (>= 0.1) 但是它将不会被安装
E: 受损安装包


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-02-10 22:17 
头像

注册: 2006-05-13 14:00
帖子: 338
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get install beryl emerald-themes beryl-plugins emerald beryl-settings beryl-manager libdbus-1-2
俺的是需要这样才能安装。。。

另外没有/etc/gdm/gdm.conf-custom 这个文件 我只好改的gdm.conf


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2007-02-10 22:19 
头像

注册: 2006-05-13 14:00
帖子: 338
送出感谢: 0 次
接收感谢: 0 次
@ubuntu$ sudo apt-get install beryl emerald-themes beryl-plugins emerald beryl-settings beryl-manager libdbus-1-2
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
将会安装下列的额外的软件包:
beryl-core beryl-plugins-data brltty brltty-x11 cupsys-driver-gutenprint gconf2 gconf2-common libatspi1.0-0 libavahi-client3
libavahi-common-data libavahi-common3 libavahi-glib1 libbrlapi1 libcupsys2 libcupsys2-gnutls10 libdbus-glib-1-2 libgconf2-4 libgnomeui-0
libgnomeui-common libgnomevfs2-0 libgnomevfs2-common libgutenprint2 libreadline4 libreadline5 libselinux1 libsepol1 libssl0.9.8 libsysfs2
libxcomposite1 pcmciautils python2.4-dbus readline-common ubuntu-minimal udev wpasupplicant
建议安装的软件包:
libbrlapi1-dev festival brltty-flite gutenprint-doc gutenprint-locales libgnomevfs2-bin libengine-pkcs11-openssl
推荐安装的软件包:
gnome-gv postscript-viewer libgnomevfs2-extra
下列软件包将被【卸载】:
dbus dbus-1-utils gnome-volume-manager hal hal-device-manager hotplug hwdb-client ifrename ubuntu-desktop update-notifier
下列【新】软件包将被安装:
beryl beryl-core beryl-manager beryl-plugins beryl-plugins-data beryl-settings brltty brltty-x11 cupsys-driver-gutenprint emerald
emerald-themes gconf2-common libatspi1.0-0 libavahi-client3 libavahi-common-data libavahi-common3 libavahi-glib1 libbrlapi1 libcupsys2
libdbus-1-2 libdbus-glib-1-2 libgutenprint2 libsepol1 libssl0.9.8 libsysfs2 libxcomposite1 pcmciautils readline-common wpasupplicant
下列的软件包将被升级:
gconf2 libcupsys2-gnutls10 libgconf2-4 libgnomeui-0 libgnomeui-common libgnomevfs2-0 libgnomevfs2-common libreadline4 libreadline5
libselinux1 python2.4-dbus ubuntu-minimal udev
共升级了 13 个软件包,新安装了 29 个软件包,要卸载 10 个软件包,有 343 个软件未被升级。
需要下载 16.0MB 的软件包。
解压缩后会消耗掉 28.0MB 的额外空间。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 25 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译