升级BERYL后,BERYL启动不了了。。。

GnomeShell/Unity/Beryl/AiGLX/XGL/Compiz Fusion
回复
头像
donny
帖子: 335
注册时间: 2005-10-03 15:25
送出感谢: 0
接收感谢: 0

升级BERYL后,BERYL启动不了了。。。

#1

帖子 donny » 2007-02-04 21:18

今天自动更新了BERYL,但之后就启动不了BERYL了,键入BERYL-MANAGER却显示
donny@ubuntu:~$ beryl-manager
donny@ubuntu:~$ **************************************************************
* Beryl system compatiblity check *
**************************************************************

Detected xserver : AIGLX

Checking Display :0.0 ...

Checking for XComposite extension : failed

No composite extension
beryl: No composite extension
但我装的是XGL+BERYL,为什么升级后就便成了AIGLE+BERYL了??
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2007-02-04 21:30

可能是用xgl启动的,现在的版本变了,不支持了。到官网去看安装,使用直接gnome/kde桌面启动的方法。
● 鸣学
头像
donny
帖子: 335
注册时间: 2005-10-03 15:25
送出感谢: 0
接收感谢: 0

#3

帖子 donny » 2007-02-04 21:57

在GNOME下启动BERYL-MANAGER 选择“窗口管理器”--beryl,终端里就出现以上字样,是不是现在新版本的BERYL对XGL不支持啦??
头像
donny
帖子: 335
注册时间: 2005-10-03 15:25
送出感谢: 0
接收感谢: 0

#4

帖子 donny » 2007-02-04 22:03

卸载了xserver-xgl启动BERYL-MANAGER依然出现
**************************************************************
* Beryl system compatiblity check *
**************************************************************

Detected xserver : AIGLX

Checking Display :0.0 ...

Checking for XComposite extension : failed

No composite extension
beryl: No composite extension
窗口管理器警告: 丢失到显示“:0.0”的连接;
可能是 X 服务器已关闭或者您杀死/摧毁了
窗口管理器。
难道新版本的BERYL真的不支持XSERVER-XGL
Jennal
帖子: 57
注册时间: 2006-09-27 9:07
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 Jennal » 2007-02-04 22:24

不会阿,我现在用的就是beryl0.2+xgl
不过快捷键变了吗?为什么旋转都不行了。。。C-M-方向,不行了吗??
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#6

帖子 zhuqin_83 » 2007-02-05 1:53

你是不是用的修改gdm.conf-custom的方法阿?
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
头像
donny
帖子: 335
注册时间: 2005-10-03 15:25
送出感谢: 0
接收感谢: 0

#7

帖子 donny » 2007-02-05 11:59

gdm.conf-custom我没修改过,我是在GDM里选择启动的。
头像
donny
帖子: 335
注册时间: 2005-10-03 15:25
送出感谢: 0
接收感谢: 0

#8

帖子 donny » 2007-02-05 17:22

重装驱动和BERYL后,运行BERYL-MANAGER,终端里显示
**************************************************************
* Beryl system compatiblity check *
**************************************************************

Detected xserver : XGL

Checking Display :1.0 ...

Checking for XComposite extension : passed (v0.3)
Checking for XDamage extension : passed
Checking for RandR extension : passed
Checking for XSync extension : passed

Checking Screen 0 ...

Checking for GLX_SGIX_fbconfig : passed
Checking for GLX_EXT_texture_from_pixmap : passed

** (beryl-manager:9162): WARNING **: Beryl拦截到致命信号 11
XGL能被识别了,但似乎又出现了新问题。
头像
stlxv
论坛版主
帖子: 8273
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

#9

帖子 stlxv » 2007-02-17 17:06

donny 写了:重装驱动和BERYL后,运行BERYL-MANAGER,终端里显示
**************************************************************
* Beryl system compatiblity check *
**************************************************************

Detected xserver : XGL

Checking Display :1.0 ...

Checking for XComposite extension : passed (v0.3)
Checking for XDamage extension : passed
Checking for RandR extension : passed
Checking for XSync extension : passed

Checking Screen 0 ...

Checking for GLX_SGIX_fbconfig : passed
Checking for GLX_EXT_texture_from_pixmap : passed

** (beryl-manager:9162): WARNING **: Beryl拦截到致命信号 11
XGL能被识别了,但似乎又出现了新问题。
我也出现这个问题
PHP是最好的语言!不服来战!
头像
stlxv
论坛版主
帖子: 8273
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

#10

帖子 stlxv » 2007-02-17 20:18

汗,你把所有配置都删掉之后,在kde里面启动beryl-manager就能正常使用了!
PHP是最好的语言!不服来战!
回复

回到 “桌面特效”