[分享][申精]Kubuntu 7.04:ATI+fglrx+XGL+Beryl+KDE

GnomeShell/Unity/Beryl/AiGLX/XGL/Compiz Fusion
回复
jl_chang
帖子: 115
注册时间: 2006-01-14 1:13
送出感谢: 0
接收感谢: 0

[分享][申精]Kubuntu 7.04:ATI+fglrx+XGL+Beryl+KDE

#1

帖子 jl_chang » 2007-04-23 16:12

经过长时间的摸索,终于搞定了A卡在Kubuntu下XGL+Beryl的安装问题,现将具体过程贴出:

硬件平台:Core Duo+945P+ATI Mobility FireGL V5200;下面的方法也适合Radeon X1000系列显卡的Kubuntu用户


1、将系统更新到最新,目前核心为2.6.20.15

2、安装ATI官方驱动[感谢zhuqin_83的分享]

具体方法见这里:http://forum.ubuntu.org.cn/viewtopic.php?t=26188&highlight=

第一种方法我安装失败,只能用第二种方法安装8.36.5版本的驱动──Google的解释是只有8.36.5和以上版本支持2.20核心,我尝试过用第二种方法安装8.35.5版驱动但同样宣告失败。

注意:ATI官网上FireGL V5000的驱动版本还停留在8.35.5;Radeon X1000部分驱动才是8.36.5,两者是不同的。但实际上8.36.5版驱动可支持Radeon X1000系列和FireGL V5000系列,在我本机上也只能使用该版本驱动。

根据链接中的第二种方法,一步一步安装即可。



3、安装XGL和Beryl[方法参考:http://wiki.beryl-project.org/wiki/Install_Beryl_on_Ubuntu_Feisty_with_XGL]

1)添加源:sudo kate /etc/apt/sources.list,加入以下行:

deb http://ubuntu.beryl-project.org/ feisty main

2)执行以下命令

$ wget http://ubuntu.beryl-project.org/root@lupine.me.uk.gpg -O- | sudo apt-key add -
$ wget http://download.tuxfamily.org/3v1deb/DD800CD9.gpg -O- | sudo apt-key add -
$ wget http://www.beerorkid.com/compiz/quinn.key.asc -O - | sudo apt-key add -

然后:
$ sudo apt-get update

3)执行以下命令(For Kubuntu/KDE:):

$ sudo apt-get install xserver-xgl beryl-kubuntu emerald-themes

由于最新Ubuntu版的beryl-core无法与XGL兼容,因此我们必须安装一个可兼容的版本, 运行:

$ kdesu kate /etc/apt/preferences 加入以下三行内容(以下三行不要隔离),保存后退出:

Package: *
Pin: release o=lupine
Pin-Priority: 1000

然后运行:
$ sudo apt-get update
$ sudo apt-get install beryl-core=0.2.0~0beryl1

(强制beryl-core的版本)

4、配置启动

1)建立startxgl.sh启动脚本
$ sudo kate /usr/local/bin/startxgl.sh

加入以下内容(我的startxgl.sh内容,只针对A卡):

Xgl -fullscreen :1 -ac -br -accel glx:pbuffer -accel xv:pbuffer -dpi 96 &
sleep 4
export DISPLAY=:1
cookie="$(xauth -i nextract - :0 | cut -d ' ' -f 9)"
xauth -i add :1 . "$cookie"
exec startkde

保存后关闭

2)让其生效

$ sudo chmod a+x /usr/local/bin/startxgl.sh

3)创建KDM登录入口

$ sudo kate /usr/share/xsessions/xgl.desktop

加入以下内容:

[Desktop Entry]
Encoding=UTF-8
Name=Xgl
Exec=/usr/local/bin/startxgl.sh
Icon=
Type=Application

4)检验:
注销或者重启系统,KDE登录入口会出现XGL链接(如果设定了自动登录,应将其取消),点选后登录XGL

打开终端,运行:$ beryl-manager

看看是否已成功,以上步骤在笔者机器上经过检测OK

5)让Beryl自动启动

$ ln -s /usr/bin/beryl-manager ~/.kde/Autostart/beryl-manager

(还有更复杂的脚本,控制Beryl只有在XGL启动时才启动,有兴趣的XD可以研究)

5、一个小问题

在XGL模式下,Fcitx输入法无法正常启动,必须运行:

$ killall fcitx
$ fcitx

才能正常启动,希望有XD贡献自动启动脚本。
头像
ilikefanshu
帖子: 29
注册时间: 2006-06-05 20:51
送出感谢: 0
接收感谢: 0

#2

帖子 ilikefanshu » 2007-04-23 22:48

哗,劲支持啊,我都试下先,我就是没有试过Beryl,
jl_chang
帖子: 115
注册时间: 2006-01-14 1:13
送出感谢: 0
接收感谢: 0

#3

帖子 jl_chang » 2007-04-24 1:15

只是针对Kubuntu,看来KDE的用户这里还是少。。。
头像
vvoody
帖子: 749
注册时间: 2007-01-21 20:10
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 vvoody » 2007-04-25 17:39

我是K用户,不过还没升级到7.04
apen
帖子: 39
注册时间: 2006-07-21 14:25
送出感谢: 0
接收感谢: 0

#5

帖子 apen » 2007-04-26 11:28

我的IBM T42 不论是安装6.10还是7.04,一但安装了3D驱动,屏就闪个不停,根本用不了!
jl_chang
帖子: 115
注册时间: 2006-01-14 1:13
送出感谢: 0
接收感谢: 0

#6

帖子 jl_chang » 2007-08-19 21:17

FCITX在XGL下无法自启动的方案:
终端下执行:

$ ln -s /usr/bin/fcitx ~/.kde/Autostart/fcitx
头像
badboych22
帖子: 200
注册时间: 2007-09-11 15:15
送出感谢: 0
接收感谢: 0

#7

帖子 badboych22 » 2007-09-13 13:53

装完后我的小企鹅也出不来了,终于有解决的了,太感谢了! :D
回复

回到 “桌面特效”