登出后黑屏

GnomeShell/Unity/Beryl/AiGLX/XGL/Compiz Fusion
回复
peikona
帖子: 42
注册时间: 2006-08-27 16:23
送出感谢: 0
接收感谢: 0

登出后黑屏

#1

帖子 peikona » 2007-05-05 1:39

各位大侠,小弟在启用受限驱动,并安装上Beryl后,可以实现桌面效果,但是有个问题是:登出就黑屏,好像死机一样,用Ctrl + Alt + F1/2切换到命令窗口都不行,就是黑屏,什么也不显示,只能强制关掉电源再重启,不知道是什么原因。
duanlf
帖子: 14
注册时间: 2006-08-16 14:15
送出感谢: 0
接收感谢: 0

同问

#2

帖子 duanlf » 2007-06-01 0:44

我的也是这个现象
头像
akaleus
帖子: 60
注册时间: 2005-11-10 10:13
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 akaleus » 2007-07-23 1:54

ATI的显卡?
貌似是很久以前ati官方就确认的bug,一直都未修复

还有,有人提到如果在intel的显卡上错装了ati的显卡驱动也会出这个问题。


罢了罢了,我觉得要长期使用linux的话还是抛弃ati吧,intel和nv都还不错。。。


P.S.万恶的Thinkpad就喜欢用ati卡,郁闷。。想换都不行
头像
akaleus
帖子: 60
注册时间: 2005-11-10 10:13
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 akaleus » 2007-07-23 2:07

这是fglrx的bug报告上找到的
Hardlock on X logout

Up from driver version 8.19.10 you will experience a system hard lock when logging out from X, if the session manager (kdm/gdm) is not properly configured. You have to tell the session manager to restart X.

In the kdm config file (gentoo: /usr/kde/<VERSION>/share/config/kdm/kdmrc) you have to add following to the section [X-:*-Core]:

代码: 全选

TerminateServer=true


In the gdm config (/etc/gdm/gdm.conf) file add the following to the daemon-section:

代码: 全选

AlwaysRestartServer=true


Information from the ATI bugtracker: http://ati.cchtml.com/show_bug.cgi?id=239


Another reason of hardlock my be using the wrong AGP driver. Make sure that you have proper drivers for your motherboard loaded before fglrx: (gentoo: /etc/modules.autoload.d/kernel-2.6):
intel-agp
fglrx

A common problem seems to be mistakenly using ATI Chipset drivers instead of Intel.




在ubuntu的英文论坛上也是找到相同的解决方法
If you suffer from a "white screen" overlayed onto gdm upon logout and the system seizing up, i.e., if you share the Ubuntu system with multiple users, then modify the file /etc/X11/gdm/gdm.conf and either add or change the AlwaysRestartServer option:

代码: 全选

AlwaysRestartServer=true

回复

回到 “桌面特效”