[问题]求助,打开compiz后窗口边框消失

GnomeShell/Unity/Beryl/AiGLX/XGL/Compiz Fusion
回复
头像
ancintosh
帖子: 309
注册时间: 2007-05-23 20:38
来自: 鍟.
送出感谢: 0
接收感谢: 0

[问题]求助,打开compiz后窗口边框消失

#1

帖子 ancintosh » 2007-05-23 23:48

请问这是怎么回事和如何解决?
今天刚拿到的7.04碟,以前的老系统就没这问题
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2007-05-24 0:03

情况不明确哦。
● 鸣学
头像
ancintosh
帖子: 309
注册时间: 2007-05-23 20:38
来自: 鍟.
送出感谢: 0
接收感谢: 0

#3

帖子 ancintosh » 2007-05-24 0:13

一切默认安装,自带N卡驱动.然后直接打开特效,问题出现
这个我也看不出来情况,反正状况是启用compiz后窗口边框消失
附件
Screenshot.png
waterplain
帖子: 25
注册时间: 2007-05-13 11:41
送出感谢: 0
接收感谢: 0

#4

帖子 waterplain » 2007-05-24 10:45

右键点击红砖石 ->选择窗口装饰器->GTK窗口装饰器
头像
vbem
帖子: 239
注册时间: 2006-09-13 9:09
送出感谢: 0
接收感谢: 0

#5

帖子 vbem » 2007-05-24 11:27

16位色深不够
要24位色深
头像
yysq009
帖子: 2682
注册时间: 2007-01-28 23:00
来自: @江西|南昌@
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 yysq009 » 2007-05-24 11:40

xorg.conf没配置好。查询下关于BERYL的帖子。

Do as you would be done by !
头像
ancintosh
帖子: 309
注册时间: 2007-05-23 20:38
来自: 鍟.
送出感谢: 0
接收感谢: 0

#7

帖子 ancintosh » 2007-05-24 13:04

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300]"
Monitor "通用显示器"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
.................

这似乎是24位色深啊
dakam
帖子: 21
注册时间: 2007-05-24 14:00
送出感谢: 0
接收感谢: 0

#8

帖子 dakam » 2007-05-24 16:20

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
Option "metamodes" "1152x864 +0+0; 1152x768 +0+0; 1024x768 +0+0; 800x600 +0+0; 640x480 +0+0"
SubSection "Display"
Depth 24
Modes "1152x864" "1152x768" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

我的fc6跟你出的情况一样。加了上面的红色一行问题没有了。
Georock
帖子: 51
注册时间: 2005-07-13 10:15
来自: shenzhen
送出感谢: 0
接收感谢: 0

#9

帖子 Georock » 2007-05-24 22:54

还 是 不行阿 ,昏
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder26) Thu Nov 9 17:55:59 PST 2006

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
InputDevice "Synaptics Touchpad"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbVariant" "intl"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "InputDevice"
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "cursor"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Monitor"
Identifier "通用显示器"
HorizSync 28.0 - 64.0
VertRefresh 43.0 - 60.0
Option "DPMS"
EndSection

Section "Device"
Identifier "nVidia Corporation C51 [Geforce 6150 Go]"
Driver "nvidia"
EndSection

Section "Screen"

Identifier "Default Screen"
Device "nVidia Corporation C51 [Geforce 6150 Go]"
Monitor "通用显示器"
DefaultDepth 24

Option "RenderAccel" "true"
Option "AllowGLXWithComposite" "true"
Option "AddARGBGLXVisuals" "True"
SubSection "Display"
Depth 1
Modes "1280x800"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x800"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x800"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x800"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x800"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x800"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection
头像
ancintosh
帖子: 309
注册时间: 2007-05-23 20:38
来自: 鍟.
送出感谢: 0
接收感谢: 0

#10

帖子 ancintosh » 2007-05-25 1:48

我用8楼的方案解决问题了,不知9楼仁兄又是什么状况
dakam
帖子: 21
注册时间: 2007-05-24 14:00
送出感谢: 0
接收感谢: 0

#11

帖子 dakam » 2007-05-25 9:32

Option "RenderAccel" "true"
Option "AllowGLXWithComposite" "true"

你把这俩句注释掉试试。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#12

帖子 eexpress » 2007-05-25 9:40

楼上的,解答前,需要清楚问题哦。楼主都不知道是不是使用beryl,或者使用过。
● 鸣学
Georock
帖子: 51
注册时间: 2005-07-13 10:15
来自: shenzhen
送出感谢: 0
接收感谢: 0

#13

帖子 Georock » 2007-05-25 12:53

我用的是berly ,Option "RenderAccel" "true"
Option "AllowGLXWithComposite" "true" 是我后加上去的,加之前 也不行。
回复

回到 “桌面特效”