当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]我的ubuntu 7.04装了xgl后怎么分辨率上不了1400*1050?
帖子发表于 : 2007-05-25 15:39 

注册: 2007-04-25 9:28
帖子: 32
送出感谢: 0 次
接收感谢: 0 次
我的机器是dell d610笔记本,显卡是ati x300.我安装的显卡驱动是ati官方的闭源驱动,在没有装xgl之前可以上到1400*1050,在上了xg后,进入xgl会话就出错,上不到1400*1050,只能用1024*768,不用xgl会话也可以上到
1400*1050。谁知道原因,大哥们帮帮小弟,用1024*768感觉不爽.


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-05-25 20:57 

注册: 2007-04-25 9:28
帖子: 32
送出感谢: 0 次
接收感谢: 0 次
怎么没有人解答啊?哪位大哥帮帮忙,现在用1024*768很别扭啊,可用工作区域很小啊?


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-05-25 21:10 

注册: 2006-08-26 14:39
帖子: 271
地址: nj
送出感谢: 0 次
接收感谢: 0 次
你贴一下自己的/etc/X11/xorg.conf文件。这样才好有人帮你。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-05-25 22:45 

注册: 2007-04-25 9:28
帖子: 32
送出感谢: 0 次
接收感谢: 0 次
哦,一时着急,糊涂了。这就来,
我的xorg.conf:

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "aticonfig-Screen[0]" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
InputDevice "Synaptics Touchpad"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "InputDevice"
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "cursor"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "fglrx"
Option "XaaNoOffscreenPixmaps"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
Option "Centermode" "off"
Option "DesktopSetup" "clone"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device "aticonfig-Device[0]"
Monitor "aticonfig-Monitor[0]"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "false"
EndSection

Section "ServerFlags"
Option "AIGLX" "off"
EndSection


谢谢大家,帮我看看,有没有解决办法。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-05-26 0:05 
头像

注册: 2005-08-25 13:58
帖子: 808
地址: ustc
送出感谢: 0 次
接收感谢: 0 次
引用:
Modes "1024x768"

改成1400x1050试试


_________________
爱喝真猪奶茶的夜鸣猪


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-05-26 0:11 

注册: 2007-04-25 9:28
帖子: 32
送出感谢: 0 次
接收感谢: 0 次
不行的,我试过了,改为1400*1050进不了xgl会话


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-05-26 10:41 

注册: 2007-04-25 9:28
帖子: 32
送出感谢: 0 次
接收感谢: 0 次
那位大哥帮帮忙啊


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-05-29 8:32 

注册: 2007-04-25 9:28
帖子: 32
送出感谢: 0 次
接收感谢: 0 次
没有人回答,那我只有继续自己琢磨了。我又重新编译了一下显卡驱动,改双头扩展为克隆,解决了问题,用Xgl会话,又回到了1400*1050画面。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译