求助!系统没声音了

GnomeShell/Unity/Beryl/AiGLX/XGL/Compiz Fusion
回复
yoyovoe
帖子: 138
注册时间: 2007-01-14 15:27
送出感谢: 0
接收感谢: 0
联系:

求助!系统没声音了

#1

帖子 yoyovoe » 2007-06-12 10:28

前些天装了beryl,开始的时候还能用的,不过用了没多久忽然就出问题了,打开的所有窗口都没有标题栏,而且beryl也看不出来什么效果了。有人说是系统音效的问题,我试了一下(如下图),除了最后一项ALSA-高级linux声音构架项没声音外,其他都有声音的。又问了一下别人,好像是混音的问题,就做了如下修改:

1 安装alsa-oss

代码: 全选

sudo apt-get install alsa-oss


2 配置alsa

代码: 全选

sudo vim /etc/asound.conf

并在其中加入了如下内容:

代码: 全选

pcm.card0 {
  type hw
  card 0
}

pcm.!default {
  type plug
  slave.pcm "dmixer"
}

pcm.dmixer {
  type dmix
  ipc_key 1025
  slave {
    pcm "hw:0,0"
    period_time 0
    period_size 1024
    buffer_size 4096
    periods 128
    rate 44100
  }
  bindings {
    0 0
    1 1
  }
}

3 修改esd配置

代码: 全选

sudo vim /etc/esound/esd.conf

原代码如下:

代码: 全选

[esd]
auto_spawn=1
spawn_options=-terminate -nobeeps -as 1
spawn_wait_ms=100
# default options are used in spawned and non-spawned mode
default_options=

改为了:

代码: 全选

[esd]
auto_spawn=1
spawn_options=-terminate -nobeeps -as 2 -d default       #修改这里
spawn_wait_ms=100
# default options are used in spawned and non-spawned mode
default_options=

然后重启电脑,再登录的时候就没有声音了。打开声音首选项,里面的所有项都没有声音了。不知道这是怎么回事,应该怎么办?
附件
Screenshot-声音首选项.png
yoyovoe
帖子: 138
注册时间: 2007-01-14 15:27
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 yoyovoe » 2007-06-12 10:58

还做了一点修改:
在xorg.conf文件中加入了一句

代码: 全选

Option "AddARGBGLXVisuals" "True"


以上加的这些代码都是irc里其他人指点的,我也不太懂是什么道理...
yoyovoe
帖子: 138
注册时间: 2007-01-14 15:27
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 yoyovoe » 2007-06-13 16:32

没人帮忙,自己顶下.晕,要不行就只能重装了
头像
code vampire
帖子: 193
注册时间: 2010-06-19 12:50
系统: AIX、UBUNTU
送出感谢: 1 次
接收感谢: 4 次
联系:

Re: 求助!系统没声音了

#4

帖子 code vampire » 2010-11-30 22:58

我在安装了Meego SDK后也出现了这一问题.估计是声卡冲突.我的解决方法是:

系统 -> 首选项 -> 多媒体系统选择器

重新设置并测试.这个方法适合于系统识别声卡但没声音,播放器打开后不工作的问题.
主要是安装软件造成的冲突.

我使用Ubuntu10.04


Keep it easy stupid !




I am Code Vampire .




I like Linux . I like open source .

菜鸟我爱linux
帖子: 23
注册时间: 2009-01-11 21:23
送出感谢: 0
接收感谢: 0

Re: 求助!系统没声音了

#5

帖子 菜鸟我爱linux » 2010-12-05 21:33

ubuntu 8.04版本会出现没有声音的情况,但是从8.10以后ubuntu会很好的兼容,这应该是ubuntu 8.04版本对主板声卡的驱动不兼容的情况,建议重新安装或者升级到8.10以后的版本,最好安装或者升级到最新10.10版本。
大家一起来研究linux,希望有一天用linux的人比用微软系统的人多吧!
回复

回到 “桌面特效”