当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]compiz出了问题,导致其他升级也无法正常运行!
帖子发表于 : 2007-06-28 23:48 

注册: 2007-06-28 14:45
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
kwok@kwok-ubuntu:~$ sudo apt-get dist-upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
您也许需要运行“apt-get -f install”来纠正上面的错误。
下列的软件包有不能满足的依赖关系:
compiz: 依赖: compiz-decorator
compiz-gnome: 依赖: compiz-gtk (= 1:0.3.6-1ubuntu13) 但是它还没有被安装
E: 不能满足依赖关系。不妨试一下 -f 选项。

kwok@kwok-ubuntu:~$ sudo apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
正在更正依赖关系... 完成
将会安装下列额外的软件包:
compiz-gnome
下列的软件包将被升级:
compiz-gnome
共升级了 1 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 2 个软件未被升级。
有 2 个软件包没有被完全安装或卸载。
需要下载 0B/165kB 的软件包。
解压缩后会消耗掉 1294kB 的额外空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 108740 个文件和目录。)
正预备替换 compiz-gnome 1:0.3.6-1ubuntu13 (使用 .../compiz-gnome_1%3a0.5.1+git20070627~3v1ubuntu1_i386.deb) ...
正在解压缩将用于更替的包文件 compiz-gnome ...
dpkg:处理 /var/cache/apt/archives/compiz-gnome_1%3a0.5.1+git20070627~3v1ubuntu1_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/compiz/libgconf.so”,它属于软件包 compiz-plugins
在处理时有错误发生:
/var/cache/apt/archives/compiz-gnome_1%3a0.5.1+git20070627~3v1ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-07-01 18:27 

注册: 2007-01-13 22:39
帖子: 202
地址: 杭州
送出感谢: 0 次
接收感谢: 0 次
顶起来!!!!
我也这样了~!~~
用了apt-get -f install 也 没有用!!!
救命阿 !!!~~~


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-07-01 18:50 

注册: 2007-01-13 22:39
帖子: 202
地址: 杭州
送出感谢: 0 次
接收感谢: 0 次
找到方法了,打开新立的,找到软件包 compiz-plugins 进行下升级就好了


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-07-08 14:49 

注册: 2006-09-30 9:18
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
你用的是什么源 ,我的怎么不行呢?
可不可以将你的源贴出来看看 ?


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-07-08 15:57 

注册: 2007-02-01 13:18
帖子: 29
送出感谢: 0 次
接收感谢: 0 次
打开新立得,找到提示错误的包,右键标记删除,然后再apt-get upgrade看看


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-07-08 23:01 
头像

注册: 2006-10-02 10:46
帖子: 88
送出感谢: 0 次
接收感谢: 0 次
7月3日更新后出现类似问题,一直到昨天还是什么更新都没有。恶搞了下结果系统完蛋了,只好重装,现在又升到了7.10,安装了Compiz Fusion,还是问题老多,一直崩溃。还有最近怎么好多的源都出现错误“无法解析域名“


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-07-17 9:26 

注册: 2006-11-01 14:09
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
应该是源的问题。 换个源试试?不要用以前的源了。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-07-19 11:18 

注册: 2007-05-28 18:48
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
cd /var/lib/dpkg/info/
删除compiz-gtk*
再执行 sudo apt-get --purge remove compiz-gtk 应该就行了


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译