[问题]sudo apt-get install -f 问题 系统不能更新

GnomeShell/Unity/Beryl/AiGLX/XGL/Compiz Fusion
回复
vikeyoo
帖子: 10
注册时间: 2007-07-05 10:09
来自: guangdong
送出感谢: 0
接收感谢: 0
联系:

[问题]sudo apt-get install -f 问题 系统不能更新

#1

帖子 vikeyoo » 2007-07-10 20:18

oo@oo-desktop:~$ sudo apt-get install -f
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
正在更正依赖关系... 完成
将会安装下列额外的软件包:
compiz-gnome
下列的软件包将被升级:
compiz-gnome
共升级了 1 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 3 个软件未被升级。
有 7 个软件包没有被完全安装或卸载。
需要下载 0B/174kB 的软件包。
解压缩后会消耗掉 1331kB 的额外空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 119713 个文件和目录。)
正预备替换 compiz-gnome 1:0.3.6-1ubuntu13 (使用 .../compiz-gnome_1%3a0.5.1+git20070706~jbs2_amd64.deb) ...
正在解压缩将用于更替的包文件 compiz-gnome ...
dpkg:处理 /var/cache/apt/archives/compiz-gnome_1%3a0.5.1+git20070706~jbs2_amd64.deb (--unpack)时出错:
正试图覆盖“/usr/lib/compiz/libgconf.so”,它属于软件包 compiz-plugins
dpkg-deb: 子进程 paste 被信号(Broken pipe)终止了
在处理时有错误发生:
/var/cache/apt/archives/compiz-gnome_1%3a0.5.1+git20070706~jbs2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
头像
chewbaaca
帖子: 126
注册时间: 2006-08-25 16:24
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 chewbaaca » 2007-07-12 10:53

昨天重新安装之后也有这个问题
去/var/cache/apt/archives/里面把compiz-core* compiz-gonme*的包都删除了,然后在再apt-get update
apt-get -f install
如果还不成
打开新立得filter已损坏的包然后选择彻底删除
再apt-get install desktop-effects ubuntu-desktop应该就好了
nothing special....
enjoy using command line console
enjoy the colour build by black and white
网兜
http://www.wangdooou.com/w

U-day
http://www.uaresmiling.com/tiki

Uaresmiling
itnet
帖子: 19
注册时间: 2006-11-01 14:09
送出感谢: 0
接收感谢: 0

#3

帖子 itnet » 2007-07-15 1:44

还有,注意一下你的源,有不少源都有问题,我碰到过,百思不得其解
回复

回到 “桌面特效”