当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [求助] 关于ubuntu 7.04 死机问题, 想请教各位,有什么解决办法阿, 快崩溃了
帖子发表于 : 2007-07-23 15:37 

注册: 2007-07-23 15:16
帖子: 48
地址: nanjing
送出感谢: 0 次
接收感谢: 0 次
:?

先说一下问题现象:
前天安装了 aiglx 驱动, compiz fusion及 icon,还安装了几个firefox 插件,包括adblock plus, gladder, mediawrap, clipmark。 驱动正常,compiz fusion也能使用,插件也没有问题。

1) 一般平均10分钟左右会死机,一旦死机, ctrl + alt + backspace, ctrl + alt + F1,F2,...., ctrl + alt +del 都没有任何反应,除鼠标能够移动外,只能按电源键强行关机。 很郁闷阿!! 这个不管是用的 metacity 还是 compiz 都一样。

2) 有时 firefox 打开了,一会儿后 firefox就变暗了,出现假死的样子, 然后死机了。 还有就是运行游戏一会儿也死机了。

我的机器的情况:
thinkpad T43, 1g 内存, x300显卡

没使用 fglrx驱动:
charles@charles-laptop:~$ fglrxinfo程序 'fglrxinfo' 尚未安装. 你可以通过输入下面内容安装:
sudo apt-get install xorg-driver-fglrx
请您确认组件'restricted' 已被激活
bash: fglrxinfo:找不到命令

用的是aiglx:
charles@charles-laptop:~$ glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer,
GLX_OML_swap_method, GLX_SGI_make_current_read, GLX_SGI_swap_control,
GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
.........
后面就不贴了。

xorg.conf内容:
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
Load "dbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "通用显示卡"
Driver "ati"
BusID "PCI:1:0:0"
Option "XAANoOffscreenPixmaps"
Option "AGPMode" "8"
Option "AGPFastWrite" "true"
Option "DisableGLXRootClipping" "true"
Option "AddARGBGLXVisuals" "true"
Option "AllowGLXWithComposite" "true"
Option "EnablePageFlip" "true"
EndSection

Section "Monitor"
Identifier "通用显示器"
Option "DPMS"
HorizSync 28-51
VertRefresh 43-60
EndSection

Section "Screen"
Identifier "Default Screen"
Device "通用显示卡"
Monitor "通用显示器"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
InputDevice "Synaptics Touchpad"
option "AIGLX" "true"
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection


:shock: 各位帮忙看看阿, 怎么解决这个问题呢?
我不知道提供的这些数据是否已经足够,还需要什么呢? 死机时应该有个记录文件吧,不晓得在哪里?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-07-23 15:41 
头像

注册: 2006-04-12 20:05
帖子: 8495
地址: 杭州
送出感谢: 0 次
接收感谢: 8
你开个ssh,死机的时候,用其他电脑ssh上去,top看看啥进程在搞鬼,呵呵。


_________________
关注我的blog: ε==3


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-07-23 15:56 

注册: 2007-07-23 15:16
帖子: 48
地址: nanjing
送出感谢: 0 次
接收感谢: 0 次
top - 15:57:26 up 1:49, 3 users, load average: 0.75, 0.77, 0.83
Tasks: 116 total, 2 running, 112 sleeping, 0 stopped, 2 zombie
Cpu(s): 8.3%us, 1.7%sy, 0.0%ni, 89.7%id, 0.0%wa, 0.0%hi, 0.3%si, 0.0%st
Mem: 1034624k total, 996824k used, 37800k free, 74252k buffers
Swap: 497972k total, 84k used, 497888k free, 508648k cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
4972 root 15 0 285m 104m 14m S 9.6 10.3 7:42.18 Xorg
15934 charles 15 0 2316 1168 880 R 0.3 0.1 0:00.61 top
1 root 15 0 2820 1884 584 S 0.0 0.2 0:01.16 init
2 root RT 0 0 0 0 S 0.0 0.0 0:00.00 migration/0
3 root 34 19 0 0 0 S 0.0 0.0 0:00.02 ksoftirqd/0
4 root RT 0 0 0 0 S 0.0 0.0 0:00.00 watchdog/0
5 root 10 -5 0 0 0 S 0.0 0.0 0:00.05 events/0
6 root 10 -5 0 0 0 S 0.0 0.0 0:00.00 khelper
7 root 10 -5 0 0 0 S 0.0 0.0 0:00.00 kthread
30 root 10 -5 0 0 0 S 0.0 0.0 0:00.01 kblockd/0
31 root 10 -5 0 0 0 S 0.0 0.0 0:00.00 kacpid
32 root 20 -5 0 0 0 S 0.0 0.0 0:00.00 kacpi_notify
143 root 10 -5 0 0 0 S 0.0 0.0 0:00.24 kseriod
165 root 15 0 0 0 0 S 0.0 0.0 0:00.12 pdflush
166 root 20 -5 0 0 0 S 0.0 0.0 0:00.14 kswapd0
167 root 14 -5 0 0 0 S 0.0 0.0 0:00.00 aio/0
1980 root 10 -5 0 0 0 S 0.0 0.0 0:00.00 ksuspend_usbd
1981 root 10 -5 0 0 0 S 0.0 0.0 0:00.00 khubd
2130 root 10 -5 0 0 0 S 0.0 0.0 0:01.03 ata/0
2131 root 10 -5 0 0 0 S 0.0 0.0 0:00.00 ata_aux
2157 root 10 -5 0 0 0 S 0.0 0.0 0:00.01 scsi_eh_0
2158 root 10 -5 0 0 0 S 0.0 0.0 0:07.56 scsi_eh_1
2359 root 10 -5 0 0 0 S 0.0 0.0 0:01.43 kjournald
2558 root 17 -4 2864 1212 376 S 0.0 0.1 0:00.18 udevd
3450 root 12 -5 0 0 0 S 0.0 0.0 0:00.00 pccardd
3547 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 kpsmoused
3606 root 10 -5 0 0 0 S 0.0 0.0 0:00.22 ipw2200/0
3662 root 20 -5 0 0 0 S 0.0 0.0 0:00.00 irda_sir_wq
3934 dhcp 13 -2 2452 576 252 S 0.0 0.1 0:00.00 dhclient3
4316 root 18 0 1648 508 440 S 0.0 0.0 0:00.00 getty
4317 root 18 0 1652 512 440 S 0.0 0.0 0:00.00 getty
4321 root 18 0 1652 512 440 S 0.0 0.0 0:00.00 getty
4322 root 18 0 1652 508 440 S 0.0 0.0 0:00.00 getty
4324 root 18 0 1652 512 440 S 0.0 0.0 0:00.00 getty



想问一下,ata那个进程干什么的,好像有时会崩出err的


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-07-23 20:01 

注册: 2005-10-26 21:41
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
我用beryl时也有类似的症状,只能找别人借机子ssh过去杀掉xorg才行,不知道为什么
但也不是一装好beryl就这样,过了快一个月不知咋的就出现了这个问题,现在都不敢开beryl了


页首
 用户资料  
 
5 楼 
 文章标题 : linux也死机
帖子发表于 : 2007-07-24 15:04 

注册: 2007-05-10 22:15
帖子: 41
送出感谢: 0 次
接收感谢: 0 次
我装beryl+avant window navigator+compiz等后也死机过几次,卸载,快了,舒服了。


页首
 用户资料  
 
6 楼 
 文章标题 : 要安装那个restricted driver
帖子发表于 : 2007-07-24 21:59 

注册: 2007-07-16 10:56
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
直接使用系统带的驱动,就是这样,我刚开是也是,装完系统就开桌面效果,结果过一会就死了。后来安装了restricted driver后就没有问题。
我的机器和你的一样,呵呵


页首
 用户资料  
 
7 楼 
 文章标题 : [求助] ATI X300 官方驱动 安装失败
帖子发表于 : 2007-07-25 22:32 

注册: 2007-07-23 15:16
帖子: 48
地址: nanjing
送出感谢: 0 次
接收感谢: 0 次
为什么每次安装 ATI驱动都不成功呢?

charles@charles-laptop:~$ fglrxinfo
Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (1.5 Mesa 6.5.2)


这个怎么搞阿 ??


页首
 用户资料  
 
8 楼 
 文章标题 : Re: [求助] ATI X300 官方驱动 安装失败
帖子发表于 : 2007-07-26 7:25 

注册: 2006-09-18 22:13
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
loza 写道:
为什么每次安装 ATI驱动都不成功呢?

charles@charles-laptop:~$ fglrxinfo
Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (1.5 Mesa 6.5.2)


这个怎么搞阿 ??


看一下这里,http://wiki.cchtml.com/index.php/Troubleshooting
我昨天也遇到同样的问题,通过上述方法解决。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-07-26 12:24 

注册: 2007-07-23 15:16
帖子: 48
地址: nanjing
送出感谢: 0 次
接收感谢: 0 次
谢谢各位回帖。

我已经通过 在系统管理- 受限驱动里删掉,重起,然后再在这里面 安装,重起就好了。呵呵。

官方的fglrx驱动+ xgl安装之后, 没有出现 aiglx的那种死机问题。 感觉挺好用的, 和我一样问题的朋友

可以试试fglrs驱动。

:D

还有个问题,安装 fglrx ,xgl 后,需要通过在 会话中选择 xgl进入 gnome。 进入gnome之前的 桌面是

一个细方格的壁纸 ,是否能够替换掉呢?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译