安装avant-window-navigator后 更新出现这种问题

GnomeShell/Unity/Beryl/AiGLX/XGL/Compiz Fusion
回复
huangjn
帖子: 18
注册时间: 2006-11-29 4:54
送出感谢: 0
接收感谢: 0

安装avant-window-navigator后 更新出现这种问题

#1

帖子 huangjn » 2007-07-27 23:44

本人是菜鸟 安装了avant-window-navigator后看了一些帖子说换成avant-window-navigator-svn的 于是按照
http://linuxdesktop.cn/2007/07/17/awn-o ... e#more-437 里的方法操作了 。
执行 sudo apt-get remove avant-window-navigator 后avant-window-navigator还在 重启后更新是发现下列问题

正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
您也许需要运行“apt-get -f install”来纠正上面的错误。
下列的软件包有不能满足的依赖关系:
avant-window-navigator-svn: 依赖: libawn-svn 但是它还没有被安装
依赖: libawn-svn (= 0.1.2-svn227-1) 但是它还没有被安装



打开新立得 出现 :您的系统里有 1 个(依赖关系)毁损的软件包!

请使用“Broken”过滤器定位它们
运行 sudo apt-get upgrade -f 显示下面的信息
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
正在更正依赖关系... 完成
下列【新】软件包将被安装:
libawn-svn
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 0B/21.9kB 的软件包。
解压缩后会消耗掉 90.1kB 的额外空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 118702 个文件和目录。)
正在解压缩 libawn-svn (从 .../libawn-svn_0.1.2-svn227-1_i386.deb) ...
dpkg:处理 /var/cache/apt/archives/libawn-svn_0.1.2-svn227-1_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/libawn.so.0.0.1”,它属于软件包 libawn0
在处理时有错误发生:
/var/cache/apt/archives/libawn-svn_0.1.2-svn227-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


请问这个问题怎么解决
huangjn
帖子: 18
注册时间: 2006-11-29 4:54
送出感谢: 0
接收感谢: 0

#2

帖子 huangjn » 2007-07-28 21:53

各位 达人 赶紧给小弟指条明路亚 现在
一打开更新管理器就出现:软件索引已被破坏

无法安装或删除任何软件。请使用包管理软件"synaptic"或在终端运行"sudo apt-get install -f"来修正这个问题。[/img]
huangjn
帖子: 18
注册时间: 2006-11-29 4:54
送出感谢: 0
接收感谢: 0

#3

帖子 huangjn » 2007-07-28 22:08

我把 libawn0 删除了 然后在装了那两个 已经没问题了 不知道我这样行不行
头像
vanciki
帖子: 212
注册时间: 2007-06-27 16:35
来自: 深圳
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 vanciki » 2007-08-15 22:57

我自己找了个libawn的rpm包,转换成deb 安装就好了
如果世界上有完美,那也只在你梦境里
图片
回复

回到 “桌面特效”