[问题]我的ubuntu 7.04 XGL无法开启

GnomeShell/Unity/Beryl/AiGLX/XGL/Compiz Fusion
回复
头像
Legendaryfish
帖子: 166
注册时间: 2006-06-10 16:55
来自: 厦门.IUE
送出感谢: 0
接收感谢: 0
联系:

[问题]我的ubuntu 7.04 XGL无法开启

#1

帖子 Legendaryfish » 2007-07-30 1:55

A卡的 X800 GTO,成功安装了fglrx 8.39.4。

按照坛子里面帖子的设置安装xgl后,从对话里选择xgl后,桌面假死,点什么都不动,只能Ctrl+Alt+Backspace。

这是怎么样的一个状况?
kane_9909
帖子: 88
注册时间: 2007-05-09 14:34
送出感谢: 0
接收感谢: 0

#2

帖子 kane_9909 » 2007-07-30 12:59

lz ctrl+alt+backspace不死机?我在这个驱动下只要到控制台再切换回X必死啊。
头像
Legendaryfish
帖子: 166
注册时间: 2006-06-10 16:55
来自: 厦门.IUE
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 Legendaryfish » 2007-07-31 13:46

不死机……
kane_9909
帖子: 88
注册时间: 2007-05-09 14:34
送出感谢: 0
接收感谢: 0

#4

帖子 kane_9909 » 2007-07-31 19:18

那楼主设置了composite和AIGLX没有?用了beryl或者什么的?
头像
Legendaryfish
帖子: 166
注册时间: 2006-06-10 16:55
来自: 厦门.IUE
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 Legendaryfish » 2007-08-01 0:44

composite 和 AIGLX都关掉了……

现在能用XGL了,只是不能从对话里面选择XGL,只能让X Server直接用XGL起来。
kane_9909
帖子: 88
注册时间: 2007-05-09 14:34
送出感谢: 0
接收感谢: 0

#6

帖子 kane_9909 » 2007-08-01 17:02

#!/bin/sh
Xgl -fullscreen :1 -ac -accel glx:pbuffer -accel xv:pbuffer &
sleep 4
export DISPLAY=:1
exec dbus-launch --exit-with-session gnome-session
这样的吗?
头像
Legendaryfish
帖子: 166
注册时间: 2006-06-10 16:55
来自: 厦门.IUE
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 Legendaryfish » 2007-08-01 22:19

不是,这样我的XGL回话进去桌面是一直假死的。

我是只能用

修改gdm.conf启动xgl
sudo gedit /etc/gdm/gdm.conf-custom
在文件的最后加入
0=Xgl
[server-Xgl]
name=Xgl server
command=/usr/bin/Xgl :0 -fullscreen -ac -accel glx:pbuffer -accel xv:fbo
flexible=true

系统就自动启动xgl

但是Gnome的用户管理器还是不能正常显示,只能键盘盲操作。我选择让系统自动登录我的帐户……
kane_9909
帖子: 88
注册时间: 2007-05-09 14:34
送出感谢: 0
接收感谢: 0

#8

帖子 kane_9909 » 2007-08-02 10:22

那你装8.38试试呢?我的8.39.4一堆问题。
lzhonsailing
帖子: 15
注册时间: 2007-04-25 13:33
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 lzhonsailing » 2007-08-02 14:13

同问!

我的显卡是ATI X1650GT, X1600系列的。不管是用8.3.94还是8.38.7,进入桌面后只显示面板和桌面,图标和其他都显示不出来,也不能进行任何操作,用Ctrl+Alt+Backspace还是可以退出来的。

我用的是在GDM登录时选择session的方法进入xgl的,不知道哪位高人能帮帮我们。
lonesane
帖子: 5
注册时间: 2007-09-05 10:01
送出感谢: 0
接收感谢: 0

#10

帖子 lonesane » 2007-09-06 10:26

我的X800装闭源驱动也是,开xgl有问题。
装开源驱动,分辨率又调不到1440x900,但 compiz fusion可用,郁闷呀!
回复

回到 “桌面特效”