当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : mobility X1300显卡下如何运行compizfusion?
帖子发表于 : 2007-07-31 22:41 

注册: 2007-07-29 13:08
帖子: 26
送出感谢: 0 次
接收感谢: 0 次
本人的联想昭阳笔记本,显卡是ATI mobility X1300,几乎把论坛上的帖子翻了个遍,所有安装的方法都试了一下,就没有一次成功的,我的显卡到底支不支持CF啊?郁闷之极!
如果这款显卡有设置成功的朋友请报个名,我也好有点信心,呵呵!
顺便说一句,今天是本人接触并安装ubuntu的第三天,下决心泡linux了


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-08-01 11:34 

注册: 2007-07-24 15:22
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
1.安装驱动,用受限驱动就可以了,装完系统后,打开受限驱动管理器,把显卡后面的勾选中,系统就会帮你装上A卡的受限驱动(也即官方闭源驱动).如果不行的话先执行
代码:
sudo apt-get update
sudo apt-get install linux-restricted-modules-$(uname -r)
sudo apt-get install xorg-driver-fglrx fglrx-control
sudo depmod -a

然后再试试勾选住
重启机器后执行
代码:
fglrxinfo
命令,若显示
代码:
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon X1300
OpenGL version string: 2.0.6334 (8.34.8)

则说明显卡驱动已经安装成功
2.安装xgl
首先安装
代码:
sudo apt-get install xserver-xgl

然后创建一个开机加载xgl的shell文件
代码:
sudo gedit /usr/local/bin/startxgl.sh

在文件中输入
代码:
#!/bin/sh
Xgl :1 -fullscreen -ac -accel xv:pbuffer -accel glx:pbuffer &
DISPLAY=:1
cookie="$(xauth -i nextract - :0 | cut -d ' ' -f 9)"
xauth -i add :1 . "$cookie"
exec dbus-launch --exit-with-session gnome-session

给刚才的文件赋予相关权限
代码:
sudo chmod a+x /usr/local/bin/startxgl.sh

再创建一个XGL进程的文件
代码:
sudo gedit /usr/share/xsessions/xgl.desktop

输入代码
代码:
[Desktop Entry]
Encoding=UTF-8
Name=GNOME with XGL
Comment=
Exec=/usr/local/bin/startxgl.sh
Icon=
Type=Application


3. 论坛里寻找安装compiz fusio 的帖子...
具体参照这个吧.
http://forum.ubuntu.org.cn/viewtopic.php?t=62449&highlight=compiz+--replace

ps:以后登入系统时选择会话要选成xgl
然后在终端输入
代码:
compiz --replace

不出意外应该可以了,因为我的机器也是这么设置的...

ThinkPad T60 ATI X1300显卡...
再次ps:为了装上特殊效果,曾经重装了三次系统,A卡确实比较难办啊...但是效果出来的那一刻,感觉值了!
希望你也能成功,祝你成功!!!


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-08-01 21:36 

注册: 2007-07-29 13:08
帖子: 26
送出感谢: 0 次
接收感谢: 0 次
ls兄弟,真的非常感谢你如此详细的介绍
呵呵,我又有了信心了
再次感谢!


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-08-01 22:25 

注册: 2007-07-29 13:08
帖子: 26
送出感谢: 0 次
接收感谢: 0 次
刚试了一下,依旧不能启动cf,想问一下jndxk朋友,我安装ubuntu的时候开始只能用alternate版本安装,然后再参照别人的帖子进入到了图形界面,不知道你的本子是不是也是这种情况?
唉,还是准备重装一遍系统了


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-08-02 9:47 

注册: 2007-07-24 15:22
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
我的可以直接进入图形界面安装的...
多试几次,呵呵
为了效果我都重装了三遍呢,感觉比windows重装起来方面.
关键是看你的显卡驱动装完后能不能被系统认出来吧
代码:
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon X1300
OpenGL version string: 2.0.6334 (8.34.8)

对了,还要在系统里面把桌面效果给开起来,你在"系统"菜单里找找看,有个桌面效果菜单的


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-08-02 11:46 

注册: 2007-07-29 13:08
帖子: 26
送出感谢: 0 次
接收感谢: 0 次
jndxk,感谢你的回复!
显卡已经认出来了,但就是不能成功运行CompizFusion,系统已经在重装了
不知道是不是宽屏的原因,依然只能用alternate版安装,然后到网上更新将近5个小时,才能进入图形桌面(漫长的等待……)
希望这次能成功,呵呵!


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-08-02 11:49 
头像

注册: 2006-06-13 14:47
帖子: 331
地址: 黄鹤楼
送出感谢: 0 次
接收感谢: 1
:twisted: :evil: :shock:
我的也是A卡X1300 M的,基于文本模式安装了7.04,启不动图形界面
按楼上的方法还是启不动
fglrxinfo
隔了约20秒,提示: ERROR: unable to open display : 0

什么意思啊,完全不懂了.

A卡镇的这么垃圾?快崩溃了


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-08-02 13:39 

注册: 2007-05-09 14:34
帖子: 88
送出感谢: 0 次
接收感谢: 0 次
A卡要用xgl的,还要在xorg.conf里面关掉Composite和AIGLX。7楼的你在登录的时候在会话里面选择xgl with gnome没有?


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-08-02 20:54 

注册: 2007-07-29 13:08
帖子: 26
送出感谢: 0 次
接收感谢: 0 次
xiaokang 写道:
:twisted: :evil: :shock:
我的也是A卡X1300 M的,基于文本模式安装了7.04,启不动图形界面
按楼上的方法还是启不动
fglrxinfo
隔了约20秒,提示: ERROR: unable to open display : 0

什么意思啊,完全不懂了.

A卡镇的这么垃圾?快崩溃了

兄弟,你的这种情况请搜索一下论坛,有答案。
本帖并不是你所说的问题


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译