compiz启动后无边框?emerald启动没反应?

GnomeShell/Unity/Beryl/AiGLX/XGL/Compiz Fusion
回复
attonie
帖子: 5
注册时间: 2007-08-21 11:30
送出感谢: 0
接收感谢: 0

compiz启动后无边框?emerald启动没反应?

#1

帖子 attonie » 2007-08-21 11:35

nvidia的卡用的是Xorg+Compiz+Emerald, Compiz可以正常启动,但是启动后窗口没有边框,运行"emerald --replace"什么反应都没有,这个怎么办?
头像
aitilang
帖子: 1026
注册时间: 2007-04-28 21:38
送出感谢: 0
接收感谢: 0

#2

帖子 aitilang » 2007-08-21 11:59

显卡驱动啊。。。
thinkpad x61 2G DDR no cdrom
--------------------------------------------
ABS学习中
sed学习中
awk学习中
perl学习中
新手描述不清,老手猜测不到,胡乱指挥一通,后果难以预料
attonie
帖子: 5
注册时间: 2007-08-21 11:30
送出感谢: 0
接收感谢: 0

#3

帖子 attonie » 2007-08-21 12:22

显卡驱动我用的版本是96xx, 这个要怎么弄?
头像
蓝蓝
帖子: 953
注册时间: 2007-06-09 9:19
来自: 上海
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 蓝蓝 » 2007-08-21 12:23

好像是再修改下xorg.conf
太阳好毒…….
attonie
帖子: 5
注册时间: 2007-08-21 11:30
送出感谢: 0
接收感谢: 0

#5

帖子 attonie » 2007-08-21 12:42

贴一下我的xorg.conf,我想这个因该没什么问题把,compiz的屏幕转动,下雪,水波纹效果都可以启动的,就是窗口theme启动不起来,另外除了emerald,还可以用其他的窗口管理器吗 ?
Section "ServerLayout"
Option "AIGLX" "ture"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection
Section "Module"

# Load "i2c"
# Load "bitmap"
Load "ddc"
# Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "dbe"
# Load "int10"
Load "vbe"
EndSection

Section "Device"

# Driver "nv"
Identifier "nVidia Corporation NV40 6800GT"
Driver "nvidia"
Option "RenderAccel" "ture"
Option "AddARGBGLXVisuals" "Ture"
Option "XAANoOffscreenPixmaps" "ture"
Option "AllowGLXWithComposite" "true"
Option "TripleBuffer" "true"

# Option "DisableGLXRootClipping" "Ture"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation NV40 6800GT"
Monitor "Acer 78g"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
EndSection

aquachick
帖子: 115
注册时间: 2007-06-02 1:03
送出感谢: 0
接收感谢: 0

#6

帖子 aquachick » 2007-08-21 16:19

我估计是你没有安装 emerald-theme,emerald没有主题,所以没有边框
头像
xiaokang
帖子: 331
注册时间: 2006-06-13 14:47
来自: 黄鹤楼
送出感谢: 0
接收感谢: 1 次

#7

帖子 xiaokang » 2007-08-21 16:44

我也遇到了同样的问题,很郁闷!
我的emerald-theme中是有主题的。
attonie
帖子: 5
注册时间: 2007-08-21 11:30
送出感谢: 0
接收感谢: 0

#8

帖子 attonie » 2007-08-21 16:46

aquachick 写了:我估计是你没有安装 emerald-theme,emerald没有主题,所以没有边框


有主题,我看见的有十多个
头像
u194252
帖子: 402
注册时间: 2007-08-04 11:06
送出感谢: 0
接收感谢: 0

#9

帖子 u194252 » 2007-09-01 21:48

我也是有主题就是无法应用主题
图片
头像
liguang3333
帖子: 39
注册时间: 2006-03-26 1:05
送出感谢: 0
接收感谢: 0

#10

帖子 liguang3333 » 2007-09-03 22:08

运行一下

代码: 全选

gnome-settings-daemon

如果可行就把这一个添加到启动项。over。
lias
帖子: 3
注册时间: 2007-08-13 11:01
送出感谢: 0
接收感谢: 0

#11

帖子 lias » 2007-09-04 7:54

看看有没有禁用桌面效果
头像
a312662352
帖子: 60
注册时间: 2011-11-16 12:42
系统: ubuntu
送出感谢: 0
接收感谢: 0

Re: compiz启动后无边框?emerald启动没反应?

#12

帖子 a312662352 » 2012-12-31 10:05

记得在compizconfig里打开 窗口装饰 选项
然后再在终端里 fusion-icon
把那个什么管理器选为emerald
然后再在emerald theme manager里选用一个主题。
应该就可以了。

我就是这样弄的 :em09
我想装archlinux
回复

回到 “桌面特效”