[问题]安装不了compiz fusion?

GnomeShell/Unity/Beryl/AiGLX/XGL/Compiz Fusion
回复
blackghost
帖子: 42
注册时间: 2007-03-18 18:35
送出感谢: 0
接收感谢: 0

[问题]安装不了compiz fusion?

#1

帖子 blackghost » 2007-09-02 13:53

我安装compiz fusion的时候出错了,该怎么解决?
附件
snap.jpg
终端截图
头像
by886
帖子: 46
注册时间: 2007-09-02 14:47
送出感谢: 0
接收感谢: 0

#2

帖子 by886 » 2007-09-02 14:52

要先在新立得里把compiz有关的都删掉。然后更新libfuse2到2.6以上。就可以按置顶贴装了!
头像
by886
帖子: 46
注册时间: 2007-09-02 14:47
送出感谢: 0
接收感谢: 0

#3

帖子 by886 » 2007-09-02 14:54

发个libfuse2_2.6.3。我用官方源都没得升级。这个是我在ubuntu的网站上找到的。
附件
libfuse2_2.6.3-1ubuntu2_i386.deb
(70.34 KiB) 下载 126 次
头像
by886
帖子: 46
注册时间: 2007-09-02 14:47
送出感谢: 0
接收感谢: 0

#4

帖子 by886 » 2007-09-02 14:57

如果不升级libfuse2,compiz-plugins好相装不了。有依赖关系。
blackghost
帖子: 42
注册时间: 2007-03-18 18:35
送出感谢: 0
接收感谢: 0

#5

帖子 blackghost » 2007-09-02 16:39

by886 写了:要先在新立得里把compiz有关的都删掉。然后更新libfuse2到2.6以上。就可以按置顶贴装了!
还是不行阿。
liweiyi@liweiyi-desktop:~$ sudo dpkg -i *.deb
(正在读取数据库 ... 系统当前总共安装有 91835 个文件和目录。)
正预备替换 libfuse2 2.6.3-1ubuntu2 (使用 libfuse2_2.6.3-1ubuntu2_i386.deb) ...
正在解压缩将用于更替的包文件 libfuse2 ...
正在设置 libfuse2 (2.6.3-1ubuntu2) ...

liweiyi@liweiyi-desktop:~$ sudo apt-get install compiz compiz-gnome
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
compiz 已经是最新的版本了。
下列【新】软件包将被安装:
compiz-gnome
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 141 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 0B/161kB 的软件包。
解压缩后会消耗掉 1004kB 的额外空间。
(正在读取数据库 ... 系统当前总共安装有 91835 个文件和目录。)
正在解压缩 compiz-gnome (从 .../compiz-gnome_1%3a0.5.5~git20070828+3v1ubuntu0_i386.deb) ...
dpkg:处理 /var/cache/apt/archives/compiz-gnome_1%3a0.5.5~git20070828+3v1ubuntu0_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/compiz/libgconf.so”,它属于软件包 compiz-plugins
在处理时有错误发生:
/var/cache/apt/archives/compiz-gnome_1%3a0.5.5~git20070828+3v1ubuntu0_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
头像
by886
帖子: 46
注册时间: 2007-09-02 14:47
送出感谢: 0
接收感谢: 0

#6

帖子 by886 » 2007-09-03 9:38

先要删掉所有与compiz有关的项目!
头像
by886
帖子: 46
注册时间: 2007-09-02 14:47
送出感谢: 0
接收感谢: 0

#7

帖子 by886 » 2007-09-03 9:44

先在新立得里搜索compiz,把compiz*都删掉。然后更新libfuse2到2.6以上。再在新立得里搜索compiz,选择 compiz-plugins ,compiz ,compiz-gnome,compizconfig-settings-manager,compiz-fusion-* ,emerald进行安装,应该就可以了。
blackghost
帖子: 42
注册时间: 2007-03-18 18:35
送出感谢: 0
接收感谢: 0

#8

帖子 blackghost » 2007-09-03 12:46

by886 写了:先在新立得里搜索compiz,把compiz*都删掉。然后更新libfuse2到2.6以上。再在新立得里搜索compiz,选择 compiz-plugins ,compiz ,compiz-gnome,compizconfig-settings-manager,compiz-fusion-* ,emerald进行安装,应该就可以了。
已经搞定了。我把compiz相关的都删了。然后apt-get dist upgrade,就可以安装了。
喜欢ubuntu
帖子: 131
注册时间: 2007-08-23 20:03
来自: 山西
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 喜欢ubuntu » 2007-09-03 17:42

可我还没有安装成功呢。第一次安装了beryl,设置后没有变化,与是安装了这个,却依然没有反应。在输入安装命令后,提示找不到命令。
blackghost
帖子: 42
注册时间: 2007-03-18 18:35
送出感谢: 0
接收感谢: 0

#10

帖子 blackghost » 2007-09-03 18:36

喜欢ubuntu 写了:可我还没有安装成功呢。第一次安装了beryl,设置后没有变化,与是安装了这个,却依然没有反应。在输入安装命令后,提示找不到命令。
你输入的是什么安装命令啊?
negol
帖子: 49
注册时间: 2007-08-21 17:59
送出感谢: 0
接收感谢: 0

#11

帖子 negol » 2007-09-09 13:38

libfuse2是什么软件啊?用新力得能更新吗?
alexeon
帖子: 10
注册时间: 2007-07-11 23:01
送出感谢: 0
接收感谢: 0

#12

帖子 alexeon » 2007-09-09 20:15

blackghost 写了:
by886 写了:先在新立得里搜索compiz,把compiz*都删掉。然后更新libfuse2到2.6以上。再在新立得里搜索compiz,选择 compiz-plugins ,compiz ,compiz-gnome,compizconfig-settings-manager,compiz-fusion-* ,emerald进行安装,应该就可以了。
已经搞定了。我把compiz相关的都删了。然后apt-get dist upgrade,就可以安装了。
出错了!
附件
Screenshot.png
安装compiz的时候新立得提示:
duer
帖子: 7
注册时间: 2007-07-28 9:52
来自: 四川成都
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 duer » 2008-06-29 10:50

我也遇到了同样的问题。现在的还是用的7.04,使用新立得直接把compiz相关的选中后标记为“重新安装”,就都好了。
回复

回到 “桌面特效”