新新手的问题。有心人请帮一帮。

GnomeShell/Unity/Beryl/AiGLX/XGL/Compiz Fusion
回复
enbor
帖子: 8
注册时间: 2007-09-17 9:41
送出感谢: 0
接收感谢: 0

新新手的问题。有心人请帮一帮。

#1

帖子 enbor » 2007-09-17 10:10

我是新装的Ubuntu的系统,也是刚学linux的。对命令还是不怎么知道。请有心人帮忙。
在装3D桌面时,运行deb http://download.tuxfamily.org/3v1deb feisty eyecandy 这个命令时。
提示bash: deb: command not found,是什么意思,又怎么解决。谢谢!
我是从Windows 转过来的,正在学习中,请多多指教。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2007-09-17 10:27

这不是命令。是一个文件里面的一行而已。wiki的新手指南上,都有。
● 鸣学
enbor
帖子: 8
注册时间: 2007-09-17 9:41
送出感谢: 0
接收感谢: 0

#3

帖子 enbor » 2007-09-17 11:05

谢谢楼上的 。
但运行: sudo apt-get install compiz compiz-gnome时
又提示
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
E: 无法找到软件包 compiz
又是什么意思?
谢谢!!!
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#4

帖子 eexpress » 2007-09-17 11:15

deb http://download.tuxfamily.org/3v1deb feisty eyecandy

一般是添加到 /etc/apt/source.list里面的,然后还要update先。你使用“新利得软件管理器”吧,那里面添加源和更新,搜索,都有。
● 鸣学
enbor
帖子: 8
注册时间: 2007-09-17 9:41
送出感谢: 0
接收感谢: 0

#5

帖子 enbor » 2007-09-17 11:40

哎 不会整。 用echo 添加不进source.list里面去。 update也就不行了。郁闷!
那个软件也不用。
GaRY
帖子: 101
注册时间: 2007-03-25 1:18
送出感谢: 0
接收感谢: 0

#6

帖子 GaRY » 2007-09-17 11:49

在桌面状态,按alt+f2键,在弹出的窗口输入gksu gedit /etc/apt/sources.list回车,弹出窗口叫你输入当前用户密码,输入密码,回车.
然后在打开的文件最后一行加入:deb http://download.tuxfamily.org/3v1deb feisty eyecandy
保存Ctrl+s,点窗口右上角的X退出.
继续按alt+f2,输入gnome-terminal,回车
在弹出的黑窗口里,输入sudo apt-get update回车
等运行结束
输入sudo apt-get install compiz compiz-gnome回车
等安装结束
关闭黑窗口(点窗口右上角的X)

这样讲总可以了吧. :roll:
enbor
帖子: 8
注册时间: 2007-09-17 9:41
送出感谢: 0
接收感谢: 0

#7

帖子 enbor » 2007-09-17 12:00

谢谢你的帮助!
这是执行:sudo apt-get update的结果。
Password:
获取:1 http://cn.archive.ubuntu.com dapper-updates Release.gpg [191B]
命中 http://cn.archive.ubuntu.com dapper-updates Release
命中 http://cn.archive.ubuntu.com dapper-updates/main Packages
命中 http://cn.archive.ubuntu.com dapper-updates/restricted Packages
命中 http://cn.archive.ubuntu.com dapper-updates/main Sources
命中 http://cn.archive.ubuntu.com dapper-updates/restricted Sources
获取:2 http://security.ubuntu.com dapper-security Release.gpg [191B]
命中 http://security.ubuntu.com dapper-security Release
命中 http://security.ubuntu.com dapper-security/main Packages
命中 http://security.ubuntu.com dapper-security/restricted Packages
命中 http://security.ubuntu.com dapper-security/main Sources
获取:3 http://download.tuxfamily.org feisty Release.gpg [189B]
命中 http://security.ubuntu.com dapper-security/restricted Sources
命中 http://download.tuxfamily.org feisty Release
命中 http://download.tuxfamily.org feisty/eyecandy Packages
获取:4 http://download.tuxfamily.org feisty/eyecandy Sources [37B]
命中 http://download.tuxfamily.org feisty/eyecandy Packages
命中 http://download.tuxfamily.org feisty/eyecandy Packages
获取:5 http://download.tuxfamily.org feisty/eyecandy Sources [37B]
下载 77B,耗时 18s (4B/s)
E: 无法获得锁 /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
enbor
帖子: 8
注册时间: 2007-09-17 9:41
送出感谢: 0
接收感谢: 0

#8

帖子 enbor » 2007-09-17 12:04

我明白了 里面有一些多余的项 没有删掉 所以出现那种情况。谢谢提醒!
enbor
帖子: 8
注册时间: 2007-09-17 9:41
送出感谢: 0
接收感谢: 0

#9

帖子 enbor » 2007-09-17 12:24

为什么/var/lib/dpkg/下的lock文件 是0字节?
enbor
帖子: 8
注册时间: 2007-09-17 9:41
送出感谢: 0
接收感谢: 0

#10

帖子 enbor » 2007-09-17 12:45

下列的软件包有不能满足的依赖关系:
compiz: 依赖: compiz-core 但是它将不会被安装
依赖: compiz-plugins 但是它将不会被安装
compiz-gnome: 依赖: libatk1.0-0 (>= 1.13.1) 但是 1.11.4-0ubuntu1 正要被安装
依赖: libbonobo2-0 (>= 2.15.0) 但是 2.14.0-0ubuntu2 正要被安装
依赖: libbonoboui2-0 (>= 2.15.1) 但是 2.14.0-0ubuntu1 正要被安装
] 依赖: libc6 (>= 2.5-0ubuntu1) 但是 2.3.6-0ubuntu20.5 正要被安装
依赖: libcairo2 (>= 1.4.0) 但是 1.0.4-0ubuntu1 正要被安装
依赖: libdbus-1-3 (>= 0.94) 但却无法安装它
依赖: libdbus-glib-1-2 (>= 0.73) 但是 0.60-6ubuntu8.1 正要被安装
依赖: libdecoration0 但是它将不会被安装
依赖: libfontconfig1 (>= 2.4.0) 但是 2.3.2-1.1ubuntu12 正要被安 装
依赖: libglib2.0-0 (>= 2.12.9) 但是 2.10.3-0ubuntu1 正要被安装
依赖: libgnome-keyring0 (>= 0.7.1) 但是 0.4.9-1ubuntu1 正要被安 装
依赖: libgnome-window-settings1 但却无法安装它
依赖: libgnomeui-0 (>= 2.17.1) 但是 2.14.1-0ubuntu3 正要被安装
依赖: libgnomevfs2-0 (>= 1:2.17.90) 但是 2.14.2-0ubuntu1 正要被 安装
依赖: libgtk2.0-0 (>= 2.10.3) 但是 2.8.20-0ubuntu1.1 正要被安装
依赖: liborbit2 (>= 1:2.14.1) 但是 1:2.14.0-0ubuntu1 正要被安装
依赖: libpango1.0-0 (>= 1.16.2) 但是 1.12.3-0ubuntu3 正要被安装
依赖: libpopt0 (>= 1.10) 但是 1.7-5 正要被安装
依赖: libwnck18 (>= 2.15.90) 但是 2.14.2-0ubuntu1 正要被安装
依赖: libxfixes3 (>= 1:4.0.1) 但是 1:3.0.1.2-0ubuntu3 正要被安装
依赖: libxrandr2 (>= 2:1.2.0) 但是 1:1.1.0.2-0ubuntu4 正要被安装
E: 无法安装的软件包

这几个包:libgnome-window-settings1 ; libdbus-1-3; libdecoration0 在库里面找不到,请问在哪里下载?
enbor
帖子: 8
注册时间: 2007-09-17 9:41
送出感谢: 0
接收感谢: 0

#11

帖子 enbor » 2007-09-17 13:11

哎 没人回答,去下一个7.04版本再装这个啦!
回复

回到 “桌面特效”