当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 17 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : [问题]3d桌面的开启?
帖子发表于 : 2007-10-09 12:56 
头像

注册: 2007-10-08 21:55
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
我的是集成的X1250的显卡,可以用3d桌面吗?怎么用啊,刚开始用ubuntu。谢谢大家帮忙啊?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-10-09 13:48 
头像

注册: 2007-09-14 21:03
帖子: 1143
地址: 浙江
送出感谢: 1
接收感谢: 1
我同学的也是你的显卡,我开启桌面效果的时候也是失败。
你先安装ati的受限驱动,再重起开起桌面效果试试,我当时这样试了,但是还不行。


_________________
Say hello to everyday!


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-10-09 20:42 
头像

注册: 2007-10-08 21:55
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
安装了,就说合成扩展不可用不知道为什么?
还有就是按照网上修改了配置文件了以后就进入不了系统,没有图形界面,不知道怎么办,只好重装,已经好几次了,请各路高手帮帮忙!!


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-10-09 21:45 
头像

注册: 2007-09-14 21:03
帖子: 1143
地址: 浙江
送出感谢: 1
接收感谢: 1
gx287658129 写道:
安装了,就说合成扩展不可用不知道为什么?
还有就是按照网上修改了配置文件了以后就进入不了系统,没有图形界面,不知道怎么办,只好重装,已经好几次了,请各路高手帮帮忙!!
我也是遇到这个问题才放弃了桌面效果,你要是找到了解决办法,记得说下阿


_________________
Say hello to everyday!


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-10-09 21:46 

注册: 2007-06-29 20:19
帖子: 112
送出感谢: 0 次
接收感谢: 1
我的也是这个问题!最后SHOW不起来了,呵呵!


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-10-09 21:48 
头像

注册: 2007-09-14 21:03
帖子: 1143
地址: 浙江
送出感谢: 1
接收感谢: 1
参考下这个
http://forum.ubuntu.org.cn/viewtopic.php?t=50750


_________________
Say hello to everyday!


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-10-10 23:36 

注册: 2007-10-10 11:24
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
哈哈 我的 ati 7500的独显 我开了 还有点卡 哈哈


页首
 用户资料  
 
8 楼 
 文章标题 : 终于开启了3d桌面
帖子发表于 : 2007-10-16 9:50 
头像

注册: 2007-10-08 21:55
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
参考了置顶和精华贴,一下是具体步骤,希望有用!!
首先安装显卡驱动,系统里的受限驱动管理器的ati驱动要打上钩。
修改显卡配置文件
代码:
sudo gedit /etc/X11/xorg.conf

在文件中加入代码:

Section "Extensions"
Option "Composite" "0"
EndSection

Section "ServerFlags"
Option "AIGLX" "off"
EndSection

接着重启,
开机后,在终端下运行
代码:
fglrxinfo
如果看到类似的以下语句:display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon X1200
OpenGL version string: 2.0.6334 (8.34.8)
显卡驱动完美安装!!
下面是XGL的安装,
首先下载安装
代码:
sudo apt-get install xserver-xgl

然后,创建一个开机加载XGL的脚本文件
代码:
sudo gedit /usr/local/bin/startxgl.sh

在文件中输入
代码:

#!/bin/sh
Xgl :1 -fullscreen -ac -accel xv:pbuffer -accel glx:pbuffer &
DISPLAY=:1
cookie="$(xauth -i nextract - :0 | cut -d ' ' -f 9)"
xauth -i add :1 . "$cookie"
exec dbus-launch --exit-with-session gnome-session

给刚才的文件赋予相关权限
代码:
sudo chmod a+x /usr/local/bin/startxgl.sh

再创建一个XGL进程的文件
代码:
sudo gedit /usr/share/xsessions/xgl.desktop

输入
代码:

[Desktop Entry]
Encoding=UTF-8
Name=GNOME with XGL
Comment=
Exec=/usr/local/bin/startxgl.sh
Icon=
Type=Application

赋予文件可执行权限
代码:
sudo chmod a+x /usr/share/xsessions/xgl.desktop
xgl安装完成

新加源:deb http://ppa.launchpad.net/amaranth/ubuntu feisty main
更新:
代码:

sudo apt-get update
sudo apt-get dist-upgrade

安装Compiz及Compiz fusion
代码:

sudo apt-get install compiz compiz-gnome
sudo apt-get install compizconfig-settings-manager
sudo apt-get install compiz-fusion-*
运行Compiz Fusion
现在你就可以享受Fusion带来的惊喜啦,同时你也可以关闭Compiz及Beryl啦,在“系统-首选项-会话”新建一个新的会话如下:
代码:

compiz --replace


Compiz 使用emerald 主题:
代码:
emerald --replace



这样,系统就可以在开机后自动加载Compiz Fusion啦。
注意:开机登录是一定要选择会话为xgl,才可以用3d桌面,效果很流畅!!各位不放试一下!!


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-10-18 13:48 
头像

注册: 2007-10-16 19:13
帖子: 72
地址: 牡丹江
送出感谢: 0 次
接收感谢: 0 次
关键是好多源都是不能连接的!~


_________________
恐怖片 www.kongbupian.net


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-10-18 17:46 
头像

注册: 2007-10-08 21:55
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
不会啊,这一歌可以啊,我试过了啊,你试一试啊!!


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 终于开启了3d桌面
帖子发表于 : 2007-10-19 20:22 

注册: 2007-09-07 16:17
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
gx287658129 写道:
参考了置顶和精华贴,一下是具体步骤,希望有用!!
首先安装显卡驱动,系统里的受限驱动管理器的ati驱动要打上钩。
修改显卡配置文件
代码:
sudo gedit /etc/X11/xorg.conf

在文件中加入代码:

Section "Extensions"
Option "Composite" "0"
EndSection

Section "ServerFlags"
Option "AIGLX" "off"
EndSection

接着重启,
开机后,在终端下运行
代码:
fglrxinfo
如果看到类似的以下语句:display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon X1200
OpenGL version string: 2.0.6334 (8.34.8)
显卡驱动完美安装!!
下面是XGL的安装,
首先下载安装
代码:
sudo apt-get install xserver-xgl

然后,创建一个开机加载XGL的脚本文件
代码:
sudo gedit /usr/local/bin/startxgl.sh

在文件中输入
代码:

#!/bin/sh
Xgl :1 -fullscreen -ac -accel xv:pbuffer -accel glx:pbuffer &
DISPLAY=:1
cookie="$(xauth -i nextract - :0 | cut -d ' ' -f 9)"
xauth -i add :1 . "$cookie"
exec dbus-launch --exit-with-session gnome-session

给刚才的文件赋予相关权限
代码:
sudo chmod a+x /usr/local/bin/startxgl.sh

再创建一个XGL进程的文件
代码:
sudo gedit /usr/share/xsessions/xgl.desktop

输入
代码:

[Desktop Entry]
Encoding=UTF-8
Name=GNOME with XGL
Comment=
Exec=/usr/local/bin/startxgl.sh
Icon=
Type=Application

赋予文件可执行权限
代码:
sudo chmod a+x /usr/share/xsessions/xgl.desktop
xgl安装完成

新加源:deb http://ppa.launchpad.net/amaranth/ubuntu feisty main
更新:
代码:

sudo apt-get update
sudo apt-get dist-upgrade

安装Compiz及Compiz fusion
代码:

sudo apt-get install compiz compiz-gnome
sudo apt-get install compizconfig-settings-manager
sudo apt-get install compiz-fusion-*
运行Compiz Fusion
现在你就可以享受Fusion带来的惊喜啦,同时你也可以关闭Compiz及Beryl啦,在“系统-首选项-会话”新建一个新的会话如下:
代码:

compiz --replace


Compiz 使用emerald 主题:
代码:
emerald --replace



这样,系统就可以在开机后自动加载Compiz Fusion啦。
注意:开机登录是一定要选择会话为xgl,才可以用3d桌面,效果很流畅!!各位不放试一下!!


感谢,这个方法成功了
:lol:


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-10-19 20:32 
头像

注册: 2006-11-11 10:23
帖子: 1226
地址: Mars
送出感谢: 0 次
接收感谢: 0 次
znf19850924 写道:
哈哈 我的 ati 7500的独显 我开了 还有点卡 哈哈


应该不会才对,我的 t40 也是 7500


_________________
抬头望星空一片晴,我独行,夜已渐寒……


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-10-20 22:15 

注册: 2007-01-03 19:29
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
默认是开启桌面效果的,用不着装受限驱动,用了的话,除非你装上XGL,否则反而不能开3D,会提示合成扩展不可用。用回默认的驱动,然后在首选项>外观>视觉效果中打开。祝你好运


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-10-21 1:17 
头像

注册: 2007-10-08 21:55
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
13楼的说的没有错,可是会白屏的,很多人都会出现这样的状况!!!


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 终于开启了3d桌面
帖子发表于 : 2007-10-21 14:03 

注册: 2007-03-08 19:12
帖子: 161
送出感谢: 0 次
接收感谢: 0 次
用受限驱动的话,这两步就可以了,我就是按这个就可以打开桌面效果了。
gx287658129 写道:
首先安装显卡驱动,系统里的受限驱动管理器的ati驱动要打上钩。
修改显卡配置文件
代码:
sudo gedit /etc/X11/xorg.conf

在文件中加入代码:

Section "Extensions"
Option "Composite" "0"
EndSection

Section "ServerFlags"
Option "AIGLX" "off"
EndSection

接着重启,
开机后,在终端下运行
代码:
fglrxinfo
如果看到类似的以下语句:display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon X1200
OpenGL version string: 2.0.6334 (8.34.Cool
显卡驱动完美安装!!
下面是XGL的安装,
首先下载安装
代码:
sudo apt-get install xserver-xgl


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 17 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译