[问题]ati集成x1250问题?

GnomeShell/Unity/Beryl/AiGLX/XGL/Compiz Fusion
回复
头像
gx287658129
帖子: 36
注册时间: 2007-10-08 21:55
送出感谢: 0
接收感谢: 0

[问题]ati集成x1250问题?

#1

帖子 gx287658129 » 2007-10-10 15:46

想问一下集成ati x1250可以流畅运行3d桌面吗?即使不流畅可以运行吗?怎样开启啊?详细点啊,我是菜鸟!!!
zm9913
帖子: 4
注册时间: 2006-12-19 14:06
送出感谢: 0
接收感谢: 0

#2

帖子 zm9913 » 2007-10-11 10:39

同样的菜鸟想知道答案!望达人指导一下!
呆东
帖子: 18
注册时间: 2007-10-05 11:42
送出感谢: 0
接收感谢: 0

#3

帖子 呆东 » 2007-10-12 8:52

可以的,X1250的显卡性能已经不错了
只要你能正确的装好ATI的 驱动就可以了
头像
wanzcong
帖子: 201
注册时间: 2007-08-23 3:52
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 wanzcong » 2007-10-14 11:48

好像得装xgl吧,那样的话性能会降低啊,
头像
gx287658129
帖子: 36
注册时间: 2007-10-08 21:55
送出感谢: 0
接收感谢: 0

#5

帖子 gx287658129 » 2007-10-14 12:02

我现在装了,可是为什么没有效果阿?按照http://forum.ubuntu.org.cn/viewtopic.php?t=62449一文装的阿!!怎么运行阿?在系统管理也有compizconfig-settings-manager 一项阿
头像
lanif08
帖子: 149
注册时间: 2007-07-02 20:53
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 lanif08 » 2007-10-14 22:16

你安装论坛的置顶帖和精华贴做就好了
我的也是x1250的
速度是很快的
头像
lanif08
帖子: 149
注册时间: 2007-07-02 20:53
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 lanif08 » 2007-10-14 22:20

实在不行按http://forum.ubuntu.org.cn/viewtopic.php?t=50750
这个装beryl,个人感觉稳定性比compiz好
头像
imagelife
帖子: 251
注册时间: 2007-10-07 11:56
来自: 湖南
送出感谢: 0
接收感谢: 0

我也一样!!!

#8

帖子 imagelife » 2007-10-18 19:00

听说是8.42版的ati驱动才能够看到3d效果啊
哪个高手发个帖专门说下这个问题!!!
Kdemod是为Arch linux 定制的KDE的一个改进版本,
基于改善的QT,和Arch linux 标准的QT兼容,拥有改进的主题,和许多的附加特性。
使用KDEMod,是感受强大的KDE魅力和简洁强大的Arch最好方式。
头像
gx287658129
帖子: 36
注册时间: 2007-10-08 21:55
送出感谢: 0
接收感谢: 0

#9

帖子 gx287658129 » 2007-10-18 21:39

参考了置顶和精华贴,一下是具体步骤,希望有用!!
首先安装显卡驱动,系统里的受限驱动管理器的ati驱动要打上钩。
修改显卡配置文件
代码:
sudo gedit /etc/X11/xorg.conf

在文件中加入代码:

Section "Extensions"
Option "Composite" "0"
EndSection

Section "ServerFlags"
Option "AIGLX" "off"
EndSection

接着重启,
开机后,在终端下运行
代码:
fglrxinfo
如果看到类似的以下语句:display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon X1200
OpenGL version string: 2.0.6334 (8.34.Cool
显卡驱动完美安装!!
下面是XGL的安装,
首先下载安装
代码:
sudo apt-get install xserver-xgl

然后,创建一个开机加载XGL的脚本文件
代码:
sudo gedit /usr/local/bin/startxgl.sh

在文件中输入
代码:

#!/bin/sh
Xgl :1 -fullscreen -ac -accel xv:pbuffer -accel glx:pbuffer &
DISPLAY=:1
cookie="$(xauth -i nextract - :0 | cut -d ' ' -f 9)"
xauth -i add :1 . "$cookie"
exec dbus-launch --exit-with-session gnome-session

给刚才的文件赋予相关权限
代码:
sudo chmod a+x /usr/local/bin/startxgl.sh

再创建一个XGL进程的文件
代码:
sudo gedit /usr/share/xsessions/xgl.desktop

输入
代码:

[Desktop Entry]
Encoding=UTF-8
Name=GNOME with XGL
Comment=
Exec=/usr/local/bin/startxgl.sh
Icon=
Type=Application

赋予文件可执行权限
代码:
sudo chmod a+x /usr/share/xsessions/xgl.desktop
xgl安装完成

新加源:deb http://ppa.launchpad.net/amaranth/ubuntu feisty main
更新:
代码:

sudo apt-get update
sudo apt-get dist-upgrade

安装Compiz及Compiz fusion
代码:

sudo apt-get install compiz compiz-gnome
sudo apt-get install compizconfig-settings-manager
sudo apt-get install compiz-fusion-*
运行Compiz Fusion
现在你就可以享受Fusion带来的惊喜啦,同时你也可以关闭Compiz及Beryl啦,在“系统-首选项-会话”新建一个新的会话如下:
代码:

compiz --replace


Compiz 使用emerald 主题:
代码:
emerald --replace



这样,系统就可以在开机后自动加载Compiz Fusion啦。
注意:开机登录是一定要选择会话为xgl,才可以用3d桌面,效果很流畅!!各位不放试一下!!
头像
luotao
帖子: 41
注册时间: 2006-12-03 23:36
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 luotao » 2007-10-23 12:09

我也是华硕690g主板,还没有能装好驱动。哪位仁兄有经验,可否分享?
sainry
帖子: 26
注册时间: 2007-07-19 13:28
送出感谢: 0
接收感谢: 0

#11

帖子 sainry » 2007-10-23 21:51

我用的是昂达690G主板,装好7.10后,启用私有驱动,之后什么都不用设置,重启后系统直接打开了3D效果。[/img]
头像
cnlvker
帖子: 88
注册时间: 2007-07-29 23:01
送出感谢: 0
接收感谢: 0

#12

帖子 cnlvker » 2008-09-09 18:32

楼主问题解决了吗?我也和楼主一样的问题
Sam8848
帖子: 4
注册时间: 2008-09-07 9:49
送出感谢: 0
接收感谢: 0

#13

帖子 Sam8848 » 2008-09-11 21:04

以前怎么装都不行,可是今天就成功了。奇怪了。按照7.04-7.10-8.04的顺序升级的。莫名其妙的就好了。我的是昂达a36g的主板。现在运行什么效果都有了。
回复

回到 “桌面特效”