[问题]进不了桌面了,求救

GnomeShell/Unity/Beryl/AiGLX/XGL/Compiz Fusion
回复
hyb123
帖子: 93
注册时间: 2007-10-14 22:23
送出感谢: 0
接收感谢: 0

[问题]进不了桌面了,求救

#1

帖子 hyb123 » 2007-10-15 13:26

装了beryl后,运行发现所有窗口的标题栏都没了,后上论坛看到有人说把受限的显卡去掉就行,结果我在受限硬件里把显卡的选钩去掉,提示我删除显卡动,接着重起,现在我一登陆桌面都是一片空白,要怎样恢复,不会要重装吧。高手救命。
头像
aerowolf
帖子: 1724
注册时间: 2006-02-25 17:09
来自: 西安
送出感谢: 32 次
接收感谢: 3 次

#2

帖子 aerowolf » 2007-10-15 14:21

桌面空白应该是beryl有问题。
我在谷歌用“ubuntu beryl 白屏”搜索了一下。下面几个地址供你参考,希望有用。
post-423096.html&highlight=&sid=7df7a92 ... 21ce8964c3
about47970.html&highlight=&sid=9e9bc7e2 ... 43ea841f0e
viewtopic.php?t=41962&postdays=0&postorder=asc&start=0

解决窗口的标题栏的问题,试试此办法:
先备份原来的配置文件cp xorg.conf xorg.conf.bak, 然后在xorg.conf中Module段加入
SubSection "extmod"
Option "omit xfree86-dga"
EndSubSection
在Device段中加入
Option "DisableGLXRootClipping" "True"
Option "AddARGBGLXVisuals" "True"
Option "AllowGLXWithComposite" "True"
Option "RenderAccel" "True"
在配置文件的最后加入
Section "Extensions"
Option "Composite" "Enable"
EndSection

如果试N卡的话, 运行下面的命令, 再重启X.
sudo nvidia-xconfig --add-argb-glx-visuals #解决没有窗口边框的问题
sudo dpkg-reconfigure -phigh xserver-xorg
OPTION ADDRGBGLXVirtual "true"

祝你好运。
头像
u194252
帖子: 402
注册时间: 2007-08-04 11:06
送出感谢: 0
接收感谢: 0

#3

帖子 u194252 » 2007-10-15 16:51

请问ls,这些代码加在每个段中位置有没有讲究阿?
图片
头像
aerowolf
帖子: 1724
注册时间: 2006-02-25 17:09
来自: 西安
送出感谢: 32 次
接收感谢: 3 次

#4

帖子 aerowolf » 2007-10-15 20:57

我想每段的结尾(EndSection)之前。

粘贴时多粘贴了sudo dpkg-reconfigure -phigh xserver-xorg
OPTION ADDRGBGLXVirtual "true"二行,请见谅。

祝你好运。
头像
aerowolf
帖子: 1724
注册时间: 2006-02-25 17:09
来自: 西安
送出感谢: 32 次
接收感谢: 3 次

#5

帖子 aerowolf » 2007-10-15 20:58

又,xorg.conf位于/etc/x11下面。
回复

回到 “桌面特效”