[问题]全新安装的7.10,执行compiz --replace出错

GnomeShell/Unity/Beryl/AiGLX/XGL/Compiz Fusion
回复
头像
nobuts
帖子: 32
注册时间: 2007-10-14 3:42
来自: Changchun, Hong Kong
送出感谢: 0
接收感谢: 0
联系:

[问题]全新安装的7.10,执行compiz --replace出错

#1

帖子 nobuts » 2007-10-20 5:44

全新安装的,不是升级来的。也安装了compizconfig-settings-manager,我是ATI X200的卡,用的是fglrx的驱动。没有装xgl(据说不用装了),执行compiz --replace后出现以下提示:

代码: 全选

Checking for Xgl: not present. 
No whitelisted driver found
aborting and using fallback: /usr/bin/metacity 
我该怎么办?多谢各位!
头像
nobuts
帖子: 32
注册时间: 2007-10-14 3:42
来自: Changchun, Hong Kong
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 nobuts » 2007-10-20 17:11

please help me.......please
leixinren
帖子: 96
注册时间: 2006-03-14 21:01
送出感谢: 0
接收感谢: 0

#3

帖子 leixinren » 2007-10-20 18:09

我的是升级的,以前在 7.04 下可以用,現在出现这个问题:

Checking for Xgl: not present.
Blacklisted PCIID '8086:29a2' found
aborting and using fallback: /usr/bin/metacity
窗口管理器警告: 在配置数据库中找到的“”不是按键组合“toggle_shaded”的有效值
头像
nobuts
帖子: 32
注册时间: 2007-10-14 3:42
来自: Changchun, Hong Kong
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 nobuts » 2007-10-21 5:05

看來需要裝xgl
头像
Legendaryfish
帖子: 166
注册时间: 2006-06-10 16:55
来自: 厦门.IUE
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 Legendaryfish » 2007-10-21 8:39

是可以用aiglx,不过用fglrx话目前版本是不支持aiglx的,得等8.42出来
@spehio
| ThinkStation A16 | Intel Xeon E5540 @2.53GHZ | Ubuntu 10.10 x64|
| ThinkPad X200 | Inter Core 2 Duo P8400 @2.26GHZ | FreeBSD 8.4 x64|
| MacBookPro 17-inch | Intel i5 @2.3GHZ | Mac Os X Snow Leopard |
头像
daf3707
论坛版主
帖子: 12670
注册时间: 2007-06-13 15:57
来自: 在他乡
送出感谢: 49 次
接收感谢: 85 次

Re: [问题]全新安装的7.10,执行compiz --replace出错

#6

帖子 daf3707 » 2007-10-21 10:36

nobuts 写了:全新安装的,不是升级来的。也安装了compizconfig-settings-manager,我是ATI X200的卡,用的是fglrx的驱动。没有装xgl(据说不用装了),执行compiz --replace后出现以下提示:

代码: 全选

Checking for Xgl: not present. 
No whitelisted driver found
aborting and using fallback: /usr/bin/metacity 
我该怎么办?多谢各位!
我的也是这样,不过我的不是这样的显卡,在“系统管理”里的换了显卡驱动就好了。
crotoc
帖子: 10
注册时间: 2007-10-19 15:21
送出感谢: 0
接收感谢: 0

#7

帖子 crotoc » 2007-10-22 19:43

装xgl
zincx
帖子: 44
注册时间: 2007-03-23 22:11
送出感谢: 0
接收感谢: 0

#8

帖子 zincx » 2007-10-22 23:34

貌似现在 fglrx的驱动 还需要 xgl , 所以建议不要装 xgl , 除非你要在 linux 下运行3D程序才装fglrx的驱动 ,
这样的话,还是不要装xgl 了, 免得影响你的3D程序, 没运行3D程序的话, 直接就不需要装驱动(其实已经装了)
可以直接启动3D效果,而且效果也很不错的。
回复

回到 “桌面特效”