当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 7.10 A卡启用Compiz Fusion(老鸟就不用进了)
帖子发表于 : 2007-10-24 0:21 

注册: 2007-06-20 12:28
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
最近本区有好多同学在安装或升级到7.10后,不能启用3D效果,Compiz Fusion是默认安装的,为什么以前7.04中用beyrl效果不错,而7.10的Compiz Fusion却不行的?和其他同学一样困惑了两天,也没有搜到较好地解释,后来我忽然想起7.04中我是先装了Xgl的,说不定Beyrl、Compiz是构架在Xgl上的(直到发本文时,我才搜到http://wiki.ubuntu.org.cn/index.php?title=Compiz&variant=zh-cn
证实我的猜想是正确的:Compiz 是架构在 Xgl 这个新的 X 环境,使用 OpenGL 绘图层 Glitz 。 Compiz 最早是由 Novell 在2006年一月时公布新版 Xgl 时所发表的。在开发初期Compiz只能正常运行在有限的几种Xgl所支援的硬件3D加速卡上。尽管Xgl和Compiz这两个全新构造的系统还存在一些臭虫并且仍处于积极的开发阶段,大多数NVIDIA和ATI图形处理卡可以在Xgl上正常运行Compiz。)((http://wiki.ubuntu.org.cn/index.php?tit ... iant=zh-cn)Xgl 是一个 X server,他借由OpenGL 技术充分发挥了新一代显示卡优异的3D立体划面表现能力;从「架构」的角度来看,XGL透过了 glitz 位在 OpenGL 的上层。XGL利用了聚合窗口管理器的帮助(像是Compiz 或 Beryl)对所有使用 X、OpenGL 和 XVideo 所制作的应用和图形效果提供了硬件加速的支援,所以能表现出包含调整窗口透明度、可旋转的3D桌面、果冻效果等等令人叹为观止的立体特效。这个计划最初由 David Reveman 发起,并在2006年1月2日的时候第一次释出(release)。)

本帖主要为像我这样的新人提供个方便的设置,也算对Ubuntu的一点贡献,老鸟们见笑了

本帖主要参考几个精华贴还有下面的Wiki
http://wiki.ubuntu.org.cn/index.php?tit ... iant=zh-cn
https://help.ubuntu.com/community/Compo ... lingCompiz
https://help.ubuntu.com/community/Compo ... ringCompiz


1.检查ATI驱动程序
安装你的ATI显卡驱动(系统-->首选项-->受限驱动管理器)
重新启动计算机

在终端中输入:
fglrxinfo
你可以发现在终端有类似于如下的输出:
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON XPRESS Series
OpenGL version string: 2.0.6334 (8.34.8)

2.安装 Xgl
现在安装 Xgl,在新立得软件仓库中搜索以下包xserver-xgl并安装或
Sudo apt-get install xserver-xgl

3.制作xgl的启动脚本:
在终端中输入:
sudo gedit /usr/bin/startxgl

-并且在文件中添加如下行:
Xgl -fullscreen :1 -ac -accel glx:pbuffer -accel xv:pbuffer & sleep 2 && DISPLAY=:1
# Start GNOME
exec gnome-session
保存并关闭文件。
-使脚本可执行
sudo chmod 755 /usr/bin/startxgl.sh

4.创建一个 XGL 登录
-给登录管理器做一个xgl会话:
sudo gedit /usr/share/xsessions/xgl.desktop

-将如下内容输入终端:
[Desktop Entry]
Encoding=UTF-8
Name=XGl
Exec=/usr/bin/startxgl
Icon=
Type=Application
关闭并保存文件。

重启后就能在“系统-首选项-外观-视觉效果”中选择Normal Extra,也可自定义。

5.运行 Compiz Fusion
在终端输入
compiz –-replace
应用窗口解码器(Gnome,KDE 用户为 kde-window-decorator)
$ compiz --replace gconf &
$ gtk-window-decorator --replace &

制作compiz的启动脚本:
$ gksudo gedit /usr/local/bin/start-compiz
-并且在文件中输入如下行:
Nvidia
#!/bin/bash
LD_PRELOAD=/usr/lib/nvidia/libGL.so.1.2.xlibmesa compiz --replace gconf &
gtk-window-decorator --replace
ATI
#!/bin/bash
LD_PRELOAD=/usr/lib/fglrx/libGL.so.1.2.xlibmesa compiz --replace gconf &
gtk-window-decorator --replace
保存并关闭文件。

-使脚本可执行
$ sudo chmod +x /usr/local/bin/start-compiz

这样就可以通过调用start-compiz 来同时启用compiz 和window decorator。也可以将其加入开机自启动选项
-把"/usr/bin/startcompiz"添加到gnome会话启动程序中。(访问“系统/菜单/首选项/会话并选择启动程序标签页)

6.如果想要使用 Compiz Fusion + emerald
在终端输入
sudo apt-get install emerald
compiz --replace -c emerald &
在终端输入
ccsm
或“系统 -> 首选项 -> CompizConfig Settings Manager ” 这里设置 Compiz Fusion。
另外,如果之前安装过 Beryl,可以共存,但我觉得没有必要让它再存在了,直接:
sudo apt-get autoremove beryl*
从现在开始可以忘记 Beryl 了。

“系统-首选项”里会有好几个设置选项,Advanced Desktop effects settings, Emerald Theme manager,GL Desktop.大家也可以安装Fusion-ico,在右上角上将会出现一个图标,可以象Beryl一样对Compiz-Fusion进行设置管理 (此处是引用Codecody的文章 http://forum.ubuntu.org.cn/viewtopic.ph ... highlight=


_________________
对知识的渴求、对美好生活的追寻、对正义的求索、对意义的追问


最后由 sunpeng 编辑于 2007-10-24 12:17,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : 等下试验下
帖子发表于 : 2007-10-24 6:56 

注册: 2007-10-24 6:45
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
顶 造福小鸟


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-10-24 7:38 
头像

注册: 2007-09-25 19:17
帖子: 62
送出感谢: 0 次
接收感谢: 0 次
实在太感谢楼主了,我找了N久的问题,原来就是XGL问题


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-10-24 8:08 

注册: 2006-11-05 8:07
帖子: 81
送出感谢: 0 次
接收感谢: 0 次
~$ compiz –replace
Checking for Xgl: present.
Checking for nVidia: not present.
Checking for Xgl: present.
Enabling Xgl with fglrx ATi drivers...
Starting gtk-window-decorator
/usr/bin/compiz.real (core) - Error: Couldn't load plugin '–replace'
/usr/bin/compiz.real (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-10-24 11:20 
头像

注册: 2007-09-25 19:17
帖子: 62
送出感谢: 0 次
接收感谢: 0 次
和4楼情况一样~~~```````卡了很久啊

楼主帮忙解决~~~`我不想又重装啊~``晕的~~`

现在任务栏动不了~~``哭


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-10-24 12:16 

注册: 2007-06-20 12:28
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
youxin 写道:
~$ compiz –replace
Checking for Xgl: present.
Checking for nVidia: not present.
Checking for Xgl: present.
Enabling Xgl with fglrx ATi drivers...
Starting gtk-window-decorator
/usr/bin/compiz.real (core) - Error: Couldn't load plugin '–replace'
/usr/bin/compiz.real (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format



太对不起了,应该是

compiz --replace


_________________
对知识的渴求、对美好生活的追寻、对正义的求索、对意义的追问


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-10-24 12:56 

注册: 2007-03-06 13:22
帖子: 50
送出感谢: 0 次
接收感谢: 0 次
楼主好像写错了。在ubuntu 7.10 下,只要装完xserver-xgl就可以了,xgl的配置可以不用做了。也就是只要做楼主写的第1,2步就可以了。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-10-24 13:09 

注册: 2007-06-20 12:28
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
bushuhui 写道:
楼主好像写错了。在ubuntu 7.10 下,只要装完xserver-xgl就可以了,xgl的配置可以不用做了。也就是只要做楼主写的第1,2步就可以了。


安装XGL确实可以只做第1,2步,但后面几步是为以后使用方便的
所以谈不上错,各人的要求不一样而已


_________________
对知识的渴求、对美好生活的追寻、对正义的求索、对意义的追问


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-10-24 16:31 
头像

注册: 2007-10-22 9:16
帖子: 35
送出感谢: 0 次
接收感谢: 0 次
我还不太懂 但是准备一会试一下
谢谢LZ造福~


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-10-24 17:48 
头像

注册: 2006-05-18 18:24
帖子: 189
地址: 四川广安
送出感谢: 0 次
接收感谢: 0 次
装上最新的8.42.3驱动,可以直接打开特效了,不再需要xgl了。


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-10-26 16:09 

注册: 2007-06-20 12:28
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
守望伊人 写道:
装上最新的8.42.3驱动,可以直接打开特效了,不再需要xgl了。


好呀。。。


_________________
对知识的渴求、对美好生活的追寻、对正义的求索、对意义的追问


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-11-14 12:50 
头像

注册: 2007-10-14 0:50
帖子: 306
地址: GUCAS
送出感谢: 0 次
接收感谢: 1
最新的8.42.3驱动支持aixgl,所以可以直接开特效。具体可看zhu_qing83的文章。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译