当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [問題][7.10]ATi 8.42.3驅動好像裝上了,但都是開不了compiz!!
帖子发表于 : 2007-10-25 22:18 

注册: 2006-09-11 17:25
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
我是跟這個帖的方法安裝的!
http://forum.ubuntu.org.cn/viewtopic.php?t=83802&highlight=8.42

到這一步就停下來了!!
第八步:重新啟動並讓Compiz Fusion工作
輸入
:~$ SKIP_CHECKS=yes compiz
Checking for Xgl: not present.
No whitelisted driver found
SKIP_CHECKS is yes, so continuing despite problems.
Checking for texture_from_pixmap: not present.
Trying again with indirect rendering:
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: not present.
SKIP_CHECKS is yes, so continuing despite problems.
Checking for nVidia: not present.
Checking for FBConfig: present.
Checking for Xgl: not present.
Starting gtk-window-decorator

(gtk-window-decorator:6550): Gdk-WARNING **: Using Cairo rendering requires the drawable argument to
have a specified colormap. All windows have a colormap,
however, pixmaps only have colormap by default if they
were created with a non-NULL window argument. Otherwise
a colormap must be set on them with gdk_drawable_set_colormap

(gtk-window-decorator:6550): Gdk-WARNING **: Using Cairo rendering requires the drawable argument to
have a specified colormap. All windows have a colormap,
however, pixmaps only have colormap by default if they
were created with a non-NULL window argument. Otherwise
a colormap must be set on them with gdk_drawable_set_colormap
/usr/bin/compiz.real (core) - Fatal: No composite extension<--一直停下來了


:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon X300/X550/X1050 Series
OpenGL version string: 2.0.6958 Release


開不了!!!!!!!
图片


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-10-25 22:51 

注册: 2005-08-06 10:10
帖子: 198
送出感谢: 0 次
接收感谢: 0 次
没安装XGL吧,不知道42版的驱动要不要装Xgl的


页首
 用户资料  
 
3 楼 
 文章标题 : Re: [問題][7.10]ATi 8.42.3驅動好像裝上了,但都是開不了compiz!!
帖子发表于 : 2007-10-26 10:35 

注册: 2007-05-09 14:34
帖子: 88
送出感谢: 0 次
接收感谢: 0 次
composite extension没开开,贴一下xorg.conf
[quote="kitkit210"]我是跟這個帖的方法安裝的!
[url]http://forum.ubuntu.org.cn/viewtopic.php?t=83802&highlight=8.42[/url]

到這一步就停下來了!!
[color=red]第八步:重新啟動並讓Compiz Fusion工作
輸入
:~$ SKIP_CHECKS=yes compiz
Checking for Xgl: not present.
No whitelisted driver found
SKIP_CHECKS is yes, so continuing despite problems.
Checking for texture_from_pixmap: not present.
Trying again with indirect rendering:
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: not present.
SKIP_CHECKS is yes, so continuing despite problems.
Checking for nVidia: not present.
Checking for FBConfig: present.
Checking for Xgl: not present.
Starting gtk-window-decorator

(gtk-window-decorator:6550): Gdk-WARNING **: Using Cairo rendering requires the drawable argument to
have a specified colormap. All windows have a colormap,
however, pixmaps only have colormap by default if they
were created with a non-NULL window argument. Otherwise
a colormap must be set on them with gdk_drawable_set_colormap

(gtk-window-decorator:6550): Gdk-WARNING **: Using Cairo rendering requires the drawable argument to
have a specified colormap. All windows have a colormap,
however, pixmaps only have colormap by default if they
were created with a non-NULL window argument. Otherwise
a colormap must be set on them with gdk_drawable_set_colormap
/usr/bin/compiz.real (core) - Fatal: No composite extension<--一直停下來了
[/color]

[color=green]:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon X300/X550/X1050 Series
OpenGL version string: 2.0.6958 Release
[/color]

開不了!!!!!!!
[img]http://upload.hkplace.net/images/1193320746.png[/img][/quote]


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-10-26 13:13 

注册: 2007-05-27 19:11
帖子: 77
送出感谢: 0 次
接收感谢: 0 次
我也是相同情况,换成老驱动,不过不如在7。04下流畅,而且xgl启动特慢


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-10-27 11:05 

注册: 2006-12-27 23:37
帖子: 56
送出感谢: 0 次
接收感谢: 0 次
在xorg.conf 最后面加上:

Section "Extensions"
Option "Composite" "1"
EndSection

Section "ServerFlags"
Option "AIGLX" "on"
EndSection


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-10-27 11:54 
头像

注册: 2007-02-18 0:42
帖子: 1352
送出感谢: 0 次
接收感谢: 10
加不加都没用,我的卡干脆无法打开3d游戏了。。
glxinfo | grep rendering
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译