我的NB装了7.10无法打开3D特效,怎么回事啊?

GnomeShell/Unity/Beryl/AiGLX/XGL/Compiz Fusion
回复
bornsoft
帖子: 13
注册时间: 2007-11-02 23:43
送出感谢: 0
接收感谢: 0

我的NB装了7.10无法打开3D特效,怎么回事啊?

#1

帖子 bornsoft » 2007-11-05 0:11

IBM ThinkPad X60 1709A33

CPU类型: Intel 酷睿双核 T2300E(1.66GHz)
标称频率: 1660MHz
内存大小: 256MB
硬盘大小: 60GB
光驱类型:
显卡描述: Intel GMA950
屏幕尺寸: 12.1英寸
分辨率: 1024*768


代码: 全选

ubuntu@ubuntu-chinaman:~$ compiz --replace 
Checking for Xgl: not present.
No whitelisted driver found
aborting and using fallback: /usr/bin/metacity



代码: 全选

ubuntu@ubuntu-chinaman:~$ fglrxinfo
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (2.1 Mesa 7.0.1)

ubuntu@ubuntu-chinaman:~$ glxinfo
name of display: :0.0
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
display: :0  screen: 0
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
    GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
    GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_get_proc_address, GLX_SGI_video_sync, GLX_ARB_multisample,
    GLX_ATI_pixel_format_float, GLX_ATI_render_texture
GLX version: 1.2
GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_multisample
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (2.1 Mesa 7.0.1)
OpenGL extensions:
    GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
    GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
    GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
    GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
    GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
    GL_EXT_texture_lod_bias

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x22 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  0  0  0  0  0  0 0 None
0x23 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  8 16 16 16  0  0 0 None
0x24 24 tc  0 32  0 r  y  .  8  8  8  8  0 16  8 16 16 16 16  0 0 None
0x25 24 tc  0 32  0 r  .  .  8  8  8  8  0 16  8 16 16 16 16  0 0 None
0x3d 32 tc  1  0  0 c  .  .  0

  ubuntu@ubuntu-chinaman:~$ glxgears
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
3391 frames in 5.1 seconds = 665.428 FPS
3100 frames in 5.1 seconds = 612.389 FPS
3480 frames in 5.2 seconds = 673.619 FPS
0  0  0  0  0  0  0  0  0  0  0 0 None
ubuntu@ubuntu-chinaman:~$
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2007-11-05 0:33

direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
没驱动。
● 鸣学
lonely
帖子: 109
注册时间: 2007-01-16 18:50
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 lonely » 2007-11-05 1:25

eexpress 写了:direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
没驱动。


我的也是,但FPS能到1800

用XGL就好

COMPIZ也正常,機子是6515b
刷新GNOME面板 : killall gnome-panel
XORG:sudo dpkg-reconfigure -phigh xserver-xorg
清理删除的残余配置: dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
注册表gconf-editor
mount --rbind olddir newdir
ltkun
帖子: 1335
注册时间: 2006-01-10 19:09
送出感谢: 0
接收感谢: 0

#4

帖子 ltkun » 2007-11-05 9:41

950的没有问题的你的驱动没有用intel?
bornsoft
帖子: 13
注册时间: 2007-11-02 23:43
送出感谢: 0
接收感谢: 0

#5

帖子 bornsoft » 2007-11-05 10:44

怎么装啊?我真的没有思路啊。
mouse21
帖子: 107
注册时间: 2006-12-19 10:14
送出感谢: 0
接收感谢: 0

#6

帖子 mouse21 » 2007-11-05 15:53

用Kubuntu时也出现这样的提示,想装xgl提示包丢失!我的是intel845g,帮顶!
bornsoft
帖子: 13
注册时间: 2007-11-02 23:43
送出感谢: 0
接收感谢: 0

#7

帖子 bornsoft » 2007-11-08 15:29

哈哈,我已经解决了。

运行 sudo dpkg-reconfigure xserver-xorg
重新配置一下显卡就可以了。不过事前要先装个包,用“新立得”装,915resolution,

915resolution is a tool to modify the video BIOS of the 800
and 900 series Intel graphics chipsets. This includes the 845G,
855G, and 865G chipsets, as well as 915G, 915GM, and 945G chipsets.
This modification is necessary to allow the display of certain
graphics resolutions for an Xorg or XFree86 graphics server.


OK,一切都好了,但是发现运行了3D后,机器速度好慢啊。真是惨啊。我这么好的电脑,也运行不了,真是可悲啊。
回复

回到 “桌面特效”