当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : N卡GF4 MX440安装驱动后就死机
帖子发表于 : 2007-11-05 17:26 

注册: 2006-06-18 14:13
帖子: 68
送出感谢: 0 次
接收感谢: 0 次
我用的N卡GF4 440听起来都有点古老了,在7.04时,我就曾启动过“桌面效果”,一启动后,就叫我安装新的驱动,但一安装完成后再重启,但出现 了问题:启动画面后,就黑屏,不能进入桌面,且按数字键,灯也没有变化,应该是死机了吧。

我曾试过一些办法,也将源里的几个GLX程序装过,但还是不行,不知道大家遇到过这样的问题没有。另外,我现在用的是7.10,今天 才升的级,以前装过一次,但当激活“激活Nvidia图形加速驱动”就就装新的驱动,装完重启,又会遇到和上面叙述中一样的黑屏死机的情况。

请大家帮我想下办法,我该怎么做,才能开启桌面效果?


多谢!


附件:
Screenshot-受限制的驱动程序.png
Screenshot-受限制的驱动程序.png [ 19.23 KiB | 被浏览 1919 次 ]

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-11-05 17:27 

注册: 2006-06-18 14:13
帖子: 68
送出感谢: 0 次
接收感谢: 0 次
这是我的xorg.conf文件内容。


引用:
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "nVidia Corporation NV17 [GeForce4 MX 440-SE]"
Driver "nv"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "通用显示器"
Option "DPMS"
HorizSync 30-70
VertRefresh 50-150
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation NV17 [GeForce4 MX 440-SE]"
Monitor "通用显示器"
DefaultDepth 24
SubSection "Display"
Depth 16
Modes "1152x800" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x400" "1x1"
EndSubSection
SubSection "Display"
Depth 24
Modes "1152x800" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x400" "1x1"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

Section "DRI"
Mode 0666
EndSection



页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-11-05 17:29 
头像

注册: 2007-01-28 23:00
帖子: 2682
地址: @江西|南昌@
送出感谢: 0 次
接收感谢: 0 次
明确的告诉你 MX440 完全可以开 特效。。。 但是驱动我是直接从NVIDIA网站下载的 直接编译安装的。并且你要注意版本,MX440不能用最新的,只能用一个旧版本,9631似乎是这个。你看看吧!!!


_________________

Do as you would be done by !


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-11-05 17:35 

注册: 2006-06-18 14:13
帖子: 68
送出感谢: 0 次
接收感谢: 0 次
谢谢,请问下你是按照什么步骤来做的。因为我用这个系统还不久,很多东西还不知道怎么去用呢,至于编译,就更搞不懂了,只有看到别人的做法来做。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-11-05 17:40 
头像

注册: 2006-05-03 0:39
帖子: 8273
地址: المريخ
送出感谢: 0 次
接收感谢: 1
我也是这显卡,完全按照系统的指引装就行了,一点问题都没有。

LZ不要急,只是你说的我还不能确定问题所在。


_________________
PHP是最好的语言!不服来战!


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-11-05 17:49 

注册: 2006-06-18 14:13
帖子: 68
送出感谢: 0 次
接收感谢: 0 次
装过N次系统了,都为了这个,呵呵,我是有点急了哈.

只要我一启动那个受限驱动后,重启就出问题了.一直找不出问题所在,也就一直没有安装成功过.


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-11-06 19:06 

注册: 2005-11-15 15:04
帖子: 154
送出感谢: 0 次
接收感谢: 0 次
huzi 写道:
装过N次系统了,都为了这个,呵呵,我是有点急了哈.

只要我一启动那个受限驱动后,重启就出问题了.一直找不出问题所在,也就一直没有安装成功过.

我单位的一台用mx440的显卡安装ubuntu,用升级的方法升级到7.10的话,驱动反复装了好多次都不行。
后来直接用7.10的DVD光盘安装,一次就OK了。
如果你是升级7.10的话,不妨试试直接用7.10的光盘安装。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-11-06 21:55 

注册: 2006-07-09 19:22
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
我的一台机器是从7.04升级的,通过受限驱动安装的没问题。后来另一台机器一样的配置,是直接装的7.10,就无法通过系统的受限驱动安装显卡驱动。而且我自己安装官方驱动明明成功了,但是第二次重启以后就失败了。后来我又重装了一遍系统,然后装上基本的编译包,然后就直接装官方驱动。就OK了。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-11-07 14:39 

注册: 2007-09-25 20:31
帖子: 22
地址: 江苏无锡江南大学
送出感谢: 0 次
接收感谢: 0 次
我用的也是这个卡,也是因为这样 的原因重装过一次系统了,
wine CS 很卡,魔兽根本不能玩,怀疑就是因为显卡驱动的原因。。
驱动用哪个版本的?在哪里下?


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-11-11 21:21 

注册: 2006-08-30 11:16
帖子: 477
地址: 广东阳春
送出感谢: 0 次
接收感谢: 0 次
我就用nvidia-glx就可以了


_________________
http://hi.baidu.com/ferlycn


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-11-11 22:01 
头像

注册: 2007-05-19 23:18
帖子: 314
地址: 广东珠海
送出感谢: 0 次
接收感谢: 0 次
asky800 写道:
我就用nvidia-glx就可以了
我也是这种显卡!受限驱动可以用上!但你要改改! xorg.conf

代码:
Section "Device"
Identifier "nVidia Corporation NV17 [GeForce4 MX 440-SE]"
Driver "nv"
BusID "PCI:1:0:0"
EndSection


改前请先备份!有问题就可以恢复!

代码:
Driver "nv" 改成这样  Driver "nvidia"

还用加上
代码:
Option         "AddARGBGLXVisuals" "true"
  Option         "DynamicTwinView" "False"


试试吧!应该是这问题!


_________________
凡事都可行.但不都有益处。凡事都可行.但不都造就人。(哥林多前10:23)

my blog : http://gdzhljw.blog.163.com/
http://gdzhljw.blog.ubuntu.org.cn/


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-11-15 22:42 

注册: 2006-06-18 14:13
帖子: 68
送出感谢: 0 次
接收感谢: 0 次
我现在用的是直接安装而成的7.10,但问题依然存在,选了“受限制驱动”后,安装上了nvidia-glx,而且看了下xorg.conf也变成了这样:
代码:
Section "Device"
   Identifier   "nVidia Corporation NV17 [GeForce4 MX 440-SE]"
   Driver      "nvidia"
   Busid      "PCI:1:0:0"
   Option      "AddARGBVisuals"   "True"
   Option      "AddARGBGLXVisuals"   "True"
   Option      "NoLogo"   "True"
EndSection

Section "Monitor"
   Identifier   "通用显示器"
   Option      "DPMS"
   Horizsync   28-80
   Vertrefresh   43-60
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "nVidia Corporation NV17 [GeForce4 MX 440-SE]"
   Monitor      "通用显示器"
   Defaultdepth   24
   SubSection "Display"
      Modes      "1024x768"   "832x624"   "800x600"   "720x400"   "640x480"   "640x400"   "1x1"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
  screen "Default Screen"
   Inputdevice   "Generic Keyboard"
   Inputdevice   "Configured Mouse"
   
   # Uncomment if you have a wacom tablet
   #   InputDevice     "stylus"   "SendCoreEvents"
   #   InputDevice     "cursor"   "SendCoreEvents"
   #   InputDevice     "eraser"   "SendCoreEvents"
EndSection
Section "Module"
   Load      "glx"
EndSection


但重启后,一样是该进入桌面时死机,也就是连登录窗口都没看到。请大家指教下。


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-11-16 0:10 

注册: 2006-06-18 14:13
帖子: 68
送出感谢: 0 次
接收感谢: 0 次
我刚刚试了下,用官方的驱动(版本:NVIDIA-Linux-x86-96.43.01-pkg1.run),按照http://wiki.ubuntu.org.cn/index.php?title=Nvidia%E6%89%8B%E5%86%8C&variant=zh-cn的方法来做的,结果,还是一样,没进桌面就死机了。


知道的朋友,请指教下。这个问题实在困我得太久了! :cry: :cry: :cry: :cry: :cry:


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-11-16 1:57 
头像

注册: 2006-11-01 3:21
帖子: 253
送出感谢: 0 次
接收感谢: 0 次
我的卡是FX 5200
问题跟楼主一样,安装了受限驱动后开机就黑屏一片
如果我要在文字下改XORG.CONF但是GEDIT不能用
我要改那一个去修改?


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2007-11-16 7:35 

注册: 2007-10-11 10:08
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
huzi 写道:
我现在用的是直接安装而成的7.10,但问题依然存在,选了“受限制驱动”后,安装上了nvidia-glx,而且看了下xorg.conf也变成了这样:
代码:
Section "Device"
   Identifier   "nVidia Corporation NV17 [GeForce4 MX 440-SE]"
   Driver      "nvidia"
   Busid      "PCI:1:0:0"
   Option      "AddARGBVisuals"   "True"
   Option      "AddARGBGLXVisuals"   "True"
   Option      "NoLogo"   "True"
EndSection

Section "Monitor"
   Identifier   "通用显示器"
   Option      "DPMS"
   Horizsync   28-80
   Vertrefresh   43-60
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "nVidia Corporation NV17 [GeForce4 MX 440-SE]"
   Monitor      "通用显示器"
   Defaultdepth   24
   SubSection "Display"
      Modes      "1024x768"   "832x624"   "800x600"   "720x400"   "640x480"   "640x400"   "1x1"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
  screen "Default Screen"
   Inputdevice   "Generic Keyboard"
   Inputdevice   "Configured Mouse"
   
   # Uncomment if you have a wacom tablet
   #   InputDevice     "stylus"   "SendCoreEvents"
   #   InputDevice     "cursor"   "SendCoreEvents"
   #   InputDevice     "eraser"   "SendCoreEvents"
EndSection
Section "Module"
   Load      "glx"
EndSection


但重启后,一样是该进入桌面时死机,也就是连登录窗口都没看到。请大家指教下。


检查一下这一段:
Section "Monitor"
Identifier "通用显示器"
Option "DPMS"
Horizsync 28-80
Vertrefresh 43-60
EndSection

看看

Horizsync 28-80
Vertrefresh 43-60

这两个参数对不对


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译