当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求救。3D效果出不来
帖子发表于 : 2007-11-07 23:08 

注册: 2007-11-07 20:55
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
A卡的驱动也装了,受限的A卡也启用了,CCSM也装了,终端里执行compiz命令就是不行,请各位大大们帮帮忙。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-11-08 9:21 

注册: 2007-11-07 20:55
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
顺便在说一下A卡是X850的,在系统--首选项--外观--效果里其他三个都选不了,一选就报错


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-11-09 12:17 

注册: 2007-08-04 2:21
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
我也是呀,我的是X800XL,也是开启不了


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-11-09 12:23 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
需要错误提示啊。别人猜谜哦。


_________________
● 鸣学


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-11-09 12:24 

注册: 2007-07-10 9:06
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
引用:
Ubuntu7.10发布后,因为它集成了compiz-fusion,可以很方便地实现3D效果,很多朋友都很想体验,但是好像安装过程不太清楚而不能实现,现在把我的配置过程写出来,以供参考(ATI显卡)。
1.安装完系统后再设置软件源,然后更新系统,命令:
sudo apt-get upgrade
此时运行glxgears为4400多帧。
2.因为系统默认不安装显卡驱动,所以得手动安装,系统光盘里就有,不用去网上下载,把系统盘放入光驱,在“系统-系统管理-受限驱动管理器”可以看到显卡,点击“已启用”,
自动从光盘中寻找驱动安装,然后重启。测试一下:
运行fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON X800 GTO
OpenGL version string: 2.0. 6473 (8.37.6)
运行glxgears得7800多帧,有近一倍的性能提升。
都说Ubuntu更新快,但是显卡驱动只到8.37.6,ATI官方都到8.40.4了。
如果实在不清楚的话,干脆使用命令:
sudo apt-get install xorg-driver-fglrx(显卡驱动的名称)
3.联网,在“系统-系统管理-新立得软件包管理器”中以“compiz”,“xgl”为关键词搜索,分别安装下面两个软件包:
compizconfig-settings-manager
xserver-xgl
下图所示:


安装完后重启。
4.在“系统-首选项-外观-视觉效果”中选择自定义,并单击“gtk首选项”其效果等同于在“系统-首选项”点击“Advanced Dekdtop Effects Settings”,弹出“compiz config 设置管理器”对话框,将“桌面立方体”,“旋转立方体”,“立方体倒映”选中。然后按Ctrl+Alt,同时点击鼠标左键并移动,怎么样,出现立方体了吧。其它的功能自己摸索吧,但是不要选的太多,各个特效插件之间是有冲突的,我曾因为选的特效太多而重装了两遍系统。网上很多文章介绍各个插件的作用的,自己搜吧。

5.Ubuntu7.10默认的主题不是很好看,可以在新立得软件包管理器”中以“emerald”为关键词搜索,安装下面两个软件包:
Emerald
Libemeraldengine
并从https://svn.generation.no/emerald-themes/下载主题导入就行了。
Emerald主题与compiz-fusion配合起来相当的漂亮。
6.我是用ATI显卡实现的,NVIDIA显卡也一样,其机制就是Graphic Driver+XGL+compiz-fusion,所以配置过程是一样的。


我是看这个帖子装好的。显卡是R9700mobile。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-11-09 13:21 

注册: 2007-01-16 18:50
帖子: 109
送出感谢: 0 次
接收感谢: 0 次
装XGL没,还有COMPIZ-FUSION装没,装了应该没事


_________________
刷新GNOME面板 : killall gnome-panel
XORG:sudo dpkg-reconfigure -phigh xserver-xorg
清理删除的残余配置: dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
注册表gconf-editor
mount --rbind olddir newdir


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-11-10 20:49 

注册: 2007-08-27 0:48
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
我也是这个问题。。。不知道5楼的方法行不行 一会儿测试下


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-11-11 13:17 

注册: 2007-11-07 20:55
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
zhuqin_83 写道:
安装编译所必须的工具
代码:
sudo apt-get update
sudo apt-get install module-assistant build-essential fakeroot dh-make debhelper debconf libstdc++5 linux-headers-$(uname -r)

创建deb包
注意:执行下面的命令的前提是,你必须cd到你下载的驱动的当前目录。不知道什么是cd命令的话,把下面的xxx.run的部分删掉,然后把你的驱动直接拖到终端,其余部分不变。终端在主菜单的附件子菜单。

Feisty:
代码:
sh *.run --buildpkg Ubuntu/feisty

gutsy:
代码:
sh *.run --buildpkg Ubuntu/gutsy

屏蔽fglrx核心模块
注意,如果你已经安装了linux-restricted-modules的话,那么此步必做。否则可以跳过(一般都要做)。
代码:
sudo gedit /etc/default/linux-restricted-modules-common
代码:
DISABLED_MODULES=""
改成
代码:
DISABLED_MODULES="fglrx"

安装deb包
代码:
sudo dpkg -i xorg-driver-fglrx_*.deb fglrx-kernel-source*.deb fglrx-amdcccle*.deb

移除旧的fglrx
如果你是第一次做,那么会提示你这个文件找不到。别管他,继续往下做就could 是。
代码:
sudo rm /usr/src/fglrx-kernel*.deb
sudo apt-get -f install

编译内核模块并安装
代码:
sudo module-assistant prepare
sudo module-assistant update
sudo module-assistant build fglrx
cd /usr/src
sudo dpkg -i fglrx-kernel-*.deb
sudo depmod -a

配置驱动
注意,如果以前装过fglrx驱动,此步无须再做。
代码:
sudo dpkg-reconfigure xserver-xorg
在选择驱动时,选择fglrx
或者用
代码:
sudo aticonfig --initial -f
以上方法只能两者择一。
然后
代码:
sudo aticonfig --ovt=Xv

如果执行出错,则把备份的xorg.conf.xx改名,用mv命令。
其实本语句相当于在/etc/X11/xorg.conf的Device段添加两行:
代码:
Option      "VideoOverlay"      "on"
Option      "OpenGLOverlay"     "off"

并且
代码:
sudo gedit /etc/X11/xorg.conf
添加两段
代码:
Section "Extensions"
        Option  "Composite" "0"
EndSection

Section "ServerFlags"
        Option  "AIGLX" "off"
EndSection
上面这两段很重要!(在7.04中,如果你用了sudo dpkg-reconfigure来配置的话,第一段应该已经有了)。另外,如果你安装了8.42.3版本,并且想开启aiglx,则这两段应该是:
代码:
Section "Extensions"
        Option  "Composite" "1"
EndSection

Section "ServerFlags"
        Option  "AIGLX" "on"
EndSection


重启系统





安照上面的方法安装之后,执行 fglrxinfo能认到显卡,但在外观--效果里选择自定义或者另外两个都提示desktop effects could no be enabled是什么问题


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-11-11 13:44 

注册: 2007-08-27 0:48
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
我也是desktop effects could no be enabled继续等待高手解决。。。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-11-11 22:19 

注册: 2007-11-11 21:52
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
能不能搞个统一 的答案 阿!


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-11-11 22:20 

注册: 2007-11-11 21:52
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
我的也不呢能!


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-11-12 9:20 

注册: 2007-07-10 9:06
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
第一步,在受限驱动管理器里勾上显卡驱动,安装驱动,然后重新启动。
第二步,安装ccsm和xserver-xgl。
第三步,在视觉效果里选择自定义,打开ccsm,勾选旋转立方体和桌面立方体。
我的机器在完成了这三步后就可以用3d 桌面了。

机器:Athlon 3000+ R9700mobile


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-11-23 12:42 
头像

注册: 2007-11-12 17:29
帖子: 58
送出感谢: 0 次
接收感谢: 0 次
窗口开一行,记得一定要在一行上,至少四个窗口, 然后启动 桌面立方体和旋转立方体。
快捷键
即可


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译