当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 43 篇帖子 ]  前往页数 1, 2, 3  下一页
作者 内容
1 楼 
 文章标题 : 安装最新的compiz和fusion及最新的插件!(增加Autumn插件)
帖子发表于 : 2007-11-15 13:36 

注册: 2007-06-08 22:57
帖子: 81
送出感谢: 0 次
接收感谢: 0 次
一、如果用7.10带的compiz,安装其他插件:
1.
代码:
sudo apt-get install compiz-bcop compiz-dev build-essential libxcomposite-dev libpng12-dev libsm-dev libxrandr-dev libxdamage-dev libxinerama-dev libstartup-notification0-dev libgconf2-dev libgl1-mesa-dev libglu1-mesa-dev libmetacity-dev librsvg2-dev libdbus-1-dev libdbus-glib-1-dev libgnome-desktop-dev libgnome-window-settings-dev gitweb curl autoconf automake automake1.9 libtool intltool libxslt1-dev xsltproc emerald x11proto-scrnsaver-dev libxss-dev

2.
代码:
mkdir -p  ~/compiz/

3.
代码:
wget -O /tmp/3d.tar.gz 'http://gitweb.opencompositing.org/?p=fusion/plugins/3d;a=snapshot;h=db3c51d6c5c0df268fc1ec29a4264ef3d21dbbb3'
wget -O /tmp/atlantis.tar.gz 'http://gitweb.opencompositing.org/?p=fusion/plugins/atlantis;a=snapshot;h=a47d7151444faccd66ea5cb884673cdebe5d7dff'
wget -O /tmp/screensaver.tar.gz 'http://gitweb.opencompositing.org/?p=users/pafy/screensaver;a=snapshot;h=6565001eb389fb0d18cfead6030054cc8edc6c5f'
wget -O /tmp/freewins.zip http://smspillaz.googlepages.com/freewins-0.3-0.6.zip
wget -O /tmp/tile.tar.gz 'http://gitweb.opencompositing.org/?p=fusion/plugins/tile;a=snapshot;h=550c91fa188efd39c9cea43f894b45716b5cc6d5'
wget -O /tmp/photowheel-0.6.tar.gz 'http://gitweb.opencompositing.org/?p=users/b0le/photowheel;a=snapshot;h=41d8090b55b629f72bef55d785beaf468f31662f'

雪花:http://gitweb.opencompositing.org/?p=fusion/plugins/snow;a=snapshot;h=01d0ff6ec71dae4699bc990e0114569c8ad4e083
代码:
wget -O /tmp/atlantis2.tar.gz 'http://gitweb.compiz-fusion.org/?p=users/smspillaz/atlantis2-0.6;a=snapshot;h=d50d17bcdef5a025699e6b1bc0d604a98d1b74b2;sf=tgz'
wget -O /tmp/anaglyph.tar.gz 'http://oreaus.googlepages.com/anaglyph.tar.gz'
wget -O /tmp/wallpaper.tar.gz 'http://gitweb.compiz-fusion.org/?p=fusion/plugins/wallpaper;a=snapshot;h=c2d19686e46ae171b6a0c04da9de1adbd74ae8be'

4.
代码:
tar -xf '/tmp/3d.tar.gz' -C ~/compiz/
tar -xf '/tmp/atlantis.tar.gz' -C ~/compiz/
tar -xf '/tmp/screensaver.tar.gz' -C ~/compiz/
unzip -d ~/compiz /tmp/freewins.zip

5.
代码:
cd ~/compiz/3d
make clean
make
make install

同样方法安装其他插件。
运行附件setup_compiz_applet可以直接完成2-5步的操作,感谢sonixrp
二、安装最新的compiz0.6.2和compiz fusion0.6.0和其他插件
1.
代码:
sudo apt-get install build-essential libxcomposite-dev libpng12-dev libsm-dev libxrandr-dev libxdamage-dev libxinerama-dev libstartup-notification0-dev libgconf2-dev libgl1-mesa-dev libglu1-mesa-dev libmetacity-dev librsvg2-dev libdbus-1-dev libdbus-glib-1-dev libgnome-desktop-dev libgnome-window-settings-dev gitweb curl autoconf automake automake1.9 libtool intltool libxslt1-dev xsltproc python-pyrex python-dev libwnck-dev

2.下载http://somelinuxguy94.googlepages.com/makecompiz4-gnome-0.6.0-usr.tar.gz
3.解压后双击里面的installcompizgnome-deb文件,选择在终端运行,将会自动下载和安装compiz0.6.2和compiz fusion0.6.0
4.双击里面的install-additional-plugins文件,选择在终端运行,将会自动下载和安装其他插件
5.在会话中添加fusion-icon
6.注销再登录就OK了
7.如果不能出现,就按照先安装compiz,再安装libcompizconfig,再安装compizconfig-python,再编译compiz-bcop,后面的顺序就无所谓了。再编译一次。命令:
代码:
cd compiz-0.6.2
./configure --prefix=/usr
make
sudo make install

具体可参照我的贴:http://forum.ubuntu.org.cn/viewtopic.php?t=87062
8.如果是其他插件不能用就按照下面的例子重新编译一下就行了
代码:
cd ~/compiz/3d
make clean
make
make install

三、从git编译compiz并使用最新的fusion!
1、下载附件bp-compiz.zip 去掉.zip
2、cd 到bp-compiz所在位置
3、sudo bash bp-compiz
4、一路回车下去就行了,当然使用kde的要选择kde,默认是gnome
5、去http://gitweb.opencompositing.org/下载最新你的插件编译,多数都可以编译成功,看一下我的插件有多少?
四.增加Autumn插件,即秋天落叶的插件,很漂亮的哦!
1.下载:Autumn和autumninstall.sh.zip 附件去掉.zip
2.将这两个文件放在同一文件夹,终端运行:bash ./autumninstall.sh
祝大家使用愉快。


附件:
autumninstall.sh.zip [975 Bytes]
被下载 460 次
Autumn.tar.gz [343.33 KiB]
被下载 956 次
文件注释: 请把脚本名更为setup_compiz_applet再使用,注意需要sudo哦!
setup_compiz_applet.tar [2.8 KiB]
被下载 429 次
Screenshot-CompizConfig 设置管理器.png
Screenshot-CompizConfig 设置管理器.png [ 182.34 KiB | 被浏览 10004 次 ]

Screenshot.png
Screenshot.png [ 276.88 KiB | 被浏览 9622 次 ]

bp-compiz.zip [23.97 KiB]
被下载 246 次


最后由 cedccy 编辑于 2007-11-26 21:27,总共编辑了 12 次
页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-11-15 14:43 
头像

注册: 2007-10-25 8:39
帖子: 52
地址: gz
送出感谢: 0 次
接收感谢: 0 次
cd ~/compiz/3d 前面几步都成功了 但找不到.compiz这个文件夹是什么问题阿,我的系统是7.10。显卡是tnt的安装了显卡驱动,不过也启动不了3d效果。 compiz默认是在那个位置的?


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-11-15 14:46 

注册: 2007-04-24 11:38
帖子: 210
地址: 火星中国
送出感谢: 0 次
接收感谢: 0 次
listen 写道:
cd ~/compiz/3d 前面几步都成功了 但找不到.compiz这个文件夹是什么问题阿,我的系统是7.10。显卡是tnt的安装了显卡驱动,不过也启动不了3d效果。 compiz默认是在那个位置的?



这个是LZ自己建在家目录底下的文件夹


_________________
我喜欢你就要喜欢你的一切!~
ATI驱动驱不上去的看


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-11-15 16:45 

注册: 2007-06-08 22:57
帖子: 81
送出感谢: 0 次
接收感谢: 0 次
终于可以使用所有插件了
star设置为Super+F4
anaylph设置为Super+F5、6,可惜没那种眼镜不然可以体验真正的3D桌面了


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-11-15 21:42 

注册: 2007-06-30 20:56
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
做第一步的时候我出现这样的问题:Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
libgnome-desktop-dev: Depends: libgnome-desktop-2 (= 1:2.20.0-0ubuntu1) but 1:2.20.1-0ubuntu1 is to be installed
E: Broken packages
请各位帮我看一下,谢谢!


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-11-15 22:50 

注册: 2007-06-08 22:57
帖子: 81
送出感谢: 0 次
接收感谢: 0 次
update一下再试看看
要先安装7.10的compiz哦


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-11-16 1:24 

注册: 2007-11-10 20:57
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
"解压后双击里面的installcompizgnome-deb文件,选择在终端运行"
这句话说在终端运行,怎么运行?不太会,打开的是文件编辑器.


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-11-16 12:20 

注册: 2005-05-19 9:47
帖子: 220
送出感谢: 1
接收感谢: 0 次
脚本应该有问题吧,我试的时候,把我的一些中文语言文件也给删除了,最后也没编译成功,firefox还变成了英文的。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-11-16 12:25 

注册: 2007-04-24 11:38
帖子: 210
地址: 火星中国
送出感谢: 0 次
接收感谢: 0 次
请以上各位兄弟确认你们CF的版本


_________________
我喜欢你就要喜欢你的一切!~
ATI驱动驱不上去的看


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-11-17 6:44 
头像

注册: 2007-05-16 18:19
帖子: 65
地址: 福建泉州
送出感谢: 0 次
接收感谢: 0 次
请问楼主anaglyph插件是怎么安装的?


_________________
UBUNTU 爱好者 QQ :313406616


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-11-17 7:02 
头像

注册: 2007-01-25 16:43
帖子: 786
地址: 塔尔塔洛斯
送出感谢: 0 次
接收感谢: 0 次
赞!
搞好了


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-11-17 10:46 
头像

注册: 2007-01-25 16:43
帖子: 786
地址: 塔尔塔洛斯
送出感谢: 0 次
接收感谢: 0 次
compiz-core.h到哪找?编译snow缺这个文件


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-11-17 11:42 
头像

注册: 2007-05-19 23:18
帖子: 314
地址: 广东珠海
送出感谢: 0 次
接收感谢: 0 次
顶啊!我喜欢!


_________________
凡事都可行.但不都有益处。凡事都可行.但不都造就人。(哥林多前10:23)

my blog : http://gdzhljw.blog.163.com/
http://gdzhljw.blog.ubuntu.org.cn/


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-11-17 11:49 
头像

注册: 2007-03-15 23:44
帖子: 377
送出感谢: 0 次
接收感谢: 1
compiz-fusion官方不是说其中的一些会引发问题吗?


_________________
For the love of PL7s
图片
图片


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2007-11-17 15:58 

注册: 2007-02-25 16:56
帖子: 1261
送出感谢: 0 次
接收感谢: 0 次
装多了容易出问题。。。 :D


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 43 篇帖子 ]  前往页数 1, 2, 3  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译