T60本本ati X1400显卡Gutsy下成功安装ati 8.42.3最新驱动并成功开启compiz

GnomeShell/Unity/Beryl/AiGLX/XGL/Compiz Fusion
wayne1017
帖子: 46
注册时间: 2006-06-09 1:38
送出感谢: 0
接收感谢: 0

T60本本ati X1400显卡Gutsy下成功安装ati 8.42.3最新驱动并成功开启compiz

#1

帖子 wayne1017 » 2007-11-24 3:59

今天在ati的官网上发现又有新的驱动了,对ati 8.42.3驱动效果不满意的人可以去下载新的驱动:ATI Catalyst™ 7.11

过程颇为曲折,但最终成功了。下面详细道来
首先我参照了这个帖子英文的http://ubuntuforums.org/showthread.php?t=593348
这个帖子TX有翻译的中文版:http://linuxdesktop.cn/2007/10/24/install-ati-8-42-3-driver-under-gutsy
但是我按照这种方法并没有成功,每次到了sudo m-a install fglrx-kernel这一步时就报错。
没办法,另辟蹊径,找到了这个帖子:http://www.mvpdream.org/blog/2007/10/ati-8423-driver-for-linux.html并最终成功了。但是这个网页里面说的方法不够详细且无法开启compiz,经过我对几个方法的综合,总结如下成功安装并成功开启compiz的方法

步骤如下:
第一步:下载驱动
把以下驱动下载到你要放置的地方,我是放在主目录下的:
http://www2.ati.com/drivers/linux/ati-driver-installer-8.42.3-x86.x86_64.run

第二步:移除旧驱动
假如之前你是用xgl的,请执行以下命令移除旧的fglrx驱动

代码: 全选

sudo apt-get remove xserver-xgl

然后到“系统”-“系统管理”-“受限驱动管理器” 处取消掉之前的驱动,或者也可以执行:

代码: 全选

sudo apt-get remove xorg-driver-fglrx

最后删除旧的fglrx软件包

代码: 全选

sudo rm -f /usr/src/fglrx-kernel*.deb

移除完毕后,就重新启动吧!
重启以后,就只能以低分辨率进入了桌面环境了。

第三步:开始安装驱动
首先杀掉Gnome桌面,输入命令:

代码: 全选

sudo /etc/init.d/gdm stop

再按下Ctrl+Alt+F1进入终端,并登录
我下载的驱动保存在主文件夹下的,那么就可以使用命令:

代码: 全选

sudo sh ati-driver-installer-8.42.3-x86.x86_64.run

随后就可以跟着显卡驱动向导来进行操作,一般都采用其默认设置就可以了。
输入命令重启:

代码: 全选

sudo reboot


第四步:修改xorg.conf文件,设置驱动
重启以后,这个时候还需要设置一下xorg.conf文件
输入命令:

代码: 全选

sudo gedit /etc/X11/xorg.conf

如果你的xorg.conf文件中没有下面的Section或者跟下面的这些Section不一样的话,请添加或者修改相应的Section:

Section "Module"
Load "dri"
Load "v4l"
Load "dbe"
Load "glx"

EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

#注意此处的Device这个Secion里面的红色部分必须有,如果红色部分不一致,请修改
Section "Device"
Identifier "Generic Video Card"
Driver "fglrx"
BusID "PCI:1:0:0"
Option "AIGLX" "true"
EndSection


第五步:重启并开启compiz
输入命令重启:

代码: 全选

sudo reboot

重启以后,进入桌面在终端输入以下命令检查驱动是否安装好:

代码: 全选

fglrxinfo

应该显示如下信息:
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon X1400
OpenGL version string: 2.0.6958 Release

输入如下命令检查:

代码: 全选

glxinfo | grep rendering

应该显示如下信息
direct rendering: Yes

如果上面两个命令都运行成功了,恭喜你,驱动已经装好了。
在“系统”-“首选项”-“外观”-“视觉效果”中点击特效就可以开启啦。
A卡的用户,大家尽情享受吧 :D
上次由 wayne1017 在 2007-11-25 18:11,总共编辑 3 次。
wayne1017
帖子: 46
注册时间: 2006-06-09 1:38
送出感谢: 0
接收感谢: 0

#2

帖子 wayne1017 » 2007-11-24 12:12

这么好的帖子没人顶。没天理啊
skyline
帖子: 10
注册时间: 2007-11-24 11:12
送出感谢: 0
接收感谢: 0

#3

帖子 skyline » 2007-11-24 13:01

我用了你的方法,装上了,驱动但是还是打不开效果,ati的ccc也看到装上了,并且在ccc中已经识别出我的显卡(690G集成的X1250),但是用fglrxinfo反过来查看显卡信息却是
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (1.5 Mesa 6.5.2)

这是怎么回事?麻烦搂主解释一下下,谢谢
ilovedvd
帖子: 22
注册时间: 2007-10-11 10:08
送出感谢: 0
接收感谢: 0

#4

帖子 ilovedvd » 2007-11-24 13:02

我来顶你。新版驱动和开源驱动性能上差别明显吗?3D桌面有问题吗?
wayne1017
帖子: 46
注册时间: 2006-06-09 1:38
送出感谢: 0
接收感谢: 0

#5

帖子 wayne1017 » 2007-11-24 13:25

skyline 写了:我用了你的方法,装上了,驱动但是还是打不开效果,ati的ccc也看到装上了,并且在ccc中已经识别出我的显卡(690G集成的X1250),但是用fglrxinfo反过来查看显卡信息却是
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (1.5 Mesa 6.5.2)

这是怎么回事?麻烦搂主解释一下下,谢谢


我也遇到过你这个问题,当时就是因为没有修改xorg.conf文件导致的
你有没有修改xorg.conf文件,加入下面的东西呢?
Section "Module"
Load "dri"
Load "v4l"
Load "dbe"
Load "glx"
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

#注意此处的Device这个Secion里面的红色部分必须有,如果红色部分不一致,请修改
Section "Device"
Identifier "Generic Video Card"
Driver "fglrx"
BusID "PCI:1:0:0"
Option "AIGLX" "true"
EndSection
上次由 wayne1017 在 2007-11-24 13:31,总共编辑 1 次。
wayne1017
帖子: 46
注册时间: 2006-06-09 1:38
送出感谢: 0
接收感谢: 0

#6

帖子 wayne1017 » 2007-11-24 13:28

ilovedvd 写了:我来顶你。新版驱动和开源驱动性能上差别明显吗?3D桌面有问题吗?


3D桌面没有问题,性能上,在我的机器上挺好的,字体变清晰了。但是我也看到网上有人装了新驱动以后反而性能下降的。
但是新驱动有一个瑕疵就是有的时候,在3D效果的时候会出现卡的情况(出现的概率很小,不清楚具体原因)。而用XGL的时候,没有出现卡的情况。
skyline
帖子: 10
注册时间: 2007-11-24 11:12
送出感谢: 0
接收感谢: 0

#7

帖子 skyline » 2007-11-24 15:51

我已经按照你的帖子修改了xorg.conf文件,但还是打不开,点击打开特效后,先是大概20秒的白屏然后弹出一个框说不能打开桌面特效
skyline
帖子: 10
注册时间: 2007-11-24 11:12
送出感谢: 0
接收感谢: 0

#8

帖子 skyline » 2007-11-24 15:55

我的xorg.conf文件中Section "Module"下本来没有Load "v4l" Load "dbe" ,我添加进去了,还有Section "Device" 中的BusID 本来是"PCI:1:5:0",我改成了和你的一样"PCI:1:0:0",还添加了Option "AIGLX" "true"。BusID是都一样要改为PCI:1:0:0吗?
skyline
帖子: 10
注册时间: 2007-11-24 11:12
送出感谢: 0
接收感谢: 0

#9

帖子 skyline » 2007-11-24 16:07

在我的Section "Module“中还有一些你列出来的没有的东西,那些要不要都删掉?
lijzz
帖子: 196
注册时间: 2006-09-03 20:53
送出感谢: 0
接收感谢: 0

Re: T60本本ati X1400显卡Gutsy下成功安装ati 8.42.3最新驱动并成功开启compiz

#10

帖子 lijzz » 2007-11-24 16:22

wayne1017 写了:过程颇为曲折,但最终成功了。下面详细道来
首先我参照了这个帖子英文的http://ubuntuforums.org/showthread.php?t=593348
这个帖子TX有翻译的中文版:http://linuxdesktop.cn/2007/10/24/install-ati-8-42-3-driver-under-gutsy
但是我按照这种方法并没有成功,每次到了sudo m-a install fglrx-kernel这一步时就报错。
没办法,另辟蹊径,找到了这个帖子:http://www.mvpdream.org/blog/2007/10/ati-8423-driver-for-linux.html并最终成功了。但是这个网页里面说的方法不够详细且无法开启compiz,经过我对几个方法的综合,总结如下成功安装并成功开启compiz的方法

步骤如下:
第一步:下载驱动
把以下驱动下载到你要放置的地方,我是放在主目录下的:
http://www2.ati.com/drivers/linux/ati-driver-installer-8.42.3-x86.x86_64.run

第二步:移除旧驱动
假如之前你是用xgl的,请执行以下命令移除旧的fglrx驱动

代码: 全选

sudo apt-get remove xserver-xgl

然后到“系统”-“系统管理”-“受限驱动管理器” 处取消掉之前的驱动,或者也可以执行:

代码: 全选

sudo apt-get remove xorg-driver-fglrx

最后删除旧的fglrx软件包

代码: 全选

sudo rm -f /usr/src/fglrx-kernel*.deb

移除完毕后,就重新启动吧!
重启以后,就只能以低分辨率进入了桌面环境了。

第三步:开始安装驱动
首先杀掉Gnome桌面,输入命令:

代码: 全选

sudo /etc/init.d/gdm stop

再按下Ctrl+Alt+F1进入终端,并登录
我下载的驱动保存在主文件夹下的,那么就可以使用命令:

代码: 全选

sudo sh ati-driver-installer-8.42.3-x86.x86_64.run

随后就可以跟着显卡驱动向导来进行操作,一般都采用其默认设置就可以了。
输入命令重启:

代码: 全选

sudo reboot


第四步:修改xorg.conf文件,设置驱动
重启以后,这个时候还需要设置一下xorg.conf文件
输入命令:

代码: 全选

sudo gedit /etc/X11/xorg.conf

如果你的xorg.conf文件中没有下面的Section或者跟下面的这些Section不一样的话,请添加或者修改相应的Section:

Section "Module"
Load "dri"
Load "v4l"
Load "dbe"
Load "glx"

EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

#注意此处的Device这个Secion里面的红色部分必须有,如果红色部分不一致,请修改
Section "Device"
Identifier "Generic Video Card"
Driver "fglrx"
BusID "PCI:1:0:0"
Option "AIGLX" "true"
EndSection


第五步:重启并开启compiz
输入命令重启:

代码: 全选

sudo reboot

重启以后,进入桌面在终端输入以下命令检查驱动是否安装好:

代码: 全选

fglrxinfo

应该显示如下信息:
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon X1400
OpenGL version string: 2.0.6958 Release

输入如下命令检查:

代码: 全选

glxinfo | grep rendering

应该显示如下信息
direct rendering: Yes

如果上面两个命令都运行成功了,恭喜你,驱动已经装好了。
在“系统”-“首选项”-“外观”-“视觉效果”中点击特效就可以开启啦。
A卡的用户,大家尽情享受吧 :D



楼上的,装完后,看电影有什么不良反应没有,我原安装8.42.3在看电影时无法选择xv输出,你的怎样?说说看
ThinkPad T43 44U
1.5G X300

Gutsy
Compiz-fusion
skyline
帖子: 10
注册时间: 2007-11-24 11:12
送出感谢: 0
接收感谢: 0

#11

帖子 skyline » 2007-11-24 16:25

我的可以正常看电影,但是我打不开3d桌面特效,其他都正常,和原来一样
wayne1017
帖子: 46
注册时间: 2006-06-09 1:38
送出感谢: 0
接收感谢: 0

#12

帖子 wayne1017 » 2007-11-24 19:29

skyline 写了:我的xorg.conf文件中Section "Module"下本来没有Load "v4l" Load "dbe" ,我添加进去了,还有Section "Device" 中的BusID 本来是"PCI:1:5:0",我改成了和你的一样"PCI:1:0:0",还添加了Option "AIGLX" "true"。BusID是都一样要改为PCI:1:0:0吗?


busid不要改!就用你自己以前的。这个每个机器是不一样的。我那个xorg.conf文件里面只列出了需要添加的或者修改的,其他的你的xorg.conf文件里面的东西不要动。
wayne1017
帖子: 46
注册时间: 2006-06-09 1:38
送出感谢: 0
接收感谢: 0

Re: T60本本ati X1400显卡Gutsy下成功安装ati 8.42.3最新驱动并成功开启compiz

#13

帖子 wayne1017 » 2007-11-24 19:30

楼上的,装完后,看电影有什么不良反应没有,我原安装8.42.3在看电影时无法选择xv输出,你的怎样?说说看


我的看电影很正常,选xv输出视频。很流畅。
wayne1017
帖子: 46
注册时间: 2006-06-09 1:38
送出感谢: 0
接收感谢: 0

#14

帖子 wayne1017 » 2007-11-24 19:32

skyline 写了:在我的Section "Module“中还有一些你列出来的没有的东西,那些要不要都删掉?


在Module Section里面没有的东西就把它删掉。
不过,我强烈建议你先备份现有的xorg.conf文件。万一出问题了还可以恢复。
wayne1017
帖子: 46
注册时间: 2006-06-09 1:38
送出感谢: 0
接收感谢: 0

#15

帖子 wayne1017 » 2007-11-24 19:33

skyline 写了:我已经按照你的帖子修改了xorg.conf文件,但还是打不开,点击打开特效后,先是大概20秒的白屏然后弹出一个框说不能打开桌面特效


打开特效后白屏的问题我也碰到过,那个表明你的驱动没有装好。试着重新安装一下。
回复

回到 “桌面特效”