当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 【求助】我的ubuntu彻底完了,图形界面都进不入。[解决]
帖子发表于 : 2007-12-10 23:42 

注册: 2007-11-15 12:36
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
做梦都想试下3D桌面效果,但是实在天不从人愿,试了论坛上的n种方法还是开启不了(我的显卡是ATI X800驱动用的是官方的,也就是在受限制驱动那里安装的,身为一只菜鸟唉啊,说都说不清 :oops:
难忘第一次看到的桌面效果算是刚装完系统还没有装显卡驱动时,那黏人的窗口,呵呵初恋的味道。。之后不管是beryl还是compiz fusion装了都是什么都看不到。。晕,最惨是那个beryl明明那颗小红钻已经出来了,可是开启了beryl以后,桌面闪闪就回到了 gnome界面下 ,郁闷。。。
今天又看到一篇文章,突然良心发现,可能系统的显卡驱动太老??就在论坛上看一篇关于如何安装AIGLX的ATi驱动8.42.3的文章file:///D:/ati8.42.3.php.html
试了以下前面的方法:
第一步:移除旧驱动

假如之前你是用xgl的,请执行以下命令移除旧的fglrx驱动

sudo apt-get remove xserver-xgl

然后到“系统”-“系统管理”-“受限驱动管理器” 处取消掉之前的驱动,或者也可以执行:

sudo apt-get remove xorg-driver-fglrx

最后删除旧的fglrx软件包

sudo rm -f /usr/src/fglrx-kernel*.deb

将旧的fglrx模块加入黑名单

sudo gedit /etc/default/linux-restricted-modules-common

加入这么一行

DISABLED_MODULES=”fglrx”

或者你也可以移除这个linux-restricted-modules-*这个软件包(如果你有其他受限驱动,不要这么做)

移除完毕后,就重新启动吧!




可是重启后就进不入图形界面了,提示下面的错误
Failed to start the X server(your graphical interface).
It is likely that it is not set up correctly.
Would you like to view the X Server output to diagnose the problem?
<Yes> <No>

现在能够进入控制台,但是不能进入图形界面。谁能救救我啊。。


最后由 huang123 编辑于 2007-12-12 21:22,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 【求助】我的ubuntu彻底完了,图形界面都进不入。
帖子发表于 : 2007-12-11 8:46 

注册: 2007-09-19 13:48
帖子: 131
送出感谢: 0 次
接收感谢: 0 次
装好ati的官方驱动7.11没?
ati官方驱动(非开源)的安装配置(07/11/21),想用compiz的不推荐更新
http://forum.ubuntu.org.cn/viewtopic.php?t=26188


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-12-11 10:16 

注册: 2007-11-15 12:36
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
装好了驱动后好像根据提示卸载了。。。。。
不过现在什么都不重要,能够回到桌面就行,有没有好的解决方法啊???各位大哥。。。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-12-11 22:58 

注册: 2007-10-17 23:09
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
好像是没有显卡驱动吧
在命令行下sudo sh *.run(你的显卡驱动)试试


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-12-12 16:23 
头像

注册: 2007-07-02 20:53
帖子: 149
送出感谢: 0 次
接收感谢: 0 次
你可以试试
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install xorg-driver-fglrx
sudo depmod -a
如果你将旧的fglrx模块加入黑名单了
可以先sudo nano /etc/default/linux-restricted-modules-common
把DISABLED_MODULES=”fglrx”改成DISABLED_MODULES=””
然后startx试试
应该可以进入
实在不行就重装算了


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-12-12 20:06 

注册: 2007-11-15 12:36
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
恩是啊,我去试试啊,我是把fglrx模块加入黑名单了呵呵
先谢谢了啊两位。。 :D


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-12-12 20:09 

注册: 2007-11-15 12:36
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
都是因为烂学校算流量(超1G用了50块钱)我上次更新系统耗尽了棺材板差点没有钱聊q所以才搞得那么狼狈啊,再不行就重装咯。。。各位费心了。。。。下次装个7.10,目前还没有光盘。。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-12-13 11:22 

注册: 2007-11-15 12:36
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
lanif08 写道:
你可以试试
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install xorg-driver-fglrx
sudo depmod -a
如果你将旧的fglrx模块加入黑名单了
可以先sudo nano /etc/default/linux-restricted-modules-common
把DISABLED_MODULES=”fglrx”改成DISABLED_MODULES=””
然后startx试试
应该可以进入
实在不行就重装算了


久违的界面终于回来了,^_^非常感谢你啊。。真是我的救命恩人:lol: 。。无以为报,以后将好好向您学习。。。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-01-18 0:30 
头像

注册: 2006-12-23 13:46
帖子: 9203
地址: Azores Islands
送出感谢: 0 次
接收感谢: 1
ATI 显卡,黑名单中有R350和 R480

R480 对应有X800 x850
R350 对应有9800

intel的显卡,有965系列的x3100

基本上被判死刑了。 :cry: :cry:


_________________
no security measure is worth anything if an attacker has physical access to the machine


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译