当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : ubuntu7.10 在intel945GM 显卡下开效果
帖子发表于 : 2007-12-21 9:50 

注册: 2007-12-12 15:55
帖子: 27
送出感谢: 0 次
接收感谢: 0 次
我把ubuntu7.10安装到移动硬盘里了,刚安装完后还试过能开效果,不是3D的那种,就是正常的,中间的那个效果,最下面的是出现窗口果冻的那种都可以开启,之后我就一直没有开效果,就是选的第一项,什么效果都没有。

可是昨天晚上我准备开个效果玩玩,始终不能开启。很郁闷,我也试过从live CD里拷xorg.conf这文件也没有用。xorg.conf里面能认出我的显卡来。

前几天也没做什么。就用别人的机器启动过我的移动ubuntu。都挺好的。只是没有注意能不能开效果。

现在很迷茫。不知道从何入手。希望朋友们给点意见。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-12-21 16:05 

注册: 2007-12-12 15:55
帖子: 27
送出感谢: 0 次
接收感谢: 0 次
不是吧。。兄弟们,给点建议把。给点方向也行呀

这个帖子不能沉啊,中国不能亡啊,


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-12-21 16:08 
头像

注册: 2006-04-12 20:05
帖子: 8495
地址: 杭州
送出感谢: 0 次
接收感谢: 8
intel的显卡还打不开效果就是rp问题了 :lol:
建议先 dpkg-reconfigure xserver-xorg 试试


_________________
关注我的blog: ε==3


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-12-21 16:27 

注册: 2007-12-12 15:55
帖子: 27
送出感谢: 0 次
接收感谢: 0 次
http://forum.ubuntu.org.cn/viewtopic.php?t=92622

看过这个帖子我感觉还 xorg.conf的问题

代码:
在/etc/xorg.conf加入
Section "Device"
Identifier "Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller"
Driver "intel"
BusID "PCI:0:2:0"
Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"
Option "XAANoOffscreenPixmaps"
Option "UseFBDev"
Option "TripleBuffer" "true"
EndSection


我的xorg.conf只有
Section "Device"
Identifier "Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller"
Driver "intel"
BusID "PCI:0:2:0"


我记得我的xorg.conf不在/etc/下 应该是在/etc/X11/xorg.conf这下面

跟这个有关系吗?


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-12-21 23:27 

注册: 2007-12-12 15:55
帖子: 27
送出感谢: 0 次
接收感谢: 0 次
郁闷了 。刚才拿我的移动硬盘去我朋友那就可以开特效的。。郁闷。。在换到我的本上就开不了特效。

ubuntu是安装在移动硬盘里的。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-12-21 23:34 
头像

注册: 2007-10-18 13:50
帖子: 264
系统: Ubuntu 14.10
送出感谢: 0 次
接收感谢: 0 次
帮不上忙,我的是A卡,intel的集成芯片不了解。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-12-22 1:34 

注册: 2007-12-12 15:55
帖子: 27
送出感谢: 0 次
接收感谢: 0 次
现在问题升华了


david@david-laptop:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) 945GM 20061017 x86/MMX/SSE2
OpenGL version string: 1.3 Mesa 7.0.1

david@david-laptop:~$ glxinfo|grep direc
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
david@david-laptop:~$


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-12-22 1:37 

注册: 2007-12-12 15:55
帖子: 27
送出感谢: 0 次
接收感谢: 0 次
LIBGL_DEBUG=verbose


在哪里设置


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-12-22 2:01 
头像

注册: 2007-11-22 10:20
帖子: 3406
地址: 北京
送出感谢: 0 次
接收感谢: 1
我要关注这个帖子!
我重装之前也是glxinfo|grep render是no,没有特效,好多东西都有问题。
重装之后就好了──我觉得就是这个的问题。
好像说是LCD与系统不能通信……

我就是i945GM的集成显卡,一样会有这样的问题──我看见其他有人也有这样的问题,他也是最后没有解决。


_________________
lenovo Thinkpad R60i 0657 LHC
windowsXP……准备换回ubuntu了。

Twitter: @carbont


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-12-25 2:49 

注册: 2007-12-03 22:49
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
我的机子是神舟F530R, 也是Inter G945集显,昨天突然兴起,照着网上开启了compiz特效,除个别特效太卡外一切正常。我装的是64位的Ubuntu,其他都是默认设置。
刚查了下/etc/X11/下的xorg.conf 信息和楼主的一样,我的 glxinfo | grep rend 信息如下:
~$ glxinfo | grep rend
direct rendering: Yes
OpenGL renderer string: Mesa DRI Intel(R) 945GM 20061017

所以G945还是能跑特效的,楼主别急。实在不行还是重装吧(我是新手,没太好的意见了……)


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-12-25 3:07 
头像

注册: 2007-11-22 10:20
帖子: 3406
地址: 北京
送出感谢: 0 次
接收感谢: 1
我重装以后没有什么问题了。
lz最开始的问题是:没有装compiz setting……
不知道这个叫什么,因为我只用了CN99的源,5.2的compiz,比较老,新的那个好像设置软件的名字不一样的,你搜索一下论坛吧!

DDC没有连通的问题我也不知道怎么办,我重装后就没有问题了。

这个是i945GM的主板,显卡应该是GMA950的──相传这个显卡是支持ubuntu的显卡。

反正我现在特效什么的都没有问题。


_________________
lenovo Thinkpad R60i 0657 LHC
windowsXP……准备换回ubuntu了。

Twitter: @carbont


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-12-25 12:35 

注册: 2007-12-03 22:49
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
carbont 写道:
我重装以后没有什么问题了。
lz最开始的问题是:没有装compiz setting……

compiz setting....应该是:compiz settings manage
我是用默认源装的

代码:
 sudo apt-get install compizconfig-settings-manager


然后在 系统首选项Advanced Desktop Effects Settings 里选择特效就行了


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-01-04 15:33 

注册: 2007-03-13 8:57
帖子: 60
送出感谢: 0 次
接收感谢: 0 次
要装一些文件libgl1-mesa等等!全新安装的我不知道!我是升级上来的!
然后在开特效之前
先要用这个 
export LD_PRELOAD=/usr/lib/fglrx/libGL.so.1.2.xlibmesa
我的如果从“外观选项”中开特效肯定没有!所以我用会话来开!
自己在/usr/bin建一个文件把
export LD_PRELOAD=/usr/lib/fglrx/libGL.so.1.2.xlibmesa
compiz --replace
加入,然后 sudo chmod a+x 文件名
然后在会话中加入此文件应该就可以了!


_________________
HP Compaq Presario V3211TU
CPU类型 赛扬-M(Yonah-533)
内存大小 1G
显卡芯片 Intel GMA950
WLAN性能 802.11b/g(54Mbps)
网卡描述 100Mbps网卡
硬盘大小 80GB(5400转)


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2008-01-04 17:34 

注册: 2007-11-30 15:17
帖子: 686
地址: 福建
送出感谢: 0 次
接收感谢: 0 次
我的也只有这一段,现在用着3D
Section "Device"
Identifier "Intel Corporation 82915G/GV/910GL Integrated Graphics Controller"
Driver "intel"
BusID "PCI:0:2:0"
EndSection


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2008-01-06 15:22 

注册: 2007-03-13 8:57
帖子: 60
送出感谢: 0 次
接收感谢: 0 次
这可能与显卡的型号有关!我的是:
Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics
还有一个是与安装的方法!我的是升级上来的!全新安装的不知道!


_________________
HP Compaq Presario V3211TU
CPU类型 赛扬-M(Yonah-533)
内存大小 1G
显卡芯片 Intel GMA950
WLAN性能 802.11b/g(54Mbps)
网卡描述 100Mbps网卡
硬盘大小 80GB(5400转)


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译