有没有哪个版本的ati驱动解决了compiz下视频无图像的问题?

GnomeShell/Unity/Beryl/AiGLX/XGL/Compiz Fusion
回复
christie.cohen
帖子: 9
注册时间: 2007-08-22 23:16
送出感谢: 0
接收感谢: 0

有没有哪个版本的ati驱动解决了compiz下视频无图像的问题?

#1

帖子 christie.cohen » 2007-12-21 13:49

rt
mifly
帖子: 86
注册时间: 2006-09-05 20:44
来自: china
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 mifly » 2007-12-21 13:55

是不是mplayer的 output driver里面的video设置不对呀,你可以选择使用xv或者x11看看
christie.cohen
帖子: 9
注册时间: 2007-08-22 23:16
送出感谢: 0
接收感谢: 0

#3

帖子 christie.cohen » 2007-12-21 14:41

选择xv就是黑屏的

选X11是可以的
但是好像cpu占用率非常高,而且全屏很卡

gl和gl也可以
但是闪烁暴严重

PS 我显卡是 ati x300

你们没遇到么?
mifly
帖子: 86
注册时间: 2006-09-05 20:44
来自: china
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 mifly » 2007-12-21 14:47

我的ati 9550,用xv不行,用x11可以,但似乎播放rmvb的时候感觉效果不太好,有点类似闪烁或者图像中间断了那样。
不知其它网友呢?ati应该选择那个驱动??
头像
weive
帖子: 3235
注册时间: 2007-10-21 18:36
来自: 汕头/广东/中国
送出感谢: 2 次
接收感谢: 3 次

#5

帖子 weive » 2007-12-21 16:16

用开源驱动。ATI的驱动问题不少。再多等几年估计才会完美。不过那时候咱的显卡就是古董了。所以用8.37.6就OK,加个XGL。
老子的哲学是“”,庄子的哲学是“
人有一技在身,则逍遥游而无不为
头像
lanif08
帖子: 149
注册时间: 2007-07-02 20:53
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 lanif08 » 2007-12-21 16:32

视频无图像
用开源和闭源的驱动都没遇到过
christie.cohen
帖子: 9
注册时间: 2007-08-22 23:16
送出感谢: 0
接收感谢: 0

#7

帖子 christie.cohen » 2007-12-21 18:43

这个问题只有在开了compiz特效的情况下才出现
不开就不会出现的
mifly
帖子: 86
注册时间: 2006-09-05 20:44
来自: china
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 mifly » 2007-12-22 1:40

ati 9550 显卡,使用受限驱动,xv黑屏,x11可以用,效果还可以,在开启compiz使用过程中,xgl内存使用率高达45%,也就是有450m。
使用开源驱动,xv可以用了,开启compiz后,内存使用也没有那么多了。像我这个老显卡情况下,用开源驱动好很多
angele
帖子: 18
注册时间: 2007-08-16 16:29
送出感谢: 0
接收感谢: 0

#9

帖子 angele » 2007-12-22 11:51

强烈不建议用mplayer,换totem-xine吧,很少出现问题的
bodhi52
帖子: 36
注册时间: 2006-08-10 19:26
送出感谢: 0
接收感谢: 0

#10

帖子 bodhi52 » 2007-12-28 9:57

compiz 和 xv冲突的问题
解决方法可以是自己编译mplayer,打个patch,patch在这里:
http://smspillaz.googlepages.com/mplayrepatch.patch
我没有编译过,是从网上查的资料。哪个好心人能编译好,给放个安装包就好了。

目前的解决方法是,用mplayer,就把compiz关掉,不用mplayer,就打开compiz,哎,无奈之举。。。。

不知道ati的驱动啥时候才能好。。。。。

附个网页:http://www.chinalinuxpub.com/read.php?wid=2034
里面说的挺清楚的
ainux
帖子: 27
注册时间: 2006-06-06 14:14
送出感谢: 0
接收感谢: 0

#11

帖子 ainux » 2007-12-28 12:35

请试试在xorg.conf加上:

Section "Extensions"
Option "XVideo" "Enable"
EndSection
回复

回到 “桌面特效”