安装了ATI的7.12驱动 发生了奇怪的事情 并解决

GnomeShell/Unity/Beryl/AiGLX/XGL/Compiz Fusion
回复
头像
lititude
帖子: 36
注册时间: 2007-10-27 17:57
送出感谢: 0
接收感谢: 0
联系:

安装了ATI的7.12驱动 发生了奇怪的事情 并解决

#1

帖子 lititude » 2007-12-23 14:05

安装了7.12版驱动,准备开compiz,运行
$compiz --replace
提示在/usr/local/bin 找不到compiz
无法启动特效
重装了n遍源上的compiz都不行

我试着
sudo gedit /usr/bin/compiz
发现开头的信息是
COMPIZ_BIN_PATH="/usr/local/bin/" # For window decorators and compiz
PLUGIN_PATH="/usr/local/lib/compiz/"
GLXINFO="/usr/bin/glxinfo"
KWIN="/usr/bin/kwin"
METACITY="/usr/bin/metacity"
COMPIZ_NAME="compiz" # Final name for compiz (compiz.real)
通过对比软件包的安装信息
把这一段改成
COMPIZ_BIN_PATH="/usr/bin/" # For window decorators and compiz
PLUGIN_PATH="/usr/lib/compiz/"
GLXINFO="/usr/bin/glxinfo"
KWIN="/usr/bin/kwin"
METACITY="/usr/bin/metacity"
COMPIZ_NAME="compiz.real" # Final name for compiz (compiz.real)
然后compiz就能用了

装驱动的时候这个信息可能被改了
想知道有没有和我遇到一样情况的
头像
zhizunbao
帖子: 264
注册时间: 2007-10-18 13:50
系统: Ubuntu 14.10
送出感谢: 0
接收感谢: 0

#2

帖子 zhizunbao » 2007-12-23 16:33

对。我跟你一样。装驱动的时候有一个选择,compiz-manager是保持原样还是更新。
头像
lititude
帖子: 36
注册时间: 2007-10-27 17:57
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 lititude » 2007-12-23 18:09

我也遇到那个选项 我选了n
头像
Yume
帖子: 1015
注册时间: 2010-05-24 12:16
送出感谢: 0
接收感谢: 0

Re: 安装了ATI的7.12驱动 发生了奇怪的事情 并解决

#4

帖子 Yume » 2010-11-28 15:31

代码: 全选

COMPIZ_BIN_PATH="/usr/bin/" # For window decorators and compiz
PLUGIN_PATH="/usr/lib/compiz/" 
GLXINFO="/usr/bin/glxinfo"
KWIN="/usr/bin/kwin"
METACITY="/usr/bin/metacity"
COMPIZ_NAME="compiz.real" # Final name for compiz (compiz.real) 
我的一直是这样,怎么运行都启动不了啊,也不知道是什么问题...
:em21
头像
jarryson
帖子: 4002
注册时间: 2005-08-14 19:53
送出感谢: 1 次
接收感谢: 2 次
联系:

Re: 安装了ATI的7.12驱动 发生了奇怪的事情 并解决

#5

帖子 jarryson » 2010-11-28 16:28

介个和ATI驱动有毛线关系?
回复

回到 “桌面特效”